Every CVE Search/ Get API key

CVE-2018-12071

CodeIgniter Session Fixation Vulnerability

9.8 CriticalFix available

A Session Fixation issue exists in CodeIgniter before 3.1.9 because session.use_strict_mode in the Session Library was mishandled.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.50%Up 1.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

A Session Fixation issue exists in CodeIgniter before 3.1.9 because session.use_strict_mode in the Session Library was mishandled.

Record
CVE-2018-12071
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-384
Updated
2026-11-02
CVE List No score

A Session Fixation issue exists in CodeIgniter before 3.1.9 because session.use_strict_mode in the Session Library was mishandled.

Record
CVE-2018-12071
Updated
2026-11-02
EUVDEUVD-2022-3879 0.0

A Session Fixation issue exists in CodeIgniter before 3.1.9 because session.use_strict_mode in the Session Library was mishandled.

Record
EUVD-2022-3879
CVSS
0.0 NoneCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-g434-3q2j-hj4r 9.8

CodeIgniter Session Fixation Vulnerability

A Session Fixation issue exists in CodeIgniter before 3.1.10 because session.use_strict_mode in the Session Library was mishandled.

Record
GHSA-g434-3q2j-hj4r
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-384
Updated
2026-11-02
OSV 9.8

A Session Fixation issue exists in CodeIgniter before 3.1.9 because session.use_strict_mode in the Session Library was mishandled.

Record
CVE-2018-12071
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-g434-3q2j-hj4r 9.8

CodeIgniter Session Fixation Vulnerability

A Session Fixation issue exists in CodeIgniter before 3.1.10 because session.use_strict_mode in the Session Library was mishandled.

Record
GHSA-g434-3q2j-hj4r
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-384
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
codeigniter/framework
Packagist
before 3.1.10
3.1.10
codeigniter/framework
Packagist
before 3.1.10, plus listed versions
3.0.03.0.13.0.1rc3.0.1rc23.0.2
Show 17 moreShow less
3.0.33.0.43.0.53.0.63.0rc3.0rc23.0rc33.1.03.1.13.1.23.1.33.1.43.1.53.1.63.1.73.1.83.1.9
3.1.10

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-12071 is a critical vulnerability (CVSS 9.8) in Codeigniter, published June 17, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.50%, the 74th percentile. Fixed in codeigniter/framework 3.1.10.

References

MoveEnter Open