CVE-2018-12457
express-cart allows any user to create an admin user
expressCart before 1.1.6 allows remote attackers to create an admin user via a /admin/setup Referer header.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
expressCart before 1.1.6 allows remote attackers to create an admin user via a /admin/setup Referer header.
- Record
CVE-2018-12457- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.5 Medium
AV:N/AC:L/Au:S/C:P/I:P/A:P - Weakness
- CWE-732
- Updated
- 2026-11-02
CVE List No score
expressCart before 1.1.6 allows remote attackers to create an admin user via a /admin/setup Referer header.
- Record
CVE-2018-12457- Updated
- 2026-11-02
EUVDEUVD-2022-4201 No score
expressCart before 1.1.6 allows remote attackers to create an admin user via a /admin/setup Referer header.
- Record
EUVD-2022-4201- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-hr89-w7p6-pjmq
8.8
express-cart allows any user to create an admin user
Express-Cart before 1.1.6 allows remote attackers to create an admin user via an /admin/setup Referer header.
- Record
GHSA-hr89-w7p6-pjmq- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-732
- Updated
- 2026-11-02
OSV
8.8
expressCart before 1.1.6 allows remote attackers to create an admin user via a /admin/setup Referer header.
- Record
CVE-2018-12457- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-hr89-w7p6-pjmq
8.8
express-cart allows any user to create an admin user
Express-Cart before 1.1.6 allows remote attackers to create an admin user via an /admin/setup Referer header.
- Record
GHSA-hr89-w7p6-pjmq- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-732
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
express-cartnpm |
before 1.1.6 | 1.1.6 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-12457 is a high vulnerability (CVSS 8.8) in Expresscart Project Expresscart, published June 15, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.89%, the 79th percentile. Fixed in express-cart 1.1.6.
References
npmjs.com/package/express-cart?activeTab=versions
hackerone.com/reports/343626
github.com/mrvautin/expressCart/commit/baccaae9b0b72f00b10c5453ca00231340ad3e3b
nvd.nist.gov/vuln/detail/CVE-2018-12457
github.com/nodejs/security-wg/blob/main/vuln/npm/469.json
snyk.io/vuln/npm:express-cart:20180712
npmjs.com/advisories/730
github.com/advisories/GHSA-hr89-w7p6-pjmq
github.com/mrvautin/expressCart