Every CVE Search/ Get API key

CVE-2018-12495

The quoteblock function in markdown.c in libmarkdown.a in DISCOUNT 2.2.3a allows remote attackers...

5.5 MediumFix available

The quoteblock function in markdown.c in libmarkdown.a in DISCOUNT 2.2.3a allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted file.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.82%Up 0.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.5

The quoteblock function in markdown.c in libmarkdown.a in DISCOUNT 2.2.3a allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted file.

Record
CVE-2018-12495
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

The quoteblock function in markdown.c in libmarkdown.a in DISCOUNT 2.2.3a allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted file.

Record
CVE-2018-12495
Updated
2026-11-02
EUVDEUVD-2018-4465 No score

The quoteblock function in markdown.c in libmarkdown.a in DISCOUNT 2.2.3a allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted file.

Record
EUVD-2018-4465
Updated
2026-11-03
GitHub AdvisoriesGHSA-mvx5-vrw8-j3pj 5.5

The quoteblock function in markdown.c in libmarkdown.a in DISCOUNT 2.2.3a allows remote attackers...

The quoteblock function in markdown.c in libmarkdown.a in DISCOUNT 2.2.3a allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted file.

Record
GHSA-mvx5-vrw8-j3pj
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSV 5.5

The quoteblock function in markdown.c in libmarkdown.a in DISCOUNT 2.2.3a allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted file.

Record
CVE-2018-12495
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2018-12495 5.5

The quoteblock function in markdown.c in libmarkdown.a in DISCOUNT 2.2.3a allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted file.

Record
DEBIAN-CVE-2018-12495
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2018-12495 5.5

The quoteblock function in markdown.c in libmarkdown.a in DISCOUNT 2.2.3a allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted file.

Record
UBUNTU-CVE-2018-12495
CVSS 3.0
5.5 MediumCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2019-0020 No score

Updated discount packages fix security vulnerabilities

The __mkd_trim_line function in mkdio.c in libmarkdown.a in DISCOUNT 2.2.3a allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted file (CVE-2018-11468).

DISCOUNT through version 2.2.3a is vulnerable to a Heap-based buffer-overflow in the markdown.c:isfootnote() function. An attacker could exploit this to cause a denial of service (CVE-2018-11503).

DISCOUNT through version 2.2.3a is vulnerable to a Heap-based buffer-overflow in the markdown.c:islist() function. An attacker could exploit this to cause a denial of service (CVE-2018-11504).

The quoteblock function in markdown.c in libmarkdown.a in DISCOUNT 2.2.3a allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted file (CVE-2018-12495).

Record
MGASA-2019-0020
Updated
2026-11-02
OSVopenSUSE-SU-2019:0019-1 No score

Security update for discount

This update for discount to version 2.2.4 fixes the following issues:

Security issues fixed:

  • CVE-2018-11468: Fixed a heap-based buffer over-read in the __mkd_trim_line function from mkdio.c (boo#1094809)
  • CVE-2018-12495: Fixed a heap-based buffer over-read via a crafted file (boo#1098252)
Record
openSUSE-SU-2019:0019-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:10718-1 No score

discount-2.2.7-1.3 on GA media

These are all security issues fixed in the discount-2.2.7-1.3 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10718-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
discount
Debian:12
before 2.2.4-1
2.2.4-1
discount
Debian:13
before 2.2.4-1
2.2.4-1
discount
Debian:14
before 2.2.4-1
2.2.4-1
discount
Debian:8
before 2.1.7-1+deb8u1, plus listed versions
2.1.7-1
2.1.7-1+deb8u1
discount
Debian:9
before 2.2.2-1+deb9u1, plus listed versions
2.2.2-1
2.2.2-1+deb9u1
discount
Mageia:6
before 2.2.4-1.mga6
2.2.4-1.mga6
discount
Ubuntu:14.04:LTS
before 2.1.7-1+deb8u1build0.14.04.1, plus listed versions
2.1.6-22.1.7-1
2.1.7-1+deb8u1build0.14.04.1
discount
Ubuntu:16.04:LTS
All versions, plus listed versions
2.1.8-2
None known
discount
Ubuntu:18.04:LTS
All versions, plus listed versions
2.1.8-22.2.3b8-2
None known
discount
SUSE:Package Hub 15
before 2.2.4-bp150.3.3.1
2.2.4-bp150.3.3.1
discount
openSUSE:Leap 15.0
before 2.2.4-bp150.3.3.1
2.2.4-bp150.3.3.1
discount
openSUSE:Tumbleweed
before 2.2.7-1.3
2.2.7-1.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-12495 is a medium vulnerability (CVSS 5.5) in Discount Project Discount, published June 15, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.82%, the 78th percentile. Fixed in discount 2.2.4-1.

References

Show 10 moreShow less
MoveEnter Open