CVE-2018-12938
openslp-dfsg vulnerabilities
DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: CVE-2017-17833. Reason: This candidate is a duplicate of CVE-2017-17833. Notes: All CVE users should reference CVE-2017-17833 instead of this candidate. All references and descriptions in this candidate have been removed to prevent accidental usage
What each source reports
CVE List No score
DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: CVE-2017-17833. Reason: This candidate is a duplicate of CVE-2017-17833. Notes: All CVE users should reference CVE-2017-17833 instead of this candidate. All references and descriptions in this candidate have been removed to prevent accidental usage
- Record
CVE-2018-12938- Updated
- 2026-11-02
EUVDEUVD-2018-4891 No score
DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: CVE-2017-17833. Reason: This candidate is a duplicate of CVE-2017-17833. Notes: All CVE users should reference CVE-2017-17833 instead of this candidate. All references and descriptions in this candidate have been removed to prevent accidental usage
- Record
EUVD-2018-4891- Updated
- 2026-11-03
NVD No score
Rejected reason: DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: CVE-2017-17833. Reason: This candidate is a duplicate of CVE-2017-17833. Notes: All CVE users should reference CVE-2017-17833 instead of this candidate. All references and descriptions in this candidate have been removed to prevent accidental usage
- Record
CVE-2018-12938- Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-12938 No score
Rejected reason: DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: CVE-2017-17833. Reason: This candidate is a duplicate of CVE-2017-17833. Notes: All CVE users should reference CVE-2017-17833 instead of this candidate. All references and descriptions in this candidate have been removed to prevent accidental usage
- Record
UBUNTU-CVE-2018-12938- Updated
- 2026-11-02
OSVUSN-3708-1 No score
openslp-dfsg vulnerabilities
It was discovered that OpenSLP incorrectly handled certain memory operations. A remote attacker could use this issue to cause OpenSLP to crash, resulting in a denial of service, or possibly execute arbitrary code.
- Record
USN-3708-1- Updated
- 2026-11-02
Affected packages
| Package | Affected | Fixed |
|---|---|---|
openslp-dfsgUbuntu:14.04:LTS |
before 1.2.1-9ubuntu0.3, plus listed versions 1.2.1-91.2.1-9ubuntu0.2 |
1.2.1-9ubuntu0.3 |
openslp-dfsgUbuntu:16.04:LTS |
before 1.2.1-11ubuntu0.16.04.1, plus listed versions 1.2.1-10ubuntu11.2.1-11 |
1.2.1-11ubuntu0.16.04.1 |
openslp-dfsgUbuntu:14.04:LTS From an advisory covering 2 CVEs |
before 1.2.1-9ubuntu0.3, plus listed versions 1.2.1-91.2.1-9ubuntu0.2 |
1.2.1-9ubuntu0.3 |
openslp-dfsgUbuntu:16.04:LTS From an advisory covering 2 CVEs |
before 1.2.1-11ubuntu0.16.04.1, plus listed versions 1.2.1-10ubuntu11.2.1-11 |
1.2.1-11ubuntu0.16.04.1 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | OpenSLP 2.0.0 - Double-Free | 2018-07-03 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-12938 has been rejected by its source and should not be treated as a live vulnerability, published June 28, 2018. Public exploit code exists. Fixed in openslp-dfsg 1.2.1-9ubuntu0.3.