Every CVE Search/ Get API key

CVE-2018-1328

Cross-site Scripting in Apache Zeppelin

6.1 MediumFix available

CVE-2018-1328 is a medium vulnerability (CVSS 6.1) in Apache Zeppelin, published April 23, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 6.02%, the 93rd percentile. Fixed in org.apache.zeppelin:zeppelin 0.8.0.

Apache Zeppelin prior to 0.8.0 had a stored XSS issue via Note permissions. Issue reported by "Josna Joseph".

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

6.02%Up 3.0 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

Apache Zeppelin prior to 0.8.0 had a stored XSS issue via Note permissions. Issue reported by "Josna Joseph".

Record
CVE-2018-1328
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Apache Zeppelin prior to 0.8.0 had a stored XSS issue via Note permissions. Issue reported by "Josna Joseph".

Record
CVE-2018-1328
Updated
2026-11-02
EUVDEUVD-2019-0431 No score

Apache Zeppelin prior to 0.8.0 had a stored XSS issue via Note permissions. Issue reported by "Josna Joseph".

Record
EUVD-2019-0431
Updated
2026-11-03
GitHub AdvisoriesGHSA-r2v5-5vcr-h3vq 6.1

Cross-site Scripting in Apache Zeppelin

Apache Zeppelin prior to 0.8.0 had a stored XSS issue via Note permissions. Issue reported by "Josna Joseph".

Record
GHSA-r2v5-5vcr-h3vq
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

Apache Zeppelin prior to 0.8.0 had a stored XSS issue via Note permissions. Issue reported by "Josna Joseph".

Record
CVE-2018-1328
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-r2v5-5vcr-h3vq 6.1

Cross-site Scripting in Apache Zeppelin

Apache Zeppelin prior to 0.8.0 had a stored XSS issue via Note permissions. Issue reported by "Josna Joseph".

Record
GHSA-r2v5-5vcr-h3vq
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.zeppelin:zeppelin
Maven
before 0.8.0
0.8.0
org.apache.zeppelin:zeppelin
Maven
before 0.8.0, plus listed versions
0.5.0-incubating0.6.00.6.10.6.20.7.00.7.10.7.20.7.3
0.8.0

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

MoveEnter Open