Every CVE Search/ Get API key

CVE-2018-1332

Moderate severity vulnerability that affects org.apache.storm:storm-core

6.5 MediumFix available

CVE-2018-1332 is a medium vulnerability (CVSS 6.5) in Apache Storm, published June 5, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.41%, the 72nd percentile. Fixed in org.apache.storm:storm-core 1.1.3.

Apache Storm version 1.0.6 and earlier, 1.2.1 and earlier, and version 1.1.2 and earlier expose a vulnerability that could allow a user to impersonate another user when communicating with some Storm Daemons.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

1.41%Down 0.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.5

Apache Storm version 1.0.6 and earlier, 1.2.1 and earlier, and version 1.1.2 and earlier expose a vulnerability that could allow a user to impersonate another user when communicating with some Storm Daemons.

Record
CVE-2018-1332
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:N/I:P/A:N
Weakness
CWE-200
Updated
2026-11-02
CVE List No score

Apache Storm version 1.0.6 and earlier, 1.2.1 and earlier, and version 1.1.2 and earlier expose a vulnerability that could allow a user to impersonate another user when communicating with some Storm Daemons.

Record
CVE-2018-1332
Updated
2026-11-02
EUVDEUVD-2018-0656 No score

Apache Storm version 1.0.6 and earlier, 1.2.1 and earlier, and version 1.1.2 and earlier expose a vulnerability that could allow a user to impersonate another user when communicating with some Storm Daemons.

Record
EUVD-2018-0656
Updated
2026-11-03
GitHub AdvisoriesGHSA-q35p-chc6-7x57 6.5

Moderate severity vulnerability that affects org.apache.storm:storm-core

Apache Storm version 1.0.6 and earlier, 1.2.1 and earlier, and version 1.1.2 and earlier expose a vulnerability that could allow a user to impersonate another user when communicating with some Storm Daemons.

Record
GHSA-q35p-chc6-7x57
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-200
Updated
2026-11-02
OSV 6.5

Apache Storm version 1.0.6 and earlier, 1.2.1 and earlier, and version 1.1.2 and earlier expose a vulnerability that could allow a user to impersonate another user when communicating with some Storm Daemons.

Record
CVE-2018-1332
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVGHSA-q35p-chc6-7x57 6.5

Moderate severity vulnerability that affects org.apache.storm:storm-core

Apache Storm version 1.0.6 and earlier, 1.2.1 and earlier, and version 1.1.2 and earlier expose a vulnerability that could allow a user to impersonate another user when communicating with some Storm Daemons.

Record
GHSA-q35p-chc6-7x57
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-200
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.storm:storm-core
Maven
before 1.1.3
1.1.3
org.apache.storm:storm-core
Maven
1.2.0 up to 1.2.2
1.2.2
org.apache.storm:storm-core
Maven
before 1.1.3, plus listed versions
0.10.00.10.0-beta0.10.0-beta10.10.10.10.2
Show 17 moreShow less
0.9.1-incubating0.9.2-incubating0.9.30.9.40.9.50.9.60.9.71.0.01.0.11.0.21.0.31.0.41.0.51.0.61.1.01.1.11.1.2
1.1.3
org.apache.storm:storm-core
Maven
1.2.0 up to 1.2.2, plus listed versions
1.2.1
1.2.2

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

MoveEnter Open