Every CVE Search/ Get API key

CVE-2018-1334

Exposure of Sensitive Information to an Unauthorized Actor in Apache Spark

4.7 MediumFix available

In Apache Spark 1.0.0 to 2.1.2, 2.2.0 to 2.2.1, and 2.3.0, when using PySpark or SparkR, it's possible for a different local user to connect to the Spark application and impersonate the user running the Spark application.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
High
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

0.51%Down 0.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 4.7

In Apache Spark 1.0.0 to 2.1.2, 2.2.0 to 2.2.1, and 2.3.0, when using PySpark or SparkR, it's possible for a different local user to connect to the Spark application and impersonate the user running the Spark application.

Record
CVE-2018-1334
CVSS 3.0
4.7 MediumCVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
1.9 LowAV:L/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-200
Updated
2026-11-02
CVE List No score

In Apache Spark 1.0.0 to 2.1.2, 2.2.0 to 2.2.1, and 2.3.0, when using PySpark or SparkR, it's possible for a different local user to connect to the Spark application and impersonate the user running the Spark application.

Record
CVE-2018-1334
Updated
2026-11-02
EUVDEUVD-2018-0127 No score

In Apache Spark 1.0.0 to 2.1.2, 2.2.0 to 2.2.1, and 2.3.0, when using PySpark or SparkR, it's possible for a different local user to connect to the Spark application and impersonate the user running the Spark application.

Record
EUVD-2018-0127
Updated
2026-11-03
GitHub AdvisoriesGHSA-6mqq-8r44-vmjc 6.0

Exposure of Sensitive Information to an Unauthorized Actor in Apache Spark

In Apache Spark 1.0.0 to 2.1.2, 2.2.0 to 2.2.1, and 2.3.0, when using PySpark or SparkR, it's possible for a different local user to connect to the Spark application and impersonate the user running the Spark application.

Record
GHSA-6mqq-8r44-vmjc
CVSS 4.0
6.0 MediumCVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS 3.0
4.7 MediumCVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-200
Updated
2026-11-02
OSV 4.7

In Apache Spark 1.0.0 to 2.1.2, 2.2.0 to 2.2.1, and 2.3.0, when using PySpark or SparkR, it's possible for a different local user to connect to the Spark application and impersonate the user running the Spark application.

Record
CVE-2018-1334
CVSS 3.0
4.7 MediumCVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVGHSA-6mqq-8r44-vmjc 6.0

Exposure of Sensitive Information to an Unauthorized Actor in Apache Spark

In Apache Spark 1.0.0 to 2.1.2, 2.2.0 to 2.2.1, and 2.3.0, when using PySpark or SparkR, it's possible for a different local user to connect to the Spark application and impersonate the user running the Spark application.

Record
GHSA-6mqq-8r44-vmjc
CVSS 4.0
6.0 MediumCVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS 3.0
4.7 MediumCVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-200
Updated
2026-11-02
OSVPYSEC-2018-25 No score

In Apache Spark 1.0.0 to 2.1.2, 2.2.0 to 2.2.1, and 2.3.0, when using PySpark or SparkR, it's possible for a different local user to connect to the Spark application and impersonate the user running the Spark application.

Record
PYSEC-2018-25
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.spark:spark-core_2.10
Maven
1.0.0 up to 2.1.3
2.1.3
org.apache.spark:spark-core_2.10
Maven
2.2.0 up to 2.2.2
2.2.2
org.apache.spark:spark-core_2.11
Maven
1.0.0 up to 2.1.3
2.1.3
org.apache.spark:spark-core_2.11
Maven
2.2.0 up to 2.2.2
2.2.2
org.apache.spark:spark-core_2.11
Maven
2.3.0 to 2.3.0
2.3.1
pyspark
PyPI
2.2.0 up to 2.2.2
2.2.2
pyspark
PyPI
before 2.1.3
2.1.3
org.apache.spark:spark-core_2.10
Maven
1.0.0 up to 2.1.3, plus listed versions
1.0.11.0.21.1.01.1.11.2.0
Show 20 moreShow less
1.2.11.2.21.3.01.3.11.4.01.4.11.5.01.5.11.5.21.6.01.6.11.6.21.6.32.0.02.0.0-preview2.0.12.0.22.1.02.1.12.1.2
2.1.3
org.apache.spark:spark-core_2.10
Maven
2.2.0 up to 2.2.2, plus listed versions
2.2.1
2.2.2
org.apache.spark:spark-core_2.11
Maven
1.0.0 up to 2.1.3, plus listed versions
1.2.01.2.11.2.21.3.01.3.1
Show 16 moreShow less
1.4.01.4.11.5.01.5.11.5.21.6.01.6.11.6.21.6.32.0.02.0.0-preview2.0.12.0.22.1.02.1.12.1.2
2.1.3
Show 5 moreShow less
Affected packages
PackageAffectedFixed
org.apache.spark:spark-core_2.11
Maven
2.2.0 up to 2.2.2, plus listed versions
2.2.1
2.2.2
org.apache.spark:spark-core_2.11
Maven
2.3.0 up to 2.3.1
2.3.1
pyspark
PyPI
2.2.0 up to 2.2.2, plus listed versions
2.2.1
2.2.2
pyspark
PyPI
before 2.1.3, plus listed versions
2.1.12.1.2
2.1.3
pyspark
PyPI
2.2.0 up to 2.2.2, before 2.1.3, plus listed versions
2.1.12.1.22.2.1
2.2.22.1.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-1334 is a medium vulnerability (CVSS 4.7) in Apache Spark, published July 12, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.51%, the 43rd percentile. Fixed in org.apache.spark:spark-core_2.10 2.1.3.

References

MoveEnter Open