Every CVE Search/ Get API key

CVE-2018-14055

ZNC before 1.7.1-rc1 does not properly validate untrusted lines coming from the network, allowing...

6.5 MediumFix available

ZNC before 1.7.1-rc1 does not properly validate untrusted lines coming from the network, allowing a non-admin user to escalate his privilege and inject rogue values into znc.conf.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

1.46%Up 0.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.5

ZNC before 1.7.1-rc1 does not properly validate untrusted lines coming from the network, allowing a non-admin user to escalate his privilege and inject rogue values into znc.conf.

Record
CVE-2018-14055
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:N/I:P/A:N
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

ZNC before 1.7.1-rc1 does not properly validate untrusted lines coming from the network, allowing a non-admin user to escalate his privilege and inject rogue values into znc.conf.

Record
CVE-2018-14055
Updated
2026-11-02
EUVDEUVD-2018-5981 No score

ZNC before 1.7.1-rc1 does not properly validate untrusted lines coming from the network, allowing a non-admin user to escalate his privilege and inject rogue values into znc.conf.

Record
EUVD-2018-5981
Updated
2026-11-03
GitHub AdvisoriesGHSA-jwph-8hwh-5w78 6.5

ZNC before 1.7.1-rc1 does not properly validate untrusted lines coming from the network, allowing...

ZNC before 1.7.1-rc1 does not properly validate untrusted lines coming from the network, allowing a non-admin user to escalate his privilege and inject rogue values into znc.conf.

Record
GHSA-jwph-8hwh-5w78
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-20
Updated
2026-11-02
OSVALPINE-CVE-2018-14055 6.5

ZNC before 1.7.1-rc1 does not properly validate untrusted lines coming from the network, allowing a non-admin user to escalate his privilege and inject rogue values into znc.conf.

Record
ALPINE-CVE-2018-14055
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSV 6.5

ZNC before 1.7.1-rc1 does not properly validate untrusted lines coming from the network, allowing a non-admin user to escalate his privilege and inject rogue values into znc.conf.

Record
CVE-2018-14055
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
Show 4 moreShow less
OSVDEBIAN-CVE-2018-14055 6.5

ZNC before 1.7.1-rc1 does not properly validate untrusted lines coming from the network, allowing a non-admin user to escalate his privilege and inject rogue values into znc.conf.

Record
DEBIAN-CVE-2018-14055
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2018-14055 6.5

ZNC before 1.7.1-rc1 does not properly validate untrusted lines coming from the network, allowing a non-admin user to escalate his privilege and inject rogue values into znc.conf.

Record
UBUNTU-CVE-2018-14055
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVMGASA-2019-0262 No score

Updated znc packages fix security vulnerabilities

Jeriko One discovered two vulnerabilities in the ZNC IRC bouncer which could result in privilege escalation or denial of service (CVE-2018-14055, CVE-2018-14056).

Two vulnerabilities were discovered in the ZNC IRC bouncer which could result in remote code execution (CVE-2019-12816) or denial of service via invalid encoding (CVE-2019-9917).

Record
MGASA-2019-0262
Updated
2026-11-02
OSVopenSUSE-SU-2024:11542-1 No score

znc-1.8.2-1.11 on GA media

These are all security issues fixed in the znc-1.8.2-1.11 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11542-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
znc
Alpine:v3.5
before 1.7.1-r0
1.7.1-r0
znc
Alpine:v3.6
before 1.7.1-r0
1.7.1-r0
znc
Alpine:v3.7
before 1.7.1-r0
1.7.1-r0
znc
Alpine:v3.8
before 1.7.1-r0
1.7.1-r0
znc
Debian:12
before 1.7.1-1
1.7.1-1
znc
Debian:13
before 1.7.1-1
1.7.1-1
znc
Debian:14
before 1.7.1-1
1.7.1-1
znc
Debian:8
From an advisory covering 2 CVEs
before 1.4-2+deb8u1, plus listed versions
1.4-2
1.4-2+deb8u1
znc
Debian:9
From an advisory covering 2 CVEs
before 1.6.5-1+deb9u1, plus listed versions
1.6.5-1
1.6.5-1+deb9u1
znc
Mageia:6
From an advisory covering 4 CVEs
before 1.7.4-1.mga6
1.7.4-1.mga6
Show 5 moreShow less
Affected packages
PackageAffectedFixed
znc
Mageia:7
From an advisory covering 4 CVEs
before 1.7.4-1.mga7
1.7.4-1.mga7
znc
Ubuntu:14.04:LTS
before 1.2-3ubuntu0.1, plus listed versions
1.0-51.0-5build11.2-11.2-21.2-31.2-3build1
1.2-3ubuntu0.1
znc
Ubuntu:16.04:LTS
before 1.6.3-1ubuntu0.1, plus listed versions
1.6.1-11.6.1-1build11.6.1-21.6.2-11.6.2-21.6.2-2build11.6.3-1
1.6.3-1ubuntu0.1
znc
Ubuntu:18.04:LTS
before 1.6.6-1ubuntu0.1, plus listed versions
1.6.5-2build21.6.5-2build31.6.5-2build41.6.5-2build51.6.6-1
1.6.6-1ubuntu0.1
znc
openSUSE:Tumbleweed
From an advisory covering 5 CVEs
before 1.8.2-1.11
1.8.2-1.11

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-14055 is a medium vulnerability (CVSS 6.5) in Znc, published July 15, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.46%, the 73rd percentile. Fixed in znc 1.7.1-r0.

References

Show 12 moreShow less
MoveEnter Open