CVE-2018-14058
Pimcore SQLi Vulnerability
Pimcore before 5.3.0 allows SQL Injection via the REST web service API.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.5
Pimcore before 5.3.0 allows SQL Injection via the REST web service API.
- Record
CVE-2018-14058- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:P/I:N/A:N - Weakness
- CWE-89
- Updated
- 2026-11-02
CVE List No score
Pimcore before 5.3.0 allows SQL Injection via the REST web service API.
- Record
CVE-2018-14058- Updated
- 2026-11-02
EUVDEUVD-2022-4879 No score
Pimcore before 5.3.0 allows SQL Injection via the REST web service API.
- Record
EUVD-2022-4879- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-q4hw-c66h-4xqc
6.5
Pimcore SQLi Vulnerability
Pimcore before 5.3.0 allows SQL Injection via the REST web service API.
- Record
GHSA-q4hw-c66h-4xqc- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-89
- Updated
- 2026-11-02
OSV
6.5
Pimcore before 5.3.0 allows SQL Injection via the REST web service API.
- Record
CVE-2018-14058- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVGHSA-q4hw-c66h-4xqc
6.5
Pimcore SQLi Vulnerability
Pimcore before 5.3.0 allows SQL Injection via the REST web service API.
- Record
GHSA-q4hw-c66h-4xqc- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-89
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pimcore/pimcorePackagist |
through 5.2.3 | 5.3.0 |
pimcore/pimcorePackagist |
before 5.3.0, plus listed versions 2.2.02.2.12.2.22.3.03.0.0 Show 43 moreShow less3.0.13.0.23.0.33.0.43.0.53.0.63.1.03.1.14.0.04.0.14.1.04.1.14.1.24.1.34.2.04.3.04.3.14.4.04.4.14.4.24.4.34.5.04.6.04.6.14.6.24.6.34.6.44.6.5v5.0.0v5.0.0-RCv5.0.1v5.0.2v5.0.3v5.0.4v5.1.0v5.1.0-alphav5.1.1v5.1.2v5.1.3v5.2.0v5.2.1v5.2.2v5.2.3 |
5.3.0 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | Pimcore 5.2.3 - SQL Injection / Cross-Site Scripting / Cross-Site Request Forgery | 2018-08-16 |
| Metasploit | Pimcore Gather Credentials via SQL Injection | 2018-08-13 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, Metasploit, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-14058 is a medium vulnerability (CVSS 6.5) in Pimcore, published August 17, 2018. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 28.6%, the 98th percentile. Fixed in pimcore/pimcore 5.3.0.
References
seclists.org/fulldisclosure/2018/Aug/13
packetstormsecurity.com/files/148954/Pimcore-5.2.3-CSRF-Cross-Site-Scripting-SQL-Injection.html
sec-consult.com/en/blog/advisories/sql-injection-xss-csrf-vulnerabilities-in-pimcore-software
exploit-db.com/exploits/45208
nvd.nist.gov/vuln/detail/CVE-2018-14058
github.com/advisories/GHSA-q4hw-c66h-4xqc