CVE-2018-14073
libsixel 1.8.1 has a memory leak in sixel_allocator_new in allocator.c.
libsixel 1.8.1 has a memory leak in sixel_allocator_new in allocator.c.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
libsixel 1.8.1 has a memory leak in sixel_allocator_new in allocator.c.
- Record
CVE-2018-14073- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-772
- Updated
- 2026-11-02
CVE List No score
libsixel 1.8.1 has a memory leak in sixel_allocator_new in allocator.c.
- Record
CVE-2018-14073- Updated
- 2026-11-02
EUVDEUVD-2018-5995 No score
libsixel 1.8.1 has a memory leak in sixel_allocator_new in allocator.c.
- Record
EUVD-2018-5995- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6pc5-jfvj-857m
7.5
libsixel 1.8.1 has a memory leak in sixel_allocator_new in allocator.c.
libsixel 1.8.1 has a memory leak in sixel_allocator_new in allocator.c.
- Record
GHSA-6pc5-jfvj-857m- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-772
- Updated
- 2026-11-02
OSV
7.5
libsixel 1.8.1 has a memory leak in sixel_allocator_new in allocator.c.
- Record
CVE-2018-14073- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-14073
7.5
libsixel 1.8.1 has a memory leak in sixel_allocator_new in allocator.c.
- Record
DEBIAN-CVE-2018-14073- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-14073
7.5
libsixel 1.8.1 has a memory leak in sixel_allocator_new in allocator.c.
- Record
UBUNTU-CVE-2018-14073- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libsixelDebian:12 |
before 1.8.2-1 | 1.8.2-1 |
libsixelDebian:13 |
before 1.8.2-1 | 1.8.2-1 |
libsixelDebian:14 |
before 1.8.2-1 | 1.8.2-1 |
libsixelUbuntu:16.04:LTS |
All versions, plus listed versions 1.4.2-11.5.2-2 |
None known |
libsixelUbuntu:18.04:LTS |
All versions, plus listed versions 1.5.2-21.7.3-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-14073 is a high vulnerability (CVSS 7.5) in Saitoha Libsixel, published July 15, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.44%, the 73rd percentile. Fixed in libsixel 1.8.2-1.