CVE-2018-16336
Exiv2::Internal::PngChunk::parseTXTChunk in Exiv2 v0.26 allows remote attackers to cause a denial...
Exiv2::Internal::PngChunk::parseTXTChunk in Exiv2 v0.26 allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted image file, a different vulnerability than CVE-2018-10999.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
6.5
Exiv2::Internal::PngChunk::parseTXTChunk in Exiv2 v0.26 allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted image file, a different vulnerability than CVE-2018-10999.
- Record
CVE-2018-16336- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-125
- Updated
- 2026-11-02
CVE List No score
Exiv2::Internal::PngChunk::parseTXTChunk in Exiv2 v0.26 allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted image file, a different vulnerability than CVE-2018-10999.
- Record
CVE-2018-16336- Updated
- 2026-11-02
EUVDEUVD-2018-0060 No score
Exiv2::Internal::PngChunk::parseTXTChunk in Exiv2 v0.26 allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted image file, a different vulnerability than CVE-2018-10999.
- Record
EUVD-2018-0060- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-f8wg-6gh7-2p7p
6.5
Exiv2::Internal::PngChunk::parseTXTChunk in Exiv2 v0.26 allows remote attackers to cause a denial...
Exiv2::Internal::PngChunk::parseTXTChunk in Exiv2 v0.26 allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted image file, a different vulnerability than CVE-2018-10999.
- Record
GHSA-f8wg-6gh7-2p7p- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-125
- Updated
- 2026-11-02
OSV
6.5
Exiv2::Internal::PngChunk::parseTXTChunk in Exiv2 v0.26 allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted image file, a different vulnerability than CVE-2018-10999.
- Record
CVE-2018-16336- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-16336
6.5
Exiv2::Internal::PngChunk::parseTXTChunk in Exiv2 v0.26 allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted image file, a different vulnerability than CVE-2018-10999.
- Record
DEBIAN-CVE-2018-16336- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVPYSEC-2018-135
6.5
Exiv2::Internal::PngChunk::parseTXTChunk in Exiv2 v0.26 allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted image file, a different vulnerability than CVE-2018-10999.
- Record
PYSEC-2018-135- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-16336
6.5
Exiv2::Internal::PngChunk::parseTXTChunk in Exiv2 v0.26 allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted image file, a different vulnerability than CVE-2018-10999.
- Record
UBUNTU-CVE-2018-16336- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUSN-3852-1 No score
exiv2 vulnerabilities
It was discovered that Exiv2 incorrectly handled certain files. An attacker could possibly use this issue to cause a denial of service. CVE-2017-9239 only affected Ubuntu 14.04 LTS and Ubuntu 16.04 LTS. (CVE-2017-11591, CVE-2017-11683, CVE-2017-14859, CVE-2017-14862, CVE-2017-14864, CVE-2017-17669, CVE-2017-9239, CVE-2018-16336, CVE-2018-1758)
- Record
USN-3852-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
exiv2Debian:12 |
before 0.27.2-6 | 0.27.2-6 |
exiv2Debian:13 |
before 0.27.2-6 | 0.27.2-6 |
exiv2Debian:14 |
before 0.27.2-6 | 0.27.2-6 |
exiv2Debian:8 |
before 0.24-4.1+deb8u2, plus listed versions 0.24-4.10.24-4.1+deb8u1 |
0.24-4.1+deb8u2 |
exiv2Ubuntu:14.04:LTS |
before 0.23-1ubuntu2.2, plus listed versions 0.23-1ubuntu10.23-1ubuntu20.23-1ubuntu2.1 |
0.23-1ubuntu2.2 |
exiv2Ubuntu:16.04:LTS |
before 0.25-2.1ubuntu16.04.3, plus listed versions 0.25-1ubuntu10.25-2.10.25-2.1ubuntu16.04.10.25-2.1ubuntu16.04.2 |
0.25-2.1ubuntu16.04.3 |
exiv2Ubuntu:18.04:LTS |
before 0.25-3.1ubuntu0.18.04.2, plus listed versions 0.25-3.10.25-3.1ubuntu0.18.04.1 |
0.25-3.1ubuntu0.18.04.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| affected, aliases, references | EUVD | |
| first indexed | OSV | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-16336 is a medium vulnerability (CVSS 6.5) in Exiv2, published September 1, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.73%, the 86th percentile. Fixed in exiv2 0.27.2-6.
References
github.com/Exiv2/exiv2/issues/400
usn.ubuntu.com/3852-1
lists.debian.org/debian-lts-announce/2018/10/msg00012.html
nvd.nist.gov/vuln/detail/CVE-2018-16336
github.com/advisories/GHSA-f8wg-6gh7-2p7p
security-tracker.debian.org/tracker/CVE-2018-16336
Show 11 moreShow less
ubuntu.com/security/CVE-2018-16336
ubuntu.com/security/notices/USN-3852-1
cve.org/CVERecord?id=CVE-2018-16336
ubuntu.com/security/CVE-2017-9239
ubuntu.com/security/CVE-2017-11591
ubuntu.com/security/CVE-2017-11683
ubuntu.com/security/CVE-2017-14859
ubuntu.com/security/CVE-2017-14862
ubuntu.com/security/CVE-2017-14864
ubuntu.com/security/CVE-2017-17669
ubuntu.com/security/CVE-2018-17581