CVE-2018-16489
Prototype Pollution in just-extend
A prototype pollution vulnerability was found in just-extend <4.0.0 that allows attack to inject properties onto Object.prototype through its functions.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
A prototype pollution vulnerability was found in just-extend <4.0.0 that allows attack to inject properties onto Object.prototype through its functions.
- Record
CVE-2018-16489- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-400, CWE-74
- Updated
- 2026-11-02
CVE List No score
A prototype pollution vulnerability was found in just-extend <4.0.0 that allows attack to inject properties onto Object.prototype through its functions.
- Record
CVE-2018-16489- Weakness
- CWE-400
- Updated
- 2026-11-02
EUVDEUVD-2019-0238 No score
A prototype pollution vulnerability was found in just-extend <4.0.0 that allows attack to inject properties onto Object.prototype through its functions.
- Record
EUVD-2019-0238- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-675m-85rw-j3w4
9.8
Prototype Pollution in just-extend
Versions of just-extend before 4.0.0 are vulnerable to prototype pollution. Provided certain input just-extend can add or modify properties of the Object prototype. These properties will be present on all objects.
Recommendation
Update to version 4.0.0 or later.
- Record
GHSA-675m-85rw-j3w4- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-400, CWE-1321
- Updated
- 2026-11-02
OSVGHSA-675m-85rw-j3w4
9.8
Prototype Pollution in just-extend
Versions of just-extend before 4.0.0 are vulnerable to prototype pollution. Provided certain input just-extend can add or modify properties of the Object prototype. These properties will be present on all objects.
Recommendation
Update to version 4.0.0 or later.
- Record
GHSA-675m-85rw-j3w4- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-1321, CWE-400
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
just-extendnpm |
before 4.0.0 | 4.0.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-16489 is a critical vulnerability (CVSS 9.8) in Hackerone Just-extend, published February 1, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.84%, the 78th percentile. Fixed in just-extend 4.0.0.