Every CVE Search/ Get API key

CVE-2018-16742

An issue was discovered in mgetty before 1.2.1. In contrib/scrts.c, a stack-based buffer overflow...

7.8 HighFix available

An issue was discovered in mgetty before 1.2.1. In contrib/scrts.c, a stack-based buffer overflow can be triggered via a command-line parameter.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.45%Unchanged since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.8

An issue was discovered in mgetty before 1.2.1. In contrib/scrts.c, a stack-based buffer overflow can be triggered via a command-line parameter.

Record
CVE-2018-16742
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
4.6 MediumAV:L/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

An issue was discovered in mgetty before 1.2.1. In contrib/scrts.c, a stack-based buffer overflow can be triggered via a command-line parameter.

Record
CVE-2018-16742
Updated
2026-11-02
EUVDEUVD-2018-8542 No score

An issue was discovered in mgetty before 1.2.1. In contrib/scrts.c, a stack-based buffer overflow can be triggered via a command-line parameter.

Record
EUVD-2018-8542
Updated
2026-11-03
GitHub AdvisoriesGHSA-4qch-qm87-8j72 7.8

An issue was discovered in mgetty before 1.2.1. In contrib/scrts.c, a stack-based buffer overflow...

An issue was discovered in mgetty before 1.2.1. In contrib/scrts.c, a stack-based buffer overflow can be triggered via a command-line parameter.

Record
GHSA-4qch-qm87-8j72
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-787
Updated
2026-11-02
OSV 7.8

An issue was discovered in mgetty before 1.2.1. In contrib/scrts.c, a stack-based buffer overflow can be triggered via a command-line parameter.

Record
CVE-2018-16742
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2018-16742 7.8

An issue was discovered in mgetty before 1.2.1. In contrib/scrts.c, a stack-based buffer overflow can be triggered via a command-line parameter.

Record
DEBIAN-CVE-2018-16742
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 6 moreShow less
OSVUBUNTU-CVE-2018-16742 7.8

An issue was discovered in mgetty before 1.2.1. In contrib/scrts.c, a stack-based buffer overflow can be triggered via a command-line parameter.

Record
UBUNTU-CVE-2018-16742
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2018-0402 No score

Updated mgetty packages fix security vulnerabilities

Updated mgetty packages fix security vulnerabilities:

The function do_activate() did not properly sanitize shell metacharacters to prevent command injection (CVE-2018-16741).

Stack-based buffer overflow that could have been triggered via a command-line parameter (CVE-2018-16742).

The command-line parameter username wsa passed unsanitized to strcpy(), which could have caused a stack-based buffer overflow (CVE-2018-16743).

The mail_to parameter was not sanitized, leading to command injection if untrusted input reached reach it (CVE-2018-16744).

The mail_to parameter was not sanitized, leading to a buffer overflow if long untrusted input reached it (CVE-2018-16745).

Record
MGASA-2018-0402
Updated
2026-11-02
OSVopenSUSE-SU-2024:11047-1 No score

g3utils-1.2.1-6.2 on GA media

These are all security issues fixed in the g3utils-1.2.1-6.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11047-1
Updated
2026-11-02
OSVSUSE-SU-2018:2850-1 No score

Security update for mgetty

This update for mgetty fixes the following issues:

  • CVE-2018-16741: The function do_activate() did not properly sanitize shell metacharacters to prevent command injection (bsc#1108752)
  • CVE-2018-16745: The mail_to parameter was not sanitized, leading to a buffer overflow if long untrusted input reached it (bsc#1108756)
  • CVE-2018-16744: The mail_to parameter was not sanitized, leading to command injection if untrusted input reached reach it (bsc#1108757)
  • CVE-2018-16742: Prevent stack-based buffer overflow that could have been triggered via a command-line parameter (bsc#1108762)
  • CVE-2018-16743: The command-line parameter username wsa passed unsanitized to strcpy(), which could have caused a stack-based buffer overflow (bsc#1108761)
Record
SUSE-SU-2018:2850-1
Updated
2026-11-02
OSVSUSE-SU-2018:2894-1 No score

Security update for mgetty

This update for mgetty fixes the following issues:

  • CVE-2018-16741: The function do_activate() did not properly sanitize shell metacharacters to prevent command injection (bsc#1108752).
  • CVE-2018-16745: The mail_to parameter was not sanitized, leading to a buffer overflow if long untrusted input reached it (bsc#1108756).
  • CVE-2018-16744: The mail_to parameter was not sanitized, leading to command injection if untrusted input reached reach it (bsc#1108757).
  • CVE-2018-16742: Prevent stack-based buffer overflow that could have been triggered via a command-line parameter (bsc#1108762).
  • CVE-2018-16743: The command-line parameter username wsa passed unsanitized to strcpy(), which could have caused a stack-based buffer overflow (bsc#1108761).
Record
SUSE-SU-2018:2894-1
Updated
2026-11-02
OSVSUSE-SU-2018:2979-1 No score

Security update for mgetty

This update for mgetty fixes the following security issues:

  • CVE-2018-16741: The function do_activate() did not properly sanitize shell metacharacters to prevent command injection (bsc#1108752)
  • CVE-2018-16745: The mail_to parameter was not sanitized, leading to a buffer overflow if long untrusted input reached it (bsc#1108756)
  • CVE-2018-16744: The mail_to parameter was not sanitized, leading to command injection if untrusted input reached reach it (bsc#1108757)
  • CVE-2018-16742: Prevent stack-based buffer overflow that could have been triggered via a command-line parameter (bsc#1108762)
  • CVE-2018-16743: The command-line parameter username wsa passed unsanitized to strcpy(), which could have caused a stack-based buffer overflow (bsc#1108761)
Record
SUSE-SU-2018:2979-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mgetty
Debian:12
before 1.2.1-1
1.2.1-1
mgetty
Debian:13
before 1.2.1-1
1.2.1-1
mgetty
Debian:14
before 1.2.1-1
1.2.1-1
mgetty
Mageia:6
before 1.1.37-1.1.mga6
1.1.37-1.1.mga6
mgetty
SUSE:Linux Enterprise Server 11 SP4
before 1.1.36-28.3.1
1.1.36-28.3.1
mgetty
SUSE:Linux Enterprise Server for SAP Applications 11 SP4
before 1.1.36-28.3.1
1.1.36-28.3.1
mgetty
SUSE:Linux Enterprise Module for Basesystem 15
before 1.1.37-3.3.2
1.1.37-3.3.2
mgetty
SUSE:Linux Enterprise Desktop 12 SP3
before 1.1.36-58.3.1
1.1.36-58.3.1
mgetty
SUSE:Linux Enterprise Server 12 SP3
before 1.1.36-58.3.1
1.1.36-58.3.1
mgetty
SUSE:Linux Enterprise Server for SAP Applications 12 SP3
before 1.1.36-58.3.1
1.1.36-58.3.1
mgetty
Ubuntu:16.04:LTS
All versions, plus listed versions
1.1.36-2.11.1.36-2.1+deb8u1build0.16.04.1
None known
mgetty
Ubuntu:18.04:LTS
All versions, plus listed versions
1.1.36-3.1
None known
mgetty
openSUSE:Tumbleweed
before 1.2.1-6.2
1.2.1-6.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-16742 is a high vulnerability (CVSS 7.8) in Mgetty Project Mgetty, published September 13, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.45%, the 39th percentile. Fixed in mgetty 1.2.1-1.

References

Show 17 moreShow less
MoveEnter Open