Every CVE Search/ Get API key

CVE-2018-16863

It was found that RHSA-2018:2918 did not fully fix CVE-2018-16509. An attacker could possibly...

7.3 HighFix available

It was found that RHSA-2018:2918 did not fully fix CVE-2018-16509. An attacker could possibly exploit another variant of the flaw and bypass the -dSAFER protection to, for example, execute arbitrary shell commands via a specially crafted PostScript document. This only affects ghostscript 9.07 as shipped with Red Hat Enterprise Linux 7.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
Low

Exploit likelihood

1.25%Down 1.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 7.3

It was found that RHSA-2018:2918 did not fully fix CVE-2018-16509. An attacker could possibly exploit another variant of the flaw and bypass the -dSAFER protection to, for example, execute arbitrary shell commands via a specially crafted PostScript document. This only affects ghostscript 9.07 as shipped with Red Hat Enterprise Linux 7.

Record
CVE-2018-16863
CVSS 3.0
7.3 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weakness
CWE-184
Updated
2026-11-02
EUVDEUVD-2018-8654 7.3

It was found that RHSA-2018:2918 did not fully fix CVE-2018-16509. An attacker could possibly exploit another variant of the flaw and bypass the -dSAFER protection to, for example, execute arbitrary shell commands via a specially crafted PostScript document. This only affects ghostscript 9.07 as shipped with Red Hat Enterprise Linux 7.

Record
EUVD-2018-8654
CVSS 3.0
7.3 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-03
GitHub AdvisoriesGHSA-83g5-f7jm-c8fc 7.8

It was found that RHSA-2018:2918 did not fully fix CVE-2018-16509. An attacker could possibly...

It was found that RHSA-2018:2918 did not fully fix CVE-2018-16509. An attacker could possibly exploit another variant of the flaw and bypass the -dSAFER protection to, for example, execute arbitrary shell commands via a specially crafted PostScript document. This only affects ghostscript 9.07 as shipped with Red Hat Enterprise Linux 7.

Record
GHSA-83g5-f7jm-c8fc
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-78, CWE-184
Updated
2026-11-02
NVD 7.3

It was found that RHSA-2018:2918 did not fully fix CVE-2018-16509. An attacker could possibly exploit another variant of the flaw and bypass the -dSAFER protection to, for example, execute arbitrary shell commands via a specially crafted PostScript document. This only affects ghostscript 9.07 as shipped with Red Hat Enterprise Linux 7.

Record
CVE-2018-16863
CVSS 3.0
7.3 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-184, CWE-78
Updated
2026-11-02
OSVRHSA-2018:3761 7.3

Red Hat Security Advisory: ghostscript security and bug fix update

Record
RHSA-2018:3761
CVSS 3.0
7.3 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ghostscript
Red Hat:enterprise_linux:7::client
before 0:9.07-31.el7_6.3
0:9.07-31.el7_6.3
ghostscript-cups
Red Hat:enterprise_linux:7::client
before 0:9.07-31.el7_6.3
0:9.07-31.el7_6.3
ghostscript-debuginfo
Red Hat:enterprise_linux:7::client
before 0:9.07-31.el7_6.3
0:9.07-31.el7_6.3
ghostscript-devel
Red Hat:enterprise_linux:7::client
before 0:9.07-31.el7_6.3
0:9.07-31.el7_6.3
ghostscript-doc
Red Hat:enterprise_linux:7::client
before 0:9.07-31.el7_6.3
0:9.07-31.el7_6.3
ghostscript-gtk
Red Hat:enterprise_linux:7::client
before 0:9.07-31.el7_6.3
0:9.07-31.el7_6.3
ghostscript
Red Hat:enterprise_linux:7::computenode
before 0:9.07-31.el7_6.3
0:9.07-31.el7_6.3
ghostscript-cups
Red Hat:enterprise_linux:7::computenode
before 0:9.07-31.el7_6.3
0:9.07-31.el7_6.3
ghostscript-debuginfo
Red Hat:enterprise_linux:7::computenode
before 0:9.07-31.el7_6.3
0:9.07-31.el7_6.3
ghostscript-devel
Red Hat:enterprise_linux:7::computenode
before 0:9.07-31.el7_6.3
0:9.07-31.el7_6.3
Show 14 moreShow less
Affected packages
PackageAffectedFixed
ghostscript-doc
Red Hat:enterprise_linux:7::computenode
before 0:9.07-31.el7_6.3
0:9.07-31.el7_6.3
ghostscript-gtk
Red Hat:enterprise_linux:7::computenode
before 0:9.07-31.el7_6.3
0:9.07-31.el7_6.3
ghostscript
Red Hat:enterprise_linux:7::server
before 0:9.07-31.el7_6.3
0:9.07-31.el7_6.3
ghostscript-cups
Red Hat:enterprise_linux:7::server
before 0:9.07-31.el7_6.3
0:9.07-31.el7_6.3
ghostscript-debuginfo
Red Hat:enterprise_linux:7::server
before 0:9.07-31.el7_6.3
0:9.07-31.el7_6.3
ghostscript-devel
Red Hat:enterprise_linux:7::server
before 0:9.07-31.el7_6.3
0:9.07-31.el7_6.3
ghostscript-doc
Red Hat:enterprise_linux:7::server
before 0:9.07-31.el7_6.3
0:9.07-31.el7_6.3
ghostscript-gtk
Red Hat:enterprise_linux:7::server
before 0:9.07-31.el7_6.3
0:9.07-31.el7_6.3
ghostscript
Red Hat:enterprise_linux:7::workstation
before 0:9.07-31.el7_6.3
0:9.07-31.el7_6.3
ghostscript-cups
Red Hat:enterprise_linux:7::workstation
before 0:9.07-31.el7_6.3
0:9.07-31.el7_6.3
ghostscript-debuginfo
Red Hat:enterprise_linux:7::workstation
before 0:9.07-31.el7_6.3
0:9.07-31.el7_6.3
ghostscript-devel
Red Hat:enterprise_linux:7::workstation
before 0:9.07-31.el7_6.3
0:9.07-31.el7_6.3
ghostscript-doc
Red Hat:enterprise_linux:7::workstation
before 0:9.07-31.el7_6.3
0:9.07-31.el7_6.3
ghostscript-gtk
Red Hat:enterprise_linux:7::workstation
before 0:9.07-31.el7_6.3
0:9.07-31.el7_6.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-16863 is a high vulnerability (CVSS 7.3) in Artifex Ghostscript, published December 3, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.25%, the 69th percentile. Fixed in ghostscript 0:9.07-31.el7_6.3.

References

Show 12 moreShow less
MoveEnter Open