Every CVE Search/ Get API key

CVE-2018-17141

HylaFAX 6.0.6 and HylaFAX+ 5.6.0 allow remote attackers to execute arbitrary code via a dial-in...

9.8 CriticalFix available

HylaFAX 6.0.6 and HylaFAX+ 5.6.0 allow remote attackers to execute arbitrary code via a dial-in session that provides a FAX page with the JPEG bit enabled, which is mishandled in FaxModem::writeECMData() in the faxd/CopyQuality.c++ file.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

5.59%Up 2.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

HylaFAX 6.0.6 and HylaFAX+ 5.6.0 allow remote attackers to execute arbitrary code via a dial-in session that provides a FAX page with the JPEG bit enabled, which is mishandled in FaxModem::writeECMData() in the faxd/CopyQuality.c++ file.

Record
CVE-2018-17141
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-787, CWE-824
Updated
2026-11-02
CVE List No score

HylaFAX 6.0.6 and HylaFAX+ 5.6.0 allow remote attackers to execute arbitrary code via a dial-in session that provides a FAX page with the JPEG bit enabled, which is mishandled in FaxModem::writeECMData() in the faxd/CopyQuality.c++ file.

Record
CVE-2018-17141
Updated
2026-11-02
EUVDEUVD-2018-8919 No score

HylaFAX 6.0.6 and HylaFAX+ 5.6.0 allow remote attackers to execute arbitrary code via a dial-in session that provides a FAX page with the JPEG bit enabled, which is mishandled in FaxModem::writeECMData() in the faxd/CopyQuality.c++ file.

Record
EUVD-2018-8919
Updated
2026-11-03
GitHub AdvisoriesGHSA-56vg-g8vf-f4v4 9.8

HylaFAX 6.0.6 and HylaFAX+ 5.6.0 allow remote attackers to execute arbitrary code via a dial-in...

HylaFAX 6.0.6 and HylaFAX+ 5.6.0 allow remote attackers to execute arbitrary code via a dial-in session that provides a FAX page with the JPEG bit enabled, which is mishandled in FaxModem::writeECMData() in the faxd/CopyQuality.c++ file.

Record
GHSA-56vg-g8vf-f4v4
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-824
Updated
2026-11-02
OSVALPINE-CVE-2018-17141 9.8

HylaFAX 6.0.6 and HylaFAX+ 5.6.0 allow remote attackers to execute arbitrary code via a dial-in session that provides a FAX page with the JPEG bit enabled, which is mishandled in FaxModem::writeECMData() in the faxd/CopyQuality.c++ file.

Record
ALPINE-CVE-2018-17141
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSV 9.8

HylaFAX 6.0.6 and HylaFAX+ 5.6.0 allow remote attackers to execute arbitrary code via a dial-in session that provides a FAX page with the JPEG bit enabled, which is mishandled in FaxModem::writeECMData() in the faxd/CopyQuality.c++ file.

Record
CVE-2018-17141
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVDEBIAN-CVE-2018-17141 9.8

HylaFAX 6.0.6 and HylaFAX+ 5.6.0 allow remote attackers to execute arbitrary code via a dial-in session that provides a FAX page with the JPEG bit enabled, which is mishandled in FaxModem::writeECMData() in the faxd/CopyQuality.c++ file.

Record
DEBIAN-CVE-2018-17141
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2018-17141 9.8

HylaFAX 6.0.6 and HylaFAX+ 5.6.0 allow remote attackers to execute arbitrary code via a dial-in session that provides a FAX page with the JPEG bit enabled, which is mishandled in FaxModem::writeECMData() in the faxd/CopyQuality.c++ file.

Record
UBUNTU-CVE-2018-17141
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2018-0456 No score

Updated hylafax+ packages fix security vulnerability

Luis Merino, Markus Vervier and Eric Sesterhenn discovered that missing input sanitising in the Hylafax fax software could potentially result in the execution of arbitrary code via a malformed fax message (CVE-2018-17141).

Record
MGASA-2018-0456
Updated
2026-11-02
OSVopenSUSE-SU-2024:10852-1 No score

hylafax+-7.0.3-5.1 on GA media

These are all security issues fixed in the hylafax+-7.0.3-5.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10852-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
hylafax
Alpine:v3.10
before 6.0.6-r5
6.0.6-r5
hylafax
Alpine:v3.11
before 6.0.6-r5
6.0.6-r5
hylafax
Alpine:v3.12
before 6.0.6-r5
6.0.6-r5
hylafax
Alpine:v3.13
before 6.0.6-r5
6.0.6-r5
hylafax
Alpine:v3.14
before 6.0.6-r5
6.0.6-r5
hylafax
Alpine:v3.15
before 6.0.6-r5
6.0.6-r5
hylafax
Alpine:v3.16
before 6.0.6-r5
6.0.6-r5
hylafax
Alpine:v3.17
before 6.0.6-r5
6.0.6-r5
hylafax
Alpine:v3.18
before 6.0.6-r5
6.0.6-r5
hylafax
Alpine:v3.19
before 6.0.6-r5
6.0.6-r5
Show 15 moreShow less
Affected packages
PackageAffectedFixed
hylafax
Alpine:v3.20
before 6.0.6-r5
6.0.6-r5
hylafax
Alpine:v3.5
before 6.0.6-r4
6.0.6-r4
hylafax
Alpine:v3.6
before 6.0.6-r5
6.0.6-r5
hylafax
Alpine:v3.7
before 6.0.6-r4
6.0.6-r4
hylafax
Alpine:v3.8
before 6.0.6-r5
6.0.6-r5
hylafax
Alpine:v3.9
before 6.0.6-r5
6.0.6-r5
hylafax
Debian:12
before 3:6.0.6-8.1
3:6.0.6-8.1
hylafax
Debian:13
before 3:6.0.6-8.1
3:6.0.6-8.1
hylafax
Debian:14
before 3:6.0.6-8.1
3:6.0.6-8.1
hylafax
Debian:8
before 3:6.0.6-6+deb8u1, plus listed versions
3:6.0.6-6
3:6.0.6-6+deb8u1
hylafax
Debian:9
before 3:6.0.6-7+deb9u1, plus listed versions
3:6.0.6-7
3:6.0.6-7+deb9u1
hylafax+
Mageia:6
before +-5.6.1-1.mga6
+-5.6.1-1.mga6
hylafax
Ubuntu:16.04:LTS
before 3:6.0.6-6+deb8u1build0.16.04.1, plus listed versions
3:6.0.6-6
3:6.0.6-6+deb8u1build0.16.04.1
hylafax
Ubuntu:18.04:LTS
before 3:6.0.6-8.1~ubuntu0.18.04.1, plus listed versions
3:6.0.6-8
3:6.0.6-8.1~ubuntu0.18.04.1
hylafax+
openSUSE:Tumbleweed
From an advisory covering 4 CVEs
before 7.0.3-5.1
7.0.3-5.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-17141 is a critical vulnerability (CVSS 9.8) in Hylafax, published September 20, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.59%, the 92nd percentile. Fixed in hylafax 6.0.6-r5.

References

Show 14 moreShow less
MoveEnter Open