Every CVE Search/ Get API key

CVE-2018-17937

gpsd versions 2.90 to 3.17 and microjson versions 1.0 to 1.3, an open source project, allow a...

8.8 HighFix available

gpsd versions 2.90 to 3.17 and microjson versions 1.0 to 1.3, an open source project, allow a stack-based buffer overflow, which may allow remote attackers to execute arbitrary code on embedded platforms via traffic on Port 2947/TCP or crafted JSON inputs.

Attack profile

How easy it is to exploit

Attack vector
Adjacent network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.66%Up 0.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

gpsd versions 2.90 to 3.17 and microjson versions 1.0 to 1.3, an open source project, allow a stack-based buffer overflow, which may allow remote attackers to execute arbitrary code on embedded platforms via traffic on Port 2947/TCP or crafted JSON inputs.

Record
CVE-2018-17937
CVSS 3.1
8.8 HighCVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
5.8 MediumAV:A/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-121, CWE-787
Updated
2026-11-02
CVE List No score

gpsd versions 2.90 to 3.17 and microjson versions 1.0 to 1.3, an open source project, allow a stack-based buffer overflow, which may allow remote attackers to execute arbitrary code on embedded platforms via traffic on Port 2947/TCP or crafted JSON inputs.

Record
CVE-2018-17937
Weakness
CWE-121
Updated
2026-11-02
EUVDEUVD-2018-9678 No score

gpsd versions 2.90 to 3.17 and microjson versions 1.0 to 1.3, an open source project, allow a stack-based buffer overflow, which may allow remote attackers to execute arbitrary code on embedded platforms via traffic on Port 2947/TCP or crafted JSON inputs.

Record
EUVD-2018-9678
Updated
2026-11-03
GitHub AdvisoriesGHSA-67xr-69p3-rj69 8.8

gpsd versions 2.90 to 3.17 and microjson versions 1.0 to 1.3, an open source project, allow a...

gpsd versions 2.90 to 3.17 and microjson versions 1.0 to 1.3, an open source project, allow a stack-based buffer overflow, which may allow remote attackers to execute arbitrary code on embedded platforms via traffic on Port 2947/TCP or crafted JSON inputs.

Record
GHSA-67xr-69p3-rj69
CVSS 3.1
8.8 HighCVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-121
Updated
2026-11-02
OSV 8.8

gpsd versions 2.90 to 3.17 and microjson versions 1.0 to 1.3, an open source project, allow a stack-based buffer overflow, which may allow remote attackers to execute arbitrary code on embedded platforms via traffic on Port 2947/TCP or crafted JSON inputs.

Record
CVE-2018-17937
CVSS 3.1
8.8 HighCVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2018-17937 8.8

gpsd versions 2.90 to 3.17 and microjson versions 1.0 to 1.3, an open source project, allow a stack-based buffer overflow, which may allow remote attackers to execute arbitrary code on embedded platforms via traffic on Port 2947/TCP or crafted JSON inputs.

Record
DEBIAN-CVE-2018-17937
CVSS 3.1
8.8 HighCVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2018-17937 8.8

gpsd versions 2.90 to 3.17 and microjson versions 1.0 to 1.3, an open source project, allow a stack-based buffer overflow, which may allow remote attackers to execute arbitrary code on embedded platforms via traffic on Port 2947/TCP or crafted JSON inputs.

Record
UBUNTU-CVE-2018-17937
CVSS 3.1
8.8 HighCVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2019-0150 No score

Updated gpsd packages fix security vulnerability

A stack-based buffer overflow flaw was found in gpsd versions 2.90 to 3.17. Successful exploitation of this vulnerability could allow remote code execution, data exfiltration, or denial-of service via device crash (CVE-2018-17937).

Record
MGASA-2019-0150
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gpsd
Debian:12
before 3.17-6
3.17-6
gpsd
Debian:13
before 3.17-6
3.17-6
gpsd
Debian:14
before 3.17-6
3.17-6
gpsd
Debian:8
before 3.11-3+deb8u1, plus listed versions
3.11-3
3.11-3+deb8u1
gpsd
Debian:9
before 3.16-4+deb9u1, plus listed versions
3.16-4
3.16-4+deb9u1
gpsd
Mageia:6
before 3.16-2.2.mga6
3.16-2.2.mga6
gpsd
Ubuntu:16.04:LTS
All versions, plus listed versions
3.11-33.15-23.15-2build1
None known
gpsd
Ubuntu:18.04:LTS
All versions, plus listed versions
3.16-43.17-33.17-5
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-17937 is a high vulnerability (CVSS 8.8) in Gpsd Project Gpsd, published March 13, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.66%, the 85th percentile. Fixed in gpsd 3.17-6.

References

Show 7 moreShow less
MoveEnter Open