CVE-2018-17983
Mercurial Out-of-bounds Read vulnerability
CVE-2018-17983 is a critical vulnerability (CVSS 9.1) in Mercurial, published October 4, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.97%, the 80th percentile. Fixed in mercurial 4.7.2.
cext/manifest.c in Mercurial before 4.7.2 has an out-of-bounds read during parsing of a malformed manifest entry.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.1
cext/manifest.c in Mercurial before 4.7.2 has an out-of-bounds read during parsing of a malformed manifest entry.
- Record
CVE-2018-17983- CVSS 3.0
- 9.1 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H - CVSS 2.0
- 6.4 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:P - Weakness
- CWE-125
- Updated
- 2026-11-02
CVE List No score
cext/manifest.c in Mercurial before 4.7.2 has an out-of-bounds read during parsing of a malformed manifest entry.
- Record
CVE-2018-17983- Updated
- 2026-11-02
EUVDEUVD-2018-0098 No score
cext/manifest.c in Mercurial before 4.7.2 has an out-of-bounds read during parsing of a malformed manifest entry.
- Record
EUVD-2018-0098- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-p575-cf9h-wv42
8.8
Mercurial Out-of-bounds Read vulnerability
cext/manifest.c in Mercurial before 4.7.2 has an out-of-bounds read during parsing of a malformed manifest entry.
- Record
GHSA-p575-cf9h-wv42- CVSS 4.0
- 8.8 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:H/SC:N/SI:N/SA:N - CVSS 3.0
- 9.1 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H - Weakness
- CWE-125
- Updated
- 2026-11-02
OSV
9.1
cext/manifest.c in Mercurial before 4.7.2 has an out-of-bounds read during parsing of a malformed manifest entry.
- Record
CVE-2018-17983- CVSS 3.0
- 9.1 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-17983
9.1
cext/manifest.c in Mercurial before 4.7.2 has an out-of-bounds read during parsing of a malformed manifest entry.
- Record
DEBIAN-CVE-2018-17983- CVSS 3.0
- 9.1 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H - Updated
- 2026-11-02
Show 8 moreShow less
OSVGHSA-p575-cf9h-wv42
8.8
Mercurial Out-of-bounds Read vulnerability
cext/manifest.c in Mercurial before 4.7.2 has an out-of-bounds read during parsing of a malformed manifest entry.
- Record
GHSA-p575-cf9h-wv42- CVSS 4.0
- 8.8 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:H/SC:N/SI:N/SA:N - CVSS 3.0
- 9.1 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H - Weakness
- CWE-125
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-17983
9.1
cext/manifest.c in Mercurial before 4.7.2 has an out-of-bounds read during parsing of a malformed manifest entry.
- Record
UBUNTU-CVE-2018-17983- CVSS 3.0
- 9.1 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H - Updated
- 2026-11-02
OSVMGASA-2018-0442 No score
Updated mercurial packages fix security vulnerability
An out-of-bounds read during parsing of a malformed manifest entry (CVE-2018-17983).
- Record
MGASA-2018-0442- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10586-1 No score
mercurial-5.9.1-2.1 on GA media
These are all security issues fixed in the mercurial-5.9.1-2.1 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10586-1- Updated
- 2026-11-02
OSVPYSEC-2018-91 No score
cext/manifest.c in Mercurial before 4.7.2 has an out-of-bounds read during parsing of a malformed manifest entry.
- Record
PYSEC-2018-91- Updated
- 2026-11-02
OSVSUSE-SU-2018:3430-1 No score
Security update for mercurial
This update for mercurial fixes the following issues:
- CVE-2018-17983: Fix an out-of-bounds read during parsing of a malformed manifest entry (bsc#1110899).
- Record
SUSE-SU-2018:3430-1- Updated
- 2026-11-02
OSVUSN-5102-1 No score
mercurial vulnerabilities
It was discovered that Mercurial mishandled symlinks in subrepositories. An attacker could use this issue to write arbitrary files to the target’s filesystem. (CVE-2019-3902)
It was discovered that Mercurial incorrectly handled certain manifest files. An attacker could use this issue to cause a denial of service and possibly execute arbitrary code. (CVE-2018-17983)
- Record
USN-5102-1- Updated
- 2026-11-02
OSVUSN-5102-2 No score
mercurial vulnerabilities
USN-5102-1 fixed vulnerabilities in Mercurial. This update provides the corresponding updates for Ubuntu 14.04 ESM and Ubuntu 16.04 ESM.
Original advisory details:
It was discovered that Mercurial mishandled symlinks in subrepositories. An attacker could use this issue to write arbitrary files to the target’s filesystem. (CVE-2019-3902)
It was discovered that Mercurial incorrectly handled certain manifest files. An attacker could use this issue to cause a denial of service and possibly execute arbitrary code. This issue only affected Ubuntu 16.04 ESM. (CVE-2018-17983)
- Record
USN-5102-2- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mercurialPyPI |
before 4.7.2 | 4.7.2 |
mercurialDebian:12 |
before 4.7.2-1 | 4.7.2-1 |
mercurialDebian:13 |
before 4.7.2-1 | 4.7.2-1 |
mercurialDebian:14 |
before 4.7.2-1 | 4.7.2-1 |
mercurialPyPI |
before 4.7.2, plus listed versions 0.8.10.90.9.10.9.20.9.3 Show 45 moreShow less0.9.40.9.51.01.0.11.0.21.11.1.11.1.21.21.2.11.31.3.11.41.4.11.4.21.4.31.51.5.11.5.21.5.31.5.41.61.6.11.6.21.6.31.6.41.71.7.11.7.21.7.31.7.51.81.8.11.8.21.8.31.8.41.91.9.11.9.21.9.32.02.0.12.0.22.12.1.1 |
4.7.2 |
mercurialMageia:6 |
before 4.7.2-1.mga6 | 4.7.2-1.mga6 |
mercurialSUSE:Linux Enterprise Module for Development Tools 15 |
before 4.5.2-3.6.1 | 4.5.2-3.6.1 |
mercurialUbuntu:18.04:LTS |
before 4.5.3-1ubuntu2.2, plus listed versions 4.3.1-24.5-1ubuntu14.5.2-0ubuntu24.5.3-1ubuntu24.5.3-1ubuntu2.1 |
4.5.3-1ubuntu2.2 |
mercurialUbuntu:Pro:14.04:LTS |
before 2.8.2-1ubuntu1.4+esm1, plus listed versions 2.6.3-12.7.2-12.8.1-22.8.2-1ubuntu12.8.2-1ubuntu1.32.8.2-1ubuntu1.4 |
2.8.2-1ubuntu1.4+esm1 |
mercurialUbuntu:Pro:16.04:LTS |
before 3.7.3-1ubuntu1.2+esm2, plus listed versions 3.4-1ubuntu23.6.2-1ubuntu23.7.3-1ubuntu13.7.3-1ubuntu1.13.7.3-1ubuntu1.2 |
3.7.3-1ubuntu1.2+esm2 |
mercurialopenSUSE:Tumbleweed |
before 5.9.1-2.1 | 5.9.1-2.1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
mercurial-scm.org/repo/hg/rev/5405cb1a7901
mercurial-scm.org/wiki/WhatsNew
nvd.nist.gov/vuln/detail/CVE-2018-17983
github.com/pypa/advisory-database/tree/main/vulns/mercurial/PYSEC-2018-91.yaml
github.com/advisories/GHSA-p575-cf9h-wv42
security-tracker.debian.org/tracker/CVE-2018-17983
Show 19 moreShow less
advisories.mageia.org/MGASA-2018-0442.html
bugs.mageia.org/show_bug.cgi?id=23763
lists.opensuse.org/opensuse-updates/2018-10/msg00212.html
suse.com/support/update/announcement/2018/suse-su-20183430-1
bugzilla.suse.com/1110899
suse.com/security/cve/CVE-2018-17983
ubuntu.com/security/CVE-2018-17983
ubuntu.com/security/notices/USN-5102-1
cve.org/CVERecord?id=CVE-2018-17983
ubuntu.com/security/notices/USN-5102-2
ubuntu.com/security/CVE-2019-3902
suse.com/security/cve/CVE-2008-2942
suse.com/security/cve/CVE-2017-1000115
suse.com/security/cve/CVE-2017-1000116
suse.com/security/cve/CVE-2017-17458
suse.com/security/cve/CVE-2018-1000132
suse.com/security/cve/CVE-2018-13346
suse.com/security/cve/CVE-2018-13348
suse.com/security/cve/CVE-2019-3902
Left out here: 102 versions. The JSON record has them.