Every CVE Search/ Get API key

CVE-2018-18020

In QPDF 8.2.1, in libqpdf/QPDFWriter.cc, QPDFWriter::unparseObject and QPDFWriter::unparseChild...

3.3 LowFix available

CVE-2018-18020 is a low vulnerability (CVSS 3.3) in Qpdf Project Qpdf, published October 6, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.21%, the 68th percentile. Fixed in qpdf 9.0.0-1.

In QPDF 8.2.1, in libqpdf/QPDFWriter.cc, QPDFWriter::unparseObject and QPDFWriter::unparseChild have recursive calls for a long time, which allows remote attackers to cause a denial of service via a crafted PDF file.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
Low

Exploit likelihood

1.21%Up 0.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 3.3

In QPDF 8.2.1, in libqpdf/QPDFWriter.cc, QPDFWriter::unparseObject and QPDFWriter::unparseChild have recursive calls for a long time, which allows remote attackers to cause a denial of service via a crafted PDF file.

Record
CVE-2018-18020
CVSS 3.0
3.3 LowCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-674
Updated
2026-11-02
CVE List No score

In QPDF 8.2.1, in libqpdf/QPDFWriter.cc, QPDFWriter::unparseObject and QPDFWriter::unparseChild have recursive calls for a long time, which allows remote attackers to cause a denial of service via a crafted PDF file.

Record
CVE-2018-18020
Updated
2026-11-02
EUVDEUVD-2018-9759 No score

In QPDF 8.2.1, in libqpdf/QPDFWriter.cc, QPDFWriter::unparseObject and QPDFWriter::unparseChild have recursive calls for a long time, which allows remote attackers to cause a denial of service via a crafted PDF file.

Record
EUVD-2018-9759
Updated
2026-11-03
GitHub AdvisoriesGHSA-r676-q927-78rr 3.3

In QPDF 8.2.1, in libqpdf/QPDFWriter.cc, QPDFWriter::unparseObject and QPDFWriter::unparseChild...

In QPDF 8.2.1, in libqpdf/QPDFWriter.cc, QPDFWriter::unparseObject and QPDFWriter::unparseChild have recursive calls for a long time, which allows remote attackers to cause a denial of service via a crafted PDF file.

Record
GHSA-r676-q927-78rr
CVSS 3.0
3.3 LowCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
Weakness
CWE-674
Updated
2026-11-02
OSV 3.3

In QPDF 8.2.1, in libqpdf/QPDFWriter.cc, QPDFWriter::unparseObject and QPDFWriter::unparseChild have recursive calls for a long time, which allows remote attackers to cause a denial of service via a crafted PDF file.

Record
CVE-2018-18020
CVSS 3.0
3.3 LowCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSVDEBIAN-CVE-2018-18020 3.3

In QPDF 8.2.1, in libqpdf/QPDFWriter.cc, QPDFWriter::unparseObject and QPDFWriter::unparseChild have recursive calls for a long time, which allows remote attackers to cause a denial of service via a crafted PDF file.

Record
DEBIAN-CVE-2018-18020
CVSS 3.0
3.3 LowCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSVUBUNTU-CVE-2018-18020 3.3

In QPDF 8.2.1, in libqpdf/QPDFWriter.cc, QPDFWriter::unparseObject and QPDFWriter::unparseChild have recursive calls for a long time, which allows remote attackers to cause a denial of service via a crafted PDF file.

Record
UBUNTU-CVE-2018-18020
CVSS 3.0
3.3 LowCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
Updated
2026-11-02
OSVUSN-5026-1 No score

qpdf vulnerabilities

It was discovered that QPDF incorrectly handled certain malformed PDF files. A remote attacker could use this issue to cause QPDF to consume resources, resulting in a denial of service. This issue only affected Ubuntu 18.04 LTS. (CVE-2018-18020)

It was discovered that QPDF incorrectly handled certain malformed PDF files. A remote attacker could use this issue to cause QPDF to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2021-36978)

Record
USN-5026-1
Updated
2026-11-02
OSVUSN-5026-2 No score

qpdf vulnerabilities

USN-5026-1 fixed several vulnerabilities in QPDF. This update provides the corresponding update for Ubuntu 16.04 ESM. Original advisory details:

It was discovered that QPDF incorrectly handled certain malformed PDF files. A remote attacker could use this issue to cause QPDF to consume resources, resulting in a denial of service. (CVE-2018-18020)

It was discovered that QPDF incorrectly handled certain malformed PDF files. A remote attacker could use this issue to cause QPDF to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2021-36978)

Record
USN-5026-2
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
qpdf
Debian:12
before 9.0.0-1
9.0.0-1
qpdf
Debian:13
before 9.0.0-1
9.0.0-1
qpdf
Debian:14
before 9.0.0-1
9.0.0-1
qpdf
Debian:10
before 8.4.0-2+deb10u1, plus listed versions
8.4.0-2
8.4.0-2+deb10u1
qpdf
Ubuntu:Pro:16.04:LTS
before 8.0.2-3~16.04.1+esm1, plus listed versions
5.1.3-25.1.3-35.2.0-15.2.0-26.0.0-28.0.2-3~16.04.1
8.0.2-3~16.04.1+esm1
qpdf
Ubuntu:18.04:LTS
before 8.0.2-3ubuntu0.1, plus listed versions
7.0.0-17.1.0-17.1.1-18.0.0-18.0.1-18.0.2-18.0.2-3
8.0.2-3ubuntu0.1
qpdf
Ubuntu:20.04:LTS
before 9.1.1-1ubuntu0.1, plus listed versions
8.4.2-19.0.2-19.1.0-19.1.1-19.1.1-1build1
9.1.1-1ubuntu0.1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 4 moreShow less
MoveEnter Open