CVE-2018-18921
CSRF in PHP Server Monitor before 3.3.2
PHP Server Monitor before 3.3.2 has CSRF, as demonstrated by a Delete action.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.5
PHP Server Monitor before 3.3.2 has CSRF, as demonstrated by a Delete action.
- Record
CVE-2018-18921- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N - CVSS 2.0
- 5.8 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:P - Weakness
- CWE-352
- Updated
- 2026-11-02
CVE List No score
PHP Server Monitor before 3.3.2 has CSRF, as demonstrated by a Delete action.
- Record
CVE-2018-18921- Updated
- 2026-11-02
EUVDEUVD-2022-5462 No score
PHP Server Monitor before 3.3.2 has CSRF, as demonstrated by a Delete action.
- Record
EUVD-2022-5462- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-w2g4-g8xr-px4x
6.5
CSRF in PHP Server Monitor before 3.3.2
PHP Server Monitor before 3.3.2 has CSRF, as demonstrated by a Delete action.
- Record
GHSA-w2g4-g8xr-px4x- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N - Weakness
- CWE-352
- Updated
- 2026-11-02
OSV
6.5
PHP Server Monitor before 3.3.2 has CSRF, as demonstrated by a Delete action.
- Record
CVE-2018-18921- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVGHSA-w2g4-g8xr-px4x
6.5
CSRF in PHP Server Monitor before 3.3.2
PHP Server Monitor before 3.3.2 has CSRF, as demonstrated by a Delete action.
- Record
GHSA-w2g4-g8xr-px4x- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N - Weakness
- CWE-352
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
phpservermon/phpservermonPackagist |
through 3.3.1 | 3.3.2 |
phpservermon/phpservermonPackagist |
before 3.3.2, plus listed versions v3.1.0v3.1.1v3.2.0v3.2.0-rc1v3.2.1v3.2.2v3.3.0v3.3.1 |
3.3.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-18921 is a medium vulnerability (CVSS 6.5) in Phpservermonitor Php Server Monitor, published December 18, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.61%, the 49th percentile. Fixed in phpservermon/phpservermon 3.3.2.
References
medium.com/bugbountywriteup/cve-2018-18921-php-server-monitor-3-3-1-cross-site-request-forgery-a73e8dae563
github.com/phpservermon/phpservermon/issues/670
nvd.nist.gov/vuln/detail/CVE-2018-18921
github.com/phpservermon/phpservermon/commit/30150714a8af0c82259b733f604fce54c0dcbf40
github.com/advisories/GHSA-w2g4-g8xr-px4x