CVE-2018-19141
Open Ticket Request System (OTRS) 4.0.x before 4.0.33 and 5.0.x before 5.0.31 allows an admin to...
Open Ticket Request System (OTRS) 4.0.x before 4.0.33 and 5.0.x before 5.0.31 allows an admin to conduct an XSS attack via a modified URL because user and customer preferences are mishandled.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- High
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
4.8
Open Ticket Request System (OTRS) 4.0.x before 4.0.33 and 5.0.x before 5.0.31 allows an admin to conduct an XSS attack via a modified URL because user and customer preferences are mishandled.
- Record
CVE-2018-19141- CVSS 3.0
- 4.8 Medium
CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 3.5 Low
AV:N/AC:M/Au:S/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Open Ticket Request System (OTRS) 4.0.x before 4.0.33 and 5.0.x before 5.0.31 allows an admin to conduct an XSS attack via a modified URL because user and customer preferences are mishandled.
- Record
CVE-2018-19141- Updated
- 2026-11-02
EUVDEUVD-2018-10853 No score
Open Ticket Request System (OTRS) 4.0.x before 4.0.33 and 5.0.x before 5.0.31 allows an admin to conduct an XSS attack via a modified URL because user and customer preferences are mishandled.
- Record
EUVD-2018-10853- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5j7r-jxpc-qhpw
4.8
Open Ticket Request System (OTRS) 4.0.x before 4.0.33 and 5.0.x before 5.0.31 allows an admin to...
Open Ticket Request System (OTRS) 4.0.x before 4.0.33 and 5.0.x before 5.0.31 allows an admin to conduct an XSS attack via a modified URL because user and customer preferences are mishandled.
- Record
GHSA-5j7r-jxpc-qhpw- CVSS 3.0
- 4.8 Medium
CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
4.8
Open Ticket Request System (OTRS) 4.0.x before 4.0.33 and 5.0.x before 5.0.31 allows an admin to conduct an XSS attack via a modified URL because user and customer preferences are mishandled.
- Record
CVE-2018-19141- CVSS 3.0
- 4.8 Medium
CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-19141
4.8
Open Ticket Request System (OTRS) 4.0.x before 4.0.33 and 5.0.x before 5.0.31 allows an admin to conduct an XSS attack via a modified URL because user and customer preferences are mishandled.
- Record
DEBIAN-CVE-2018-19141- CVSS 3.0
- 4.8 Medium
CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-19141
4.8
Open Ticket Request System (OTRS) 4.0.x before 4.0.33 and 5.0.x before 5.0.31 allows an admin to conduct an XSS attack via a modified URL because user and customer preferences are mishandled.
- Record
UBUNTU-CVE-2018-19141- CVSS 3.0
- 4.8 Medium
CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
otrs2Debian:11 |
before 6.0.1-1, plus listed versions 2.0.4p01-102.0.4p01-112.0.4p01-122.0.4p01-132.0.4p01-14 Show 45 moreShow less2.0.4p01-14.12.0.4p01-152.0.4p01-162.0.4p01-172.0.4p01-182.0.4p01-62.0.4p01-72.0.4p01-82.0.4p01-92.0.99beta1-12.0.99beta1-22.1.1-12.1.3-12.1.4-12.1.4-22.1.5-12.1.5-22.1.5-32.1.6-12.1.7-12.1.7-22.2.0~beta2-12.2.0~beta3-12.2.1-12.2.2-12.2.3-12.2.4-12.2.5-12.2.5-22.2.6-12.2.7-12.2.7-22.2.7-2lenny12.2.7-2lenny22.2.7-2lenny32.2.7-32.3.2-12.3.2-22.3.3-12.3.4-12.3.4-22.3.4-32.3.4-42.3.4-52.3.4-6 |
6.0.1-1 |
otrs2Debian:8 From an advisory covering 2 CVEs |
before 3.3.18-1+deb8u7, plus listed versions 3.3.10-13.3.11-13.3.18-1+deb8u13.3.18-1+deb8u23.3.18-1+deb8u3 Show 8 moreShow less3.3.18-1+deb8u43.3.18-1+deb8u53.3.18-1+deb8u63.3.18-1~deb7u13.3.18-1~deb7u23.3.18-1~deb7u33.3.9-33.3.9-3+deb8u1 |
3.3.18-1+deb8u7 |
otrs2Ubuntu:16.04:LTS |
All versions, plus listed versions 4.0.10-15.0.1-15.0.1-25.0.2-15.0.3-15.0.5-15.0.6-15.0.7-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-19141 is a medium vulnerability (CVSS 4.8) in Otrs Open Ticket Request System, published November 11, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.67%, the 52nd percentile. Fixed in otrs2 6.0.1-1.
References
lists.debian.org/debian-lts-announce/2018/11/msg00028.html
community.otrs.com/security-advisory-2018-09-security-update-for-otrs-framework
nvd.nist.gov/vuln/detail/CVE-2018-19141
github.com/advisories/GHSA-5j7r-jxpc-qhpw
security-tracker.debian.org/tracker/CVE-2018-19141
ubuntu.com/security/CVE-2018-19141
cve.org/CVERecord?id=CVE-2018-19141
Left out here: 148 versions. The JSON record has them.