Every CVE Search/ Get API key

CVE-2018-19274

phpBB Remote Code Execution

7.2 HighFix available

Passing an absolute path to a file_exists check in phpBB before 3.2.4 allows Remote Code Execution through Object Injection by employing Phar deserialization when an attacker has access to the Admin Control Panel with founder permissions.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
High
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

5.20%Up 3.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.2

Passing an absolute path to a file_exists check in phpBB before 3.2.4 allows Remote Code Execution through Object Injection by employing Phar deserialization when an attacker has access to the Admin Control Panel with founder permissions.

Record
CVE-2018-19274
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:P
Weakness
CWE-502, CWE-1321
Updated
2026-11-02
CVE List No score

Passing an absolute path to a file_exists check in phpBB before 3.2.4 allows Remote Code Execution through Object Injection by employing Phar deserialization when an attacker has access to the Admin Control Panel with founder permissions.

Record
CVE-2018-19274
Updated
2026-11-02
EUVDEUVD-2022-4053 No score

Passing an absolute path to a file_exists check in phpBB before 3.2.4 allows Remote Code Execution through Object Injection by employing Phar deserialization when an attacker has access to the Admin Control Panel with founder permissions.

Record
EUVD-2022-4053
Updated
2026-11-03
GitHub AdvisoriesGHSA-h3mr-q96r-37v4 7.2

phpBB Remote Code Execution

Passing an absolute path to a file_exists check in phpBB before 3.2.4 allows Remote Code Execution through Object Injection by employing Phar deserialization when an attacker has access to the Admin Control Panel with founder permissions.

Record
GHSA-h3mr-q96r-37v4
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-502
Updated
2026-11-02
OSV 7.2

Passing an absolute path to a file_exists check in phpBB before 3.2.4 allows Remote Code Execution through Object Injection by employing Phar deserialization when an attacker has access to the Admin Control Panel with founder permissions.

Record
CVE-2018-19274
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-h3mr-q96r-37v4 7.2

phpBB Remote Code Execution

Passing an absolute path to a file_exists check in phpBB before 3.2.4 allows Remote Code Execution through Object Injection by employing Phar deserialization when an attacker has access to the Admin Control Panel with founder permissions.

Record
GHSA-h3mr-q96r-37v4
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-502
Updated
2026-11-02
OSVUBUNTU-CVE-2018-19274 7.2

Passing an absolute path to a file_exists check in phpBB before 3.2.4 allows Remote Code Execution through Object Injection by employing Phar deserialization when an attacker has access to the Admin Control Panel with founder permissions.

Record
UBUNTU-CVE-2018-19274
CVSS 3.1
7.2 HighCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
phpbb/phpbb
Packagist
before 3.2.4
3.2.4
phpbb3
Debian:8
before 3.0.12-5+deb8u2, plus listed versions
3.0.12-53.0.12-5+deb8u1
3.0.12-5+deb8u2
phpbb/phpbb
Packagist
before 3.2.4, plus listed versions
3.0.123.0.12-RC13.0.12-RC23.0.12-RC33.0.13
Show 45 moreShow less
3.0.13-PL13.0.13-RC13.0.143.0.14-RC13.1.03.1.0-RC13.1.0-RC23.1.0-RC33.1.0-RC43.1.0-RC53.1.0-RC63.1.0-a13.1.0-a23.1.0-a33.1.0-b13.1.0-b23.1.0-b33.1.0-b43.1.13.1.103.1.10-RC13.1.113.1.11-RC13.1.123.1.23.1.2-RC13.1.33.1.3-RC13.1.3-RC23.1.43.1.4-RC13.1.4-RC23.1.53.1.5-RC13.1.63.1.6-RC13.1.73.1.7-RC13.1.7-pl13.1.83.1.8-RC13.1.93.1.9-RC13.2.03.2.0-RC1
3.2.4
phpbb3
Ubuntu:Pro:14.04:LTS
before 3.0.12-1ubuntu0.1~esm1, plus listed versions
3.0.11-53.0.12-1
3.0.12-1ubuntu0.1~esm1
phpbb3
Ubuntu:16.04:LTS
All versions, plus listed versions
3.0.14-13.0.14-1ubuntu1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-19274 is a high vulnerability (CVSS 7.2) in Phpbb, published November 17, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.20%, the 92nd percentile. Fixed in phpbb/phpbb 3.2.4.

References

This page doesn't list everything

Left out here: 11 versions. The JSON record has them.

MoveEnter Open