Every CVE Search/ Get API key

CVE-2018-19532

A NULL pointer dereference vulnerability exists in the function PdfTranslator::setTarget() in...

8.8 HighFix available

A NULL pointer dereference vulnerability exists in the function PdfTranslator::setTarget() in pdftranslator.cpp of PoDoFo 0.9.6, while creating the PdfXObject, as demonstrated by podofoimpose. It allows an attacker to cause Denial of Service.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.66%Up 0.9 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

A NULL pointer dereference vulnerability exists in the function PdfTranslator::setTarget() in pdftranslator.cpp of PoDoFo 0.9.6, while creating the PdfXObject, as demonstrated by podofoimpose. It allows an attacker to cause Denial of Service.

Record
CVE-2018-19532
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-476
Updated
2026-11-02
CVE List No score

A NULL pointer dereference vulnerability exists in the function PdfTranslator::setTarget() in pdftranslator.cpp of PoDoFo 0.9.6, while creating the PdfXObject, as demonstrated by podofoimpose. It allows an attacker to cause Denial of Service.

Record
CVE-2018-19532
Updated
2026-11-02
EUVDEUVD-2018-11221 No score

A NULL pointer dereference vulnerability exists in the function PdfTranslator::setTarget() in pdftranslator.cpp of PoDoFo 0.9.6, while creating the PdfXObject, as demonstrated by podofoimpose. It allows an attacker to cause Denial of Service.

Record
EUVD-2018-11221
Updated
2026-11-03
GitHub AdvisoriesGHSA-qp6c-p26q-wjqf 8.8

A NULL pointer dereference vulnerability exists in the function PdfTranslator::setTarget() in...

A NULL pointer dereference vulnerability exists in the function PdfTranslator::setTarget() in pdftranslator.cpp of PoDoFo 0.9.6, while creating the PdfXObject, as demonstrated by podofoimpose. It allows an attacker to cause Denial of Service.

Record
GHSA-qp6c-p26q-wjqf
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-476
Updated
2026-11-02
OSVALPINE-CVE-2018-19532 8.8

A NULL pointer dereference vulnerability exists in the function PdfTranslator::setTarget() in pdftranslator.cpp of PoDoFo 0.9.6, while creating the PdfXObject, as demonstrated by podofoimpose. It allows an attacker to cause Denial of Service.

Record
ALPINE-CVE-2018-19532
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSV 8.8

A NULL pointer dereference vulnerability exists in the function PdfTranslator::setTarget() in pdftranslator.cpp of PoDoFo 0.9.6, while creating the PdfXObject, as demonstrated by podofoimpose. It allows an attacker to cause Denial of Service.

Record
CVE-2018-19532
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVDEBIAN-CVE-2018-19532 8.8

A NULL pointer dereference vulnerability exists in the function PdfTranslator::setTarget() in pdftranslator.cpp of PoDoFo 0.9.6, while creating the PdfXObject, as demonstrated by podofoimpose. It allows an attacker to cause Denial of Service.

Record
DEBIAN-CVE-2018-19532
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2018-19532 8.8

A NULL pointer dereference vulnerability exists in the function PdfTranslator::setTarget() in pdftranslator.cpp of PoDoFo 0.9.6, while creating the PdfXObject, as demonstrated by podofoimpose. It allows an attacker to cause Denial of Service.

Record
UBUNTU-CVE-2018-19532
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2019-0044 No score

Updated podofo packages fix security vulnerabilities

The podofo package has been updated to fix several security issues.

Record
MGASA-2019-0044
Updated
2026-11-02
OSVopenSUSE-SU-2024:14278-1 No score

libpodofo-devel-0.10.3-2.1 on GA media

These are all security issues fixed in the libpodofo-devel-0.10.3-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:14278-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
podofo
Alpine:v3.13
before 0.9.7-r0
0.9.7-r0
podofo
Alpine:v3.14
before 0.9.7-r0
0.9.7-r0
podofo
Alpine:v3.15
before 0.9.7-r0
0.9.7-r0
podofo
Alpine:v3.16
before 0.9.7-r0
0.9.7-r0
podofo
Alpine:v3.17
before 0.9.7-r0
0.9.7-r0
podofo
Alpine:v3.18
before 0.9.7-r0
0.9.7-r0
podofo
Alpine:v3.19
before 0.9.7-r0
0.9.7-r0
podofo
Alpine:v3.20
before 0.9.7-r0
0.9.7-r0
podofo
Alpine:v3.21
before 0.9.7-r0
0.9.7-r0
podofo
Alpine:v3.22
before 0.9.7-r0
0.9.7-r0
Show 10 moreShow less
Affected packages
PackageAffectedFixed
podofo
Alpine:v3.23
before 0.9.7-r0
0.9.7-r0
podofo
Alpine:v3.24
before 0.9.7-r0
0.9.7-r0
libpodofo
Debian:12
before 0.9.6+dfsg-4
0.9.6+dfsg-4
libpodofo
Debian:13
before 0.9.6+dfsg-4
0.9.6+dfsg-4
libpodofo
Debian:14
before 0.9.6+dfsg-4
0.9.6+dfsg-4
podofo
Mageia:6
before 0.9.6-1.mga6
0.9.6-1.mga6
libpodofo
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
0.9.0-1.1ubuntu10.9.0-1.20.9.0-1.2ubuntu0.1~esm10.9.0-1.2ubuntu0.1~esm3
None known
libpodofo
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
0.9.0-1.30.9.3-30.9.3-40.9.3-4ubuntu0.1~esm1
None known
libpodofo
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
0.9.5-60.9.5-80.9.5-8build10.9.5-90.9.5-9ubuntu0.1~esm1
None known
podofo
openSUSE:Tumbleweed
before 0.10.3-2.1
0.10.3-2.1

History

History
RecordedChangedSources
affected, aliases, referencesOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-19532 is a high vulnerability (CVSS 8.8) in Podofo Project Podofo, published November 26, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.66%, the 76th percentile. Fixed in podofo 0.9.7-r0.

References

Show 11 moreShow less
MoveEnter Open