Every CVE Search/ Get API key

CVE-2018-19542

An issue was discovered in JasPer 2.0.14. There is a NULL pointer dereference in the function...

6.5 MediumFix available

An issue was discovered in JasPer 2.0.14. There is a NULL pointer dereference in the function jp2_decode in libjasper/jp2/jp2_dec.c, leading to a denial of service.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.96%Up 0.7 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.5

An issue was discovered in JasPer 2.0.14. There is a NULL pointer dereference in the function jp2_decode in libjasper/jp2/jp2_dec.c, leading to a denial of service.

Record
CVE-2018-19542
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-476
Updated
2026-11-02
CVE List No score

An issue was discovered in JasPer 2.0.14. There is a NULL pointer dereference in the function jp2_decode in libjasper/jp2/jp2_dec.c, leading to a denial of service.

Record
CVE-2018-19542
Updated
2026-11-02
EUVDEUVD-2018-11231 No score

An issue was discovered in JasPer 2.0.14. There is a NULL pointer dereference in the function jp2_decode in libjasper/jp2/jp2_dec.c, leading to a denial of service.

Record
EUVD-2018-11231
Updated
2026-11-02
GitHub AdvisoriesGHSA-qp52-65cq-8g48 6.5

An issue was discovered in JasPer 2.0.14. There is a NULL pointer dereference in the function...

An issue was discovered in JasPer 2.0.14. There is a NULL pointer dereference in the function jp2_decode in libjasper/jp2/jp2_dec.c, leading to a denial of service.

Record
GHSA-qp52-65cq-8g48
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-476
Updated
2026-11-02
OSV 6.5

An issue was discovered in JasPer 2.0.14. There is a NULL pointer dereference in the function jp2_decode in libjasper/jp2/jp2_dec.c, leading to a denial of service.

Record
CVE-2018-19542
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2018-19542 6.5

An issue was discovered in JasPer 2.0.14. There is a NULL pointer dereference in the function jp2_decode in libjasper/jp2/jp2_dec.c, leading to a denial of service.

Record
UBUNTU-CVE-2018-19542
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 6 moreShow less
OSVMGASA-2019-0167 No score

Updated jasper packages fix security vulnerabilities

Updated jasper packages fix security vulnerabilities:

The jpc_floorlog2 function in jpc_math.c in JasPer before 1.900.17 allows remote attackers to cause a denial of service (assertion failure) via unspecified vectors (CVE-2016-9398).

A denial of service in jp2_decode (CVE-2018-19542).

A denial of service in jas_image_readcmpt (CVE-2018-19539).

Record
MGASA-2019-0167
Updated
2026-11-02
OSVopenSUSE-SU-2019:1315-1 No score

Security update for jasper

This update for jasper fixes the following issues:

Security issues fixed:

  • CVE-2018-19542: Fixed a denial of service in jp2_decode (bsc#1117505).
  • CVE-2018-19539: Fixed a denial of service in jas_image_readcmpt (bsc#1117511).
  • CVE-2016-9396: Fixed a denial of service in jpc_cox_getcompparms (bsc#1010783).

This update was imported from the SUSE:SLE-15:Update update project.

Record
openSUSE-SU-2019:1315-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:10869-1 No score

jasper-2.0.33-1.2 on GA media

These are all security issues fixed in the jasper-2.0.33-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10869-1
Updated
2026-11-02
OSVSUSE-SU-2019:1018-1 No score

Security update for jasper

This update for jasper fixes the following issues:

Security issues fixed:

  • CVE-2018-19542: Fixed a denial of service in jp2_decode (bsc#1117505).
  • CVE-2018-19539: Fixed a denial of service in jas_image_readcmpt (bsc#1117511).
  • CVE-2016-9396: Fixed a denial of service in jpc_cox_getcompparms (bsc#1010783).
Record
SUSE-SU-2019:1018-1
Updated
2026-11-02
OSVSUSE-SU-2019:2513-1 No score

Security update for jasper

This update for jasper fixes the following issues:

Security issues fixed:

  • CVE-2018-19540: Fixed a heap based overflow in jas_icctxtdesc_input (bsc#1117508).
  • CVE-2018-19541: Fix heap based overread in jas_image_depalettize (bsc#1117507).
  • CVE-2018-19542: Fixed a denial of service in jp2_decode (bsc#1117505).
  • CVE-2018-19539: Fixed a denial of service in jas_image_readcmpt (bsc#1117511).
  • CVE-2016-9396: Fixed a denial of service in jpc_cox_getcompparms (bsc#1010783).
Record
SUSE-SU-2019:2513-1
Updated
2026-11-02
OSVUSN-4688-1 No score

jasper vulnerabilities

It was discovered that Jasper incorrectly certain files. An attacker could possibly use this issue to cause a crash. (CVE-2018-18873)

It was discovered that Jasper incorrectly handled certain files. An attacker could possibly use this issue to cause a denial of service. (CVE-2018-19542)

It was discovered that Jasper incorrectly handled certain JPC encoders. An attacker could possibly use this issue to execute arbitrary code. (CVE-2020-27828)

It was discovered that Jasper incorrectly handled certain images. An attacker could possibly use this issue to expose sensitive information or cause a crash. (CVE-2017-9782)

Record
USN-4688-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
jasper
Debian:8
before 1.900.1-debian1-2.4+deb8u5, plus listed versions
1.900.1-debian1-2.41.900.1-debian1-2.4+deb8u11.900.1-debian1-2.4+deb8u21.900.1-debian1-2.4+deb8u31.900.1-debian1-2.4+deb8u4
1.900.1-debian1-2.4+deb8u5
jasper
Mageia:6
before 1.900.23-5.2.mga6
1.900.23-5.2.mga6
jasper
SUSE:Linux Enterprise Module for Basesystem 15
before 2.0.14-3.3.2
2.0.14-3.3.2
jasper
SUSE:Linux Enterprise Module for Desktop Applications 15
before 2.0.14-3.3.2
2.0.14-3.3.2
jasper
SUSE:Linux Enterprise Desktop 12 SP4
before 1.900.14-195.15.1
1.900.14-195.15.1
jasper
SUSE:Linux Enterprise Software Development Kit 12 SP4
before 1.900.14-195.15.1
1.900.14-195.15.1
jasper
SUSE:Linux Enterprise Server 12 SP4
before 1.900.14-195.15.1
1.900.14-195.15.1
jasper
SUSE:Linux Enterprise Server for SAP Applications 12 SP4
before 1.900.14-195.15.1
1.900.14-195.15.1
jasper
Ubuntu:16.04:LTS
before 1.900.1-debian1-2.4ubuntu1.3, plus listed versions
1.900.1-debian1-2.41.900.1-debian1-2.4ubuntu11.900.1-debian1-2.4ubuntu1.11.900.1-debian1-2.4ubuntu1.2
1.900.1-debian1-2.4ubuntu1.3
jasper
openSUSE:Leap 15.0
before 2.0.14-lp150.2.3.1
2.0.14-lp150.2.3.1
jasper
openSUSE:Tumbleweed
before 2.0.33-1.2
2.0.33-1.2

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-19542 is a medium vulnerability (CVSS 6.5) in Jasper Project Jasper, published November 26, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.96%, the 80th percentile. Fixed in jasper 1.900.1-debian1-2.4+deb8u5.

References

Show 55 moreShow less
MoveEnter Open