CVE-2018-19785
XSS in PHP-Proxy-App through v3.0
PHP-Proxy through 5.1.0 has Cross-Site Scripting (XSS) via the URL field in index.php.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
PHP-Proxy through 5.1.0 has Cross-Site Scripting (XSS) via the URL field in index.php.
- Record
CVE-2018-19785- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
PHP-Proxy through 5.1.0 has Cross-Site Scripting (XSS) via the URL field in index.php.
- Record
CVE-2018-19785- Updated
- 2026-11-02
EUVDEUVD-2022-3574 No score
PHP-Proxy through 5.1.0 has Cross-Site Scripting (XSS) via the URL field in index.php.
- Record
EUVD-2022-3574- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-cghj-w42g-hqmr
6.1
XSS in PHP-Proxy-App through v3.0
PHP-Proxy-App through 3.0 has Cross-Site Scripting (XSS) via the URL field in index.php.
- Record
GHSA-cghj-w42g-hqmr- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-cghj-w42g-hqmr
6.1
XSS in PHP-Proxy-App through v3.0
PHP-Proxy-App through 3.0 has Cross-Site Scripting (XSS) via the URL field in index.php.
- Record
GHSA-cghj-w42g-hqmr- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
athlon1600/php-proxy-appPackagist |
before 3.0 | 3.0 |
athlon1600/php-proxy-appPackagist |
before 3.0, plus listed versions 1.0.02.0.0 |
3.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-19785 is a medium vulnerability (CVSS 6.1) in Php-proxy, published December 1, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.94%, the 61st percentile. Fixed in athlon1600/php-proxy-app 3.0.