CVE-2018-20028
Contao Information Disclosure via Access Control Flaws
Contao 3.x before 3.5.37, 4.4.x before 4.4.31 and 4.6.x before 4.6.11 has Incorrect Access Control.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.5
Contao 3.x before 3.5.37, 4.4.x before 4.4.31 and 4.6.x before 4.6.11 has Incorrect Access Control.
- Record
CVE-2018-20028- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:P/I:N/A:N - Updated
- 2026-11-02
CVE List No score
Contao 3.x before 3.5.37, 4.4.x before 4.4.31 and 4.6.x before 4.6.11 has Incorrect Access Control.
- Record
CVE-2018-20028- Updated
- 2026-11-02
EUVDEUVD-2022-4927 No score
Contao 3.x before 3.5.37, 4.4.x before 4.4.31 and 4.6.x before 4.6.11 has Incorrect Access Control.
- Record
EUVD-2022-4927- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-q99w-j4mj-7hj8
6.5
Contao Information Disclosure via Access Control Flaws
Contao 3.x before 3.5.37, 4.4.x before 4.4.31 and 4.6.x before 4.6.11 has Incorrect Access Control.
- Record
GHSA-q99w-j4mj-7hj8- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-284
- Updated
- 2026-11-02
OSV
6.5
Contao 3.x before 3.5.37, 4.4.x before 4.4.31 and 4.6.x before 4.6.11 has Incorrect Access Control.
- Record
CVE-2018-20028- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVGHSA-q99w-j4mj-7hj8
6.5
Contao Information Disclosure via Access Control Flaws
Contao 3.x before 3.5.37, 4.4.x before 4.4.31 and 4.6.x before 4.6.11 has Incorrect Access Control.
- Record
GHSA-q99w-j4mj-7hj8- CVSS 3.0
- 6.5 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-284
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
contao/contaoPackagist |
3.0.0 up to 3.5.37 | 3.5.37 |
contao/contaoPackagist |
4.6.0 up to 4.6.11 | 4.6.11 |
contao/contaoPackagist |
4.4.0 up to 4.4.31 | 4.4.31 |
contao/contaoPackagist |
4.6.0 up to 4.6.11, plus listed versions 4.6.14.6.104.6.24.6.34.6.4 Show 5 moreShow less4.6.54.6.64.6.74.6.84.6.9 |
4.6.11 |
contao/contaoPackagist |
4.4.0 up to 4.4.31, plus listed versions 4.4.224.4.234.4.244.4.254.4.26 Show 4 moreShow less4.4.274.4.284.4.294.4.30 |
4.4.31 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-20028 is a medium vulnerability (CVSS 6.5) in Contao Cms, published April 17, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.91%, the 60th percentile. Fixed in contao/contao 3.5.37.