Every CVE Search/ Get API key

CVE-2018-20199

A NULL pointer dereference was discovered in ifilter_bank of libfaad/filtbank.c in Freeware...

5.5 MediumFix available

A NULL pointer dereference was discovered in ifilter_bank of libfaad/filtbank.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service because adding to windowed output is mishandled in the ONLY_LONG_SEQUENCE case.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.13%Up 0.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.5

A NULL pointer dereference was discovered in ifilter_bank of libfaad/filtbank.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service because adding to windowed output is mishandled in the ONLY_LONG_SEQUENCE case.

Record
CVE-2018-20199
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-476
Updated
2026-11-02
CVE List No score

A NULL pointer dereference was discovered in ifilter_bank of libfaad/filtbank.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service because adding to windowed output is mishandled in the ONLY_LONG_SEQUENCE case.

Record
CVE-2018-20199
Updated
2026-11-02
EUVDEUVD-2018-12766 No score

A NULL pointer dereference was discovered in ifilter_bank of libfaad/filtbank.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service because adding to windowed output is mishandled in the ONLY_LONG_SEQUENCE case.

Record
EUVD-2018-12766
Updated
2026-11-03
GitHub AdvisoriesGHSA-8fmv-4jcp-rv3m 5.5

A NULL pointer dereference was discovered in ifilter_bank of libfaad/filtbank.c in Freeware...

A NULL pointer dereference was discovered in ifilter_bank of libfaad/filtbank.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service because adding to windowed output is mishandled in the ONLY_LONG_SEQUENCE case.

Record
GHSA-8fmv-4jcp-rv3m
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-476
Updated
2026-11-02
OSVALPINE-CVE-2018-20199 5.5

A NULL pointer dereference was discovered in ifilter_bank of libfaad/filtbank.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service because adding to windowed output is mishandled in the ONLY_LONG_SEQUENCE case.

Record
ALPINE-CVE-2018-20199
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSV 5.5

A NULL pointer dereference was discovered in ifilter_bank of libfaad/filtbank.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service because adding to windowed output is mishandled in the ONLY_LONG_SEQUENCE case.

Record
CVE-2018-20199
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2018-20199 5.5

A NULL pointer dereference was discovered in ifilter_bank of libfaad/filtbank.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service because adding to windowed output is mishandled in the ONLY_LONG_SEQUENCE case.

Record
DEBIAN-CVE-2018-20199
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2018-20199 5.5

A NULL pointer dereference was discovered in ifilter_bank of libfaad/filtbank.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. The vulnerability causes a segmentation fault and application crash, which leads to denial of service because adding to windowed output is mishandled in the ONLY_LONG_SEQUENCE case.

Record
UBUNTU-CVE-2018-20199
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2025:15214-1 No score

faad2-2.11.2-2.1 on GA media

These are all security issues fixed in the faad2-2.11.2-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2025:15214-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
faad2
Alpine:v3.10
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.11
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.12
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.13
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.14
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.15
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.16
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.17
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.18
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.19
before 2.9.0-r0
2.9.0-r0
Show 18 moreShow less
Affected packages
PackageAffectedFixed
faad2
Alpine:v3.20
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.21
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.22
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.23
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.24
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.7
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.8
before 2.9.0-r0
2.9.0-r0
faad2
Alpine:v3.9
before 2.9.0-r0
2.9.0-r0
faad2
Debian:12
before 2.8.8-3.1
2.8.8-3.1
faad2
Debian:13
before 2.8.8-3.1
2.8.8-3.1
faad2
Debian:14
before 2.8.8-3.1
2.8.8-3.1
faad2
Debian:8
before 2.7-8+deb8u3, plus listed versions
2.7-82.7-8+deb8u12.7-8+deb8u2
2.7-8+deb8u3
faad2
Debian:9
before 2.8.0~cvs20161113-1+deb9u3, plus listed versions
2.8.0~cvs20161113-12.8.0~cvs20161113-1+deb9u12.8.0~cvs20161113-1+deb9u2
2.8.0~cvs20161113-1+deb9u3
faad2
Debian:10
before 2.10.0-1~deb10u1, plus listed versions
2.8.8-32.8.8-3+deb10u12.8.8-3.12.8.8-3.22.9.0-12.9.1-12.9.2-1
2.10.0-1~deb10u1
faad2
Ubuntu:Pro:14.04:LTS
before 2.7-8+deb8u3build0.14.04.1~esm1, plus listed versions
2.7-82.7-8+deb7u1build0.14.04.1
2.7-8+deb8u3build0.14.04.1~esm1
faad2
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.8.0~cvs20150510-12.8.0~cvs20150510-1ubuntu0.12.8.0~cvs20150510-1ubuntu0.1+esm1
None known
faad2
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
2.8.1-22.8.5-12.8.6-12.8.8-12.8.8-1ubuntu0.1~esm1
None known
faad2
openSUSE:Tumbleweed
before 2.11.2-2.1
2.11.2-2.1

History

History
RecordedChangedSources
affectedOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-20199 is a medium vulnerability (CVSS 5.5) in Audiocoding Freeware Advanced Audio Decoder 2, published December 18, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.13%, the 66th percentile. Fixed in faad2 2.9.0-r0.

References

Show 13 moreShow less
MoveEnter Open