Every CVE Search/ Get API key

CVE-2018-20242

Cross-site Scripting in jspwiki-war

6.1 MediumFix available

A carefully crafted URL could trigger an XSS vulnerability on Apache JSPWiki, from versions up to 2.10.5, which could lead to session hijacking.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

5.36%Up 2.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

A carefully crafted URL could trigger an XSS vulnerability on Apache JSPWiki, from versions up to 2.10.5, which could lead to session hijacking.

Record
CVE-2018-20242
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

A carefully crafted URL could trigger an XSS vulnerability on Apache JSPWiki, from versions up to 2.10.5, which could lead to session hijacking.

Record
CVE-2018-20242
Updated
2026-11-02
EUVDEUVD-2019-0231 No score

A carefully crafted URL could trigger an XSS vulnerability on Apache JSPWiki, from versions up to 2.10.5, which could lead to session hijacking.

Record
EUVD-2019-0231
Updated
2026-11-03
GitHub AdvisoriesGHSA-5q75-cxcq-wr26 6.1

Cross-site Scripting in jspwiki-war

A carefully crafted URL could trigger an XSS vulnerability on Apache JSPWiki, from versions up to 2.10.5, which could lead to session hijacking.

Record
GHSA-5q75-cxcq-wr26
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

A carefully crafted URL could trigger an XSS vulnerability on Apache JSPWiki, from versions up to 2.10.5, which could lead to session hijacking.

Record
CVE-2018-20242
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-5q75-cxcq-wr26 6.1

Cross-site Scripting in jspwiki-war

A carefully crafted URL could trigger an XSS vulnerability on Apache JSPWiki, from versions up to 2.10.5, which could lead to session hijacking.

Record
GHSA-5q75-cxcq-wr26
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.jspwiki:jspwiki-war
Maven
through 2.10.5
2.11.0.M1
org.apache.jspwiki:jspwiki-war
Maven
before 2.11.0.M1, plus listed versions
2.10.02.10.12.10.22.10.32.10.42.10.5
2.11.0.M1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-20242 is a medium vulnerability (CVSS 6.1) in Apache Jspwiki, published February 11, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.36%, the 92nd percentile. Fixed in org.apache.jspwiki:jspwiki-war 2.11.0.M1.

References

MoveEnter Open