CVE-2018-20758
MODX vulnerability allows for XSS via user settings parameters
CVE-2018-20758 is a medium vulnerability (CVSS 5.4) in Modx Revolution, published February 6, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.61%, the 49th percentile. Fixed in modx/revolution 2.7.1-pl.
MODX Revolution through v2.7.0-pl allows XSS via User Settings such as Description.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.4
MODX Revolution through v2.7.0-pl allows XSS via User Settings such as Description.
- Record
CVE-2018-20758- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 3.5 Low
AV:N/AC:M/Au:S/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
MODX Revolution through v2.7.0-pl allows XSS via User Settings such as Description.
- Record
CVE-2018-20758- Updated
- 2026-11-02
EUVDEUVD-2018-13301 No score
MODX Revolution through v2.7.0-pl allows XSS via User Settings such as Description.
- Record
EUVD-2018-13301- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-vwqw-wfhv-2xcq
5.4
MODX vulnerability allows for XSS via user settings parameters
MODX Revolution through v2.7.0-pl allows XSS via User Settings such as Description.
- Record
GHSA-vwqw-wfhv-2xcq- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
5.4
MODX Revolution through v2.7.0-pl allows XSS via User Settings such as Description.
- Record
CVE-2018-20758- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-vwqw-wfhv-2xcq
5.4
MODX vulnerability allows for XSS via user settings parameters
MODX Revolution through v2.7.0-pl allows XSS via User Settings such as Description.
- Record
GHSA-vwqw-wfhv-2xcq- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
modx/revolutionPackagist |
before 2.7.1-pl | 2.7.1-pl |
modx/revolutionPackagist |
before 2.7.1-pl, plus listed versions v2.7.0-pl |
2.7.1-pl |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |