Every CVE Search/ Get API key

CVE-2018-20761

GPAC version 0.7.1 and earlier has a Buffer Overflow vulnerability in the gf_sm_load_init...

7.8 HighFix available

GPAC version 0.7.1 and earlier has a Buffer Overflow vulnerability in the gf_sm_load_init function in scene_manager.c in libgpac_static.a.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.48%Up 0.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.8

GPAC version 0.7.1 and earlier has a Buffer Overflow vulnerability in the gf_sm_load_init function in scene_manager.c in libgpac_static.a.

Record
CVE-2018-20761
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

GPAC version 0.7.1 and earlier has a Buffer Overflow vulnerability in the gf_sm_load_init function in scene_manager.c in libgpac_static.a.

Record
CVE-2018-20761
Updated
2026-11-02
EUVDEUVD-2018-13304 No score

GPAC version 0.7.1 and earlier has a Buffer Overflow vulnerability in the gf_sm_load_init function in scene_manager.c in libgpac_static.a.

Record
EUVD-2018-13304
Updated
2026-11-03
GitHub AdvisoriesGHSA-7vg9-jpp6-29qg 7.8

GPAC version 0.7.1 and earlier has a Buffer Overflow vulnerability in the gf_sm_load_init...

GPAC version 0.7.1 and earlier has a Buffer Overflow vulnerability in the gf_sm_load_init function in scene_manager.c in libgpac_static.a.

Record
GHSA-7vg9-jpp6-29qg
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-119
Updated
2026-11-02
OSV 7.8

GPAC version 0.7.1 and earlier has a Buffer Overflow vulnerability in the gf_sm_load_init function in scene_manager.c in libgpac_static.a.

Record
CVE-2018-20761
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2018-20761 7.8

GPAC version 0.7.1 and earlier has a Buffer Overflow vulnerability in the gf_sm_load_init function in scene_manager.c in libgpac_static.a.

Record
DEBIAN-CVE-2018-20761
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2018-20761 7.8

GPAC version 0.7.1 and earlier has a Buffer Overflow vulnerability in the gf_sm_load_init function in scene_manager.c in libgpac_static.a.

Record
UBUNTU-CVE-2018-20761
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2019-0146 No score

Updated gpac packages fix security vulnerability

It was discovered that the GPAC MP4Box utility incorrectly handled certain memory operations. If an user or automated system were tricked into opening a specially crafted MP4 file, a remote attacker could use this issue to cause MP4Box to crash, resulting in a denial of service, or possibly execute arbitrary code (CVE-2018-7752, CVE-2018-13005, CVE-2018-13006, CVE-2018-20760, CVE-2018-20761, CVE-2018-20762, CVE-2018-20763, CVE-2018-1000100).

Record
MGASA-2019-0146
Updated
2026-11-02
OSVUSN-3926-1 No score

gpac vulnerabilities

It was discovered that the GPAC MP4Box utility incorrectly handled certain memory operations. If an user or automated system were tricked into opening a specially crafted MP4 file, a remote attacker could use this issue to cause MP4Box to crash, resulting in a denial of service, or possibly execute arbitrary code.

Record
USN-3926-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gpac
Debian:11
before 0.5.2-426-gc5ad4e4+dfsg5-4.1
0.5.2-426-gc5ad4e4+dfsg5-4.1
gpac
Debian:8
From an advisory covering 5 CVEs
before 0.5.0+svn5324~dfsg1-1+deb8u2, plus listed versions
0.5.0+svn5324~dfsg1-10.5.0+svn5324~dfsg1-1+deb8u1
0.5.0+svn5324~dfsg1-1+deb8u2
gpac
Mageia:6
From an advisory covering 8 CVEs
before 0.6.1-4.1.mga6.tainted
0.6.1-4.1.mga6.tainted
gpac
Ubuntu:Pro:14.04:LTS
before 0.5.0+svn4288~dfsg1-4ubuntu1+esm1, plus listed versions
0.5.0+svn4288~dfsg1-1ubuntu10.5.0+svn4288~dfsg1-40.5.0+svn4288~dfsg1-4ubuntu1
0.5.0+svn4288~dfsg1-4ubuntu1+esm1
gpac
Ubuntu:16.04:LTS
before 0.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.1, plus listed versions
0.5.2-426-gc5ad4e4+dfsg5-1build1
0.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.1
gpac
Ubuntu:18.04:LTS
before 0.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.1, plus listed versions
0.5.2-426-gc5ad4e4+dfsg5-3
0.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.1
gpac
Ubuntu:16.04:LTS
From an advisory covering 8 CVEs
before 0.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.1, plus listed versions
0.5.2-426-gc5ad4e4+dfsg5-1build1
0.5.2-426-gc5ad4e4+dfsg5-1ubuntu0.1
gpac
Ubuntu:18.04:LTS
From an advisory covering 8 CVEs
before 0.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.1, plus listed versions
0.5.2-426-gc5ad4e4+dfsg5-3
0.5.2-426-gc5ad4e4+dfsg5-3ubuntu0.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-20761 is a high vulnerability (CVSS 7.8) in Gpac Project Gpac, published February 6, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.48%, the 74th percentile. Fixed in gpac 0.5.2-426-gc5ad4e4+dfsg5-4.1.

References

Show 13 moreShow less
MoveEnter Open