CVE-2018-20962
Backpack\CRUD for Laravel XSS Vulnerability
The Backpack\CRUD Backpack component before 3.4.9 for Laravel allows XSS via the select field type.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
The Backpack\CRUD Backpack component before 3.4.9 for Laravel allows XSS via the select field type.
- Record
CVE-2018-20962- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
The Backpack\CRUD Backpack component before 3.4.9 for Laravel allows XSS via the select field type.
- Record
CVE-2018-20962- Updated
- 2026-11-02
EUVDEUVD-2022-2792 No score
The Backpack\CRUD Backpack component before 3.4.9 for Laravel allows XSS via the select field type.
- Record
EUVD-2022-2792- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6gfm-gpr3-8wh9
6.1
Backpack\CRUD for Laravel XSS Vulnerability
The Backpack\CRUD Backpack component before 3.4.9 for Laravel allows XSS via the select field type.
- Record
GHSA-6gfm-gpr3-8wh9- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
The Backpack\CRUD Backpack component before 3.4.9 for Laravel allows XSS via the select field type.
- Record
CVE-2018-20962- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-6gfm-gpr3-8wh9
6.1
Backpack\CRUD for Laravel XSS Vulnerability
The Backpack\CRUD Backpack component before 3.4.9 for Laravel allows XSS via the select field type.
- Record
GHSA-6gfm-gpr3-8wh9- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
backpack/crudPackagist |
before 3.4.9 | 3.4.9 |
backpack/crudPackagist |
before 3.4.9, plus listed versions 0.4.10.5.00.5.10.5.100.5.9 Show 45 moreShow less0.6.00.6.10.6.20.6.30.6.40.6.50.70.7.10.7.20.7.30.7.40.7.50.7.60.7.70.7.80.7.90.8.00.8.10.8.100.8.110.8.120.8.130.8.140.8.150.8.160.8.170.8.180.8.20.8.30.8.40.8.50.8.60.8.70.8.80.8.90.9.00.9.10.9.100.9.20.9.30.9.40.9.50.9.60.9.70.9.8 |
3.4.9 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-20962 is a medium vulnerability (CVSS 6.1) in Backpackforlaravel Backpack\\crud, published August 8, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.31%, the 70th percentile. Fixed in backpack/crud 3.4.9.
References
github.com/Laravel-Backpack/CRUD/compare/3.4.8...3.4.9
github.com/Laravel-Backpack/CRUD/issues/1297
github.com/Laravel-Backpack/CRUD/blob/master/CHANGELOG.md
github.com/Laravel-Backpack/CRUD/commit/8b6bd0a2d489a4690f6b1d7ace67e2f07f5f0cc6
nvd.nist.gov/vuln/detail/CVE-2018-20962
github.com/Laravel-Backpack/CRUD/blob/8b6bd0a2d489a4690f6b1d7ace67e2f07f5f0cc6/CHANGELOG.md?plain=1
github.com/advisories/GHSA-6gfm-gpr3-8wh9
github.com/Laravel-Backpack/CRUD
Left out here: 157 versions. The JSON record has them.