Every CVE Search/ Get API key

CVE-2018-25017

RawSpeed (aka librawspeed) 3.1 has a heap-based buffer overflow in TableLookUp::setTable.

9.8 CriticalFix available

RawSpeed (aka librawspeed) 3.1 has a heap-based buffer overflow in TableLookUp::setTable.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.74%Up 0.9 points since Jul 1, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

RawSpeed (aka librawspeed) 3.1 has a heap-based buffer overflow in TableLookUp::setTable.

Record
CVE-2018-25017
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

RawSpeed (aka librawspeed) 3.1 has a heap-based buffer overflow in TableLookUp::setTable.

Record
CVE-2018-25017
Updated
2026-11-02
EUVDEUVD-2018-13798 No score

RawSpeed (aka librawspeed) 3.1 has a heap-based buffer overflow in TableLookUp::setTable.

Record
EUVD-2018-13798
Updated
2026-11-03
GitHub AdvisoriesGHSA-996h-628f-g37q No score

RawSpeed (aka librawspeed) 3.1 has a heap-based buffer overflow in TableLookUp::setTable.

RawSpeed (aka librawspeed) 3.1 has a heap-based buffer overflow in TableLookUp::setTable.

Record
GHSA-996h-628f-g37q
Weakness
CWE-787
Updated
2026-11-02
OSV 9.8

RawSpeed (aka librawspeed) 3.1 has a heap-based buffer overflow in TableLookUp::setTable.

Record
CVE-2018-25017
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2018-25017 9.8

RawSpeed (aka librawspeed) 3.1 has a heap-based buffer overflow in TableLookUp::setTable.

Record
DEBIAN-CVE-2018-25017
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2018-25017 9.8

RawSpeed (aka librawspeed) 3.1 has a heap-based buffer overflow in TableLookUp::setTable.

Record
UBUNTU-CVE-2018-25017
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
darktable
Debian:12
before 2.6.0-1
2.6.0-1
darktable
Debian:13
before 2.6.0-1
2.6.0-1
darktable
Debian:14
before 2.6.0-1
2.6.0-1
darktable
Ubuntu:16.04:LTS
All versions, plus listed versions
1.6.8-11.6.9-12.0.0-12.0.1-12.0.3-1
None known
darktable
Ubuntu:18.04:LTS
All versions, plus listed versions
2.2.5-22.4.0-12.4.1-12.4.2-1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-25017 is a critical vulnerability (CVSS 9.8) in Rawspeed, published July 1, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.74%, the 77th percentile. Fixed in darktable 2.6.0-1.

References

MoveEnter Open