CVE-2018-25031
Spoofing attack in swagger-ui
Swagger UI 4.1.2 and earlier could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions. Note: This was originally claimed to be resolved in 4.1.3. However, third parties have indicated this is not resolved in 4.1.3 and even occurs in that version and possibly others.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
4.3
Swagger UI 4.1.2 and earlier could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions. Note: This was originally claimed to be resolved in 4.1.3. However, third parties have indicated this is not resolved in 4.1.3 and even occurs in that version and possibly others.
- Record
CVE-2018-25031- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:P/I:N/A:N - Weakness
- CWE-20, CWE-918, CWE-922
- Updated
- 2026-11-02
CVE List
4.3
Swagger UI 4.1.2 and earlier could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions. Note: This was originally claimed to be resolved in 4.1.3. However, third parties have indicated this is not resolved in 4.1.3 and even occurs in that version and possibly others.
- Record
CVE-2018-25031- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N - Weakness
- CWE-922, CWE-918, CWE-20
- Updated
- 2026-11-02
EUVDEUVD-2022-1408
4.3
Swagger UI 4.1.2 and earlier could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions. Note: This was originally claimed to be resolved in 4.1.3. However, third parties have indicated this is not resolved in 4.1.3 and even occurs in that version and possibly others.
- Record
EUVD-2022-1408- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-cr3q-pqgq-m8c2
4.3
Spoofing attack in swagger-ui
Swagger UI before 4.1.3 could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions.
- Record
GHSA-cr3q-pqgq-m8c2- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N - Weakness
- CWE-20, CWE-918, CWE-922
- Updated
- 2026-11-02
OSV
4.3
Swagger UI 4.1.2 and earlier could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions. Note: This was originally claimed to be resolved in 4.1.3. However, third parties have indicated this is not resolved in 4.1.3 and even occurs in that version and possibly others.
- Record
CVE-2018-25031- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N - Updated
- 2026-11-02
OSVGHSA-cr3q-pqgq-m8c2
4.3
Spoofing attack in swagger-ui
Swagger UI before 4.1.3 could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions.
- Record
GHSA-cr3q-pqgq-m8c2- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N - Weakness
- CWE-20, CWE-918, CWE-922
- Updated
- 2026-11-02
OSVCLSA-2026-1785468079 No score
TuxCare security update for swagger-ui (3 CVEs)
TuxCare rebuilt swagger-ui to address 3 CVEs. Fixed in 2.2.10-tuxcare.1.
- Record
CLSA-2026-1785468079- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
swagger-uinpm |
before 4.1.3 | 4.1.3 |
org.webjars:swagger-uiMaven |
before 4.1.3 | 4.1.3 |
swagger-uiTuxCare:npm From an advisory covering 2 CVEs |
2.2.10-tuxcare.0 up to 2.2.10-tuxcare.1, plus listed versions 2.2.10 |
2.2.10-tuxcare.1 |
org.webjars:swagger-uiMaven |
before 4.1.3, plus listed versions 2.0.122.0.142.0.14-12.0.172.0.18 Show 45 moreShow less2.0.212.0.222.0.242.1.02.1.0-M12.1.0-alpha.62.1.12.1.22.1.32.1.42.1.52.1.8-M12.2.02.2.102.2.10-12.2.22.2.52.2.62.2.83.0.103.0.143.0.173.0.183.0.193.0.23.0.203.0.213.0.33.0.43.0.53.0.73.0.83.1.23.1.43.1.53.1.63.1.73.10.03.11.03.12.03.12.13.13.03.13.13.13.23.13.3 |
4.1.3 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | afine-com/CVE-2018-25031 | 2022-05-26 |
| PoC in GitHub | rafaelcintralopes/SwaggerUI-CVE-2018-25031 | 2023-04-14 |
| PoC in GitHub | mathis2001/CVE-2018-25031 | 2023-06-28 |
| PoC in GitHub | LUCASRENAA/CVE-2018-25031 | 2023-11-16 |
| PoC in GitHub | hev0x/CVE-2018-25031-PoC | 2023-12-13 |
| PoC in GitHub | johnlaurance/CVE-2018-25031-test2 | 2024-02-22 |
| PoC in GitHub | geozin/POC-CVE-2018-25031 | 2024-05-15 |
| PoC in GitHub | h2oa/CVE-2018-25031 | 2024-05-21 |
| PoC in GitHub | natpakun/SSRF-CVE-2018-25031- | 2024-07-24 |
| PoC in GitHub | KonEch0/CVE-2018-25031-SG | 2024-11-15 |
Show 5 moreShow less
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | nigartest/CVE-2018-25031 | 2025-04-18 |
| PoC in GitHub | h4ckt0m/CVE-2018-25031-test | 2025-06-18 |
| PoC in GitHub | rasinfosec/CVE-2018-25031 | 2025-06-18 |
| PoC in GitHub | RelicHunt3r/swagger-ui | 2025-09-20 |
| PoC in GitHub | labeebSabbah/CVE-2018-25031 | 2025-11-10 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, exploits, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-25031 is a medium vulnerability (CVSS 4.3) in Smartbear Swagger Ui, published March 11, 2022. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 42.3%, the 98th percentile. Fixed in swagger-ui 4.1.3.
References
security.snyk.io/vuln/SNYK-JS-SWAGGERUI-2314885
github.com/swagger-api/swagger-ui/issues/4872
github.com/swagger-api/swagger-ui/releases/tag/v4.1.3
security.netapp.com/advisory/ntap-20220407-0004
nvd.nist.gov/vuln/detail/CVE-2018-25031
github.com/swagger-api/swagger-ui/pull/7697
github.com/advisories/GHSA-cr3q-pqgq-m8c2
github.com/swagger-api/swagger-ui
Left out here: 91 versions. The JSON record has them.