CVE-2018-25033
Out-of-bounds read in admesh
CVE-2018-25033 is a high vulnerability (CVSS 8.1) in Admesh Project Admesh, published May 8, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.07%, the 64th percentile. Fixed in admesh 0.98.5.
ADMesh through 0.98.4 has a heap-based buffer over-read in stl_update_connects_remove_1 (called from stl_remove_degenerate) in connect.c in libadmesh.a.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.1
ADMesh through 0.98.4 has a heap-based buffer over-read in stl_update_connects_remove_1 (called from stl_remove_degenerate) in connect.c in libadmesh.a.
- Record
CVE-2018-25033- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H - CVSS 2.0
- 5.8 Medium
AV:N/AC:M/Au:N/C:P/I:N/A:P - Weakness
- CWE-125
- Updated
- 2026-11-02
CVE List No score
ADMesh through 0.98.4 has a heap-based buffer over-read in stl_update_connects_remove_1 (called from stl_remove_degenerate) in connect.c in libadmesh.a.
- Record
CVE-2018-25033- Updated
- 2026-11-02
EUVDEUVD-2022-0001 No score
ADMesh through 0.98.4 has a heap-based buffer over-read in stl_update_connects_remove_1 (called from stl_remove_degenerate) in connect.c in libadmesh.a.
- Record
EUVD-2022-0001- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5jrq-582v-9767
8.1
Out-of-bounds read in admesh
ADMesh through 0.98.4 has a heap-based buffer over-read in stl_update_connects_remove_1 (called from stl_remove_degenerate) in connect.c in libadmesh.a.
- Record
GHSA-5jrq-582v-9767- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H - Weakness
- CWE-125
- Updated
- 2026-11-02
OSV
8.1
ADMesh through 0.98.4 has a heap-based buffer over-read in stl_update_connects_remove_1 (called from stl_remove_degenerate) in connect.c in libadmesh.a.
- Record
CVE-2018-25033- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-25033
8.1
ADMesh through 0.98.4 has a heap-based buffer over-read in stl_update_connects_remove_1 (called from stl_remove_degenerate) in connect.c in libadmesh.a.
- Record
DEBIAN-CVE-2018-25033- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H - Updated
- 2026-11-02
Show 4 moreShow less
OSVGHSA-5jrq-582v-9767
8.1
Out-of-bounds read in admesh
ADMesh through 0.98.4 has a heap-based buffer over-read in stl_update_connects_remove_1 (called from stl_remove_degenerate) in connect.c in libadmesh.a.
- Record
GHSA-5jrq-582v-9767- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H - Weakness
- CWE-125
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-25033
8.1
ADMesh through 0.98.4 has a heap-based buffer over-read in stl_update_connects_remove_1 (called from stl_remove_degenerate) in connect.c in libadmesh.a.
- Record
UBUNTU-CVE-2018-25033- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H - Updated
- 2026-11-02
OSVMGASA-2022-0209 No score
Updated admesh packages fix security vulnerability
ADMesh through 0.98.4 has a heap-based buffer over-read in stl_update_connects_remove_1 (called from stl_remove_degenerate) in connect.c in libadmesh.a. (CVE-2018-25033)
- Record
MGASA-2022-0209- Updated
- 2026-11-02
OSVPYSEC-2022-182 No score
ADMesh through 0.98.4 has a heap-based buffer over-read in stl_update_connects_remove_1 (called from stl_remove_degenerate) in connect.c in libadmesh.a.
- Record
PYSEC-2022-182- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
admeshPyPI |
before 0.98.5 | 0.98.5 |
admeshDebian:12 |
before 0.98.4-2 | 0.98.4-2 |
admeshDebian:13 |
before 0.98.4-2 | 0.98.4-2 |
admeshDebian:14 |
before 0.98.4-2 | 0.98.4-2 |
admeshDebian:9 |
before 0.98.2-3+deb9u1, plus listed versions 0.98.2-3 |
0.98.2-3+deb9u1 |
admeshPyPI |
before 0.98.5, plus listed versions 0.960.980.98.10.98.20.98.30.98.40.98a1 |
0.98.5 |
admeshMageia:8 |
before 0.98.4-2.1.mga8 | 0.98.4-2.1.mga8 |
admeshUbuntu:16.04:LTS |
All versions, plus listed versions 0.98.2-2 |
None known |
admeshUbuntu:18.04:LTS |
All versions, plus listed versions 0.98.3-1ubuntu10.98.3-2 |
None known |
admeshUbuntu:20.04:LTS |
All versions, plus listed versions 0.98.3-40.98.4-1 |
None known |
Show 5 moreShow less
| Package | Affected | Fixed |
|---|---|---|
admeshUbuntu:22.04:LTS |
All versions, plus listed versions 0.98.4-1 |
None known |
admeshUbuntu:24.04:LTS |
All versions, plus listed versions 0.98.4-20.98.5-10.98.5-1build1 |
None known |
admeshUbuntu:25.10 |
All versions, plus listed versions 0.98.5-1build1 |
None known |
admeshUbuntu:26.10 |
All versions, plus listed versions 0.98.5-1build2 |
None known |
admeshUbuntu:26.04:LTS |
All versions, plus listed versions 0.98.5-1build10.98.5-1build2 |
None known |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
github.com/admesh/admesh/issues/28
lists.debian.org/debian-lts-announce/2022/05/msg00029.html
nvd.nist.gov/vuln/detail/CVE-2018-25033
github.com/advisories/GHSA-5jrq-582v-9767
github.com/pypa/advisory-database/tree/main/vulns/admesh/PYSEC-2022-182.yaml
security-tracker.debian.org/tracker/CVE-2018-25033