Every CVE Search/ Get API key

CVE-2018-3716

Stored Cross-Site Scripting in simplehttpserver

5.4 MediumFix available

CVE-2018-3716 is a medium vulnerability (CVSS 5.4) in Hackerone Simplehttpserver Node Module, published June 7, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.63%, the 50th percentile. Fixed in simplehttpserver 0.1.0.

simplehttpserver node module suffers from a Cross-Site Scripting vulnerability to a lack of validation of file names.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.63%Up 0.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 5.4

simplehttpserver node module suffers from a Cross-Site Scripting vulnerability to a lack of validation of file names.

Record
CVE-2018-3716
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

simplehttpserver node module suffers from a Cross-Site Scripting vulnerability to a lack of validation of file names.

Record
CVE-2018-3716
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2018-0291 No score

simplehttpserver node module suffers from a Cross-Site Scripting vulnerability to a lack of validation of file names.

Record
EUVD-2018-0291
Updated
2026-11-03
GitHub AdvisoriesGHSA-jrhj-2j3q-xf3v 5.4

Stored Cross-Site Scripting in simplehttpserver

Simplehttpserver prior to version 0.1.0 are vulnerable to stored cross-site scripting (XSS). To be exploited an attacker needs to control the filename of a file that is used in the directory listing output. This version is patched in 0.1.0

Record
GHSA-jrhj-2j3q-xf3v
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-jrhj-2j3q-xf3v 5.4

Stored Cross-Site Scripting in simplehttpserver

Simplehttpserver prior to version 0.1.0 are vulnerable to stored cross-site scripting (XSS). To be exploited an attacker needs to control the filename of a file that is used in the directory listing output. This version is patched in 0.1.0

Record
GHSA-jrhj-2j3q-xf3v
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
simplehttpserver
npm
before 0.1.0
0.1.0

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

MoveEnter Open