Every CVE Search/ Get API key

CVE-2018-3729

Path Traversal in localhost-now

7.5 HighFix available

localhost-now node module suffers from a Path Traversal vulnerability due to lack of validation of file, which allows a malicious user to read content of any file with known path.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

1.99%Up 1.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

localhost-now node module suffers from a Path Traversal vulnerability due to lack of validation of file, which allows a malicious user to read content of any file with known path.

Record
CVE-2018-3729
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
CVE List No score

localhost-now node module suffers from a Path Traversal vulnerability due to lack of validation of file, which allows a malicious user to read content of any file with known path.

Record
CVE-2018-3729
Weakness
CWE-22
Updated
2026-11-02
EUVDEUVD-2018-0206 No score

localhost-now node module suffers from a Path Traversal vulnerability due to lack of validation of file, which allows a malicious user to read content of any file with known path.

Record
EUVD-2018-0206
Updated
2026-11-03
GitHub AdvisoriesGHSA-2gjg-5x33-mmp2 7.5

Path Traversal in localhost-now

Versions of localhost-now before 1.0.2 are vulnerable to path traversal. This allows a remote attacker to read the content of an arbitrary file.

Recommendation

Update to version 1.0.2 or later.

Record
GHSA-2gjg-5x33-mmp2
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02
OSVGHSA-2gjg-5x33-mmp2 7.5

Path Traversal in localhost-now

Versions of localhost-now before 1.0.2 are vulnerable to path traversal. This allows a remote attacker to read the content of an arbitrary file.

Recommendation

Update to version 1.0.2 or later.

Record
GHSA-2gjg-5x33-mmp2
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-22
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
localhost-now
npm
before 1.0.2
1.0.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-3729 is a high vulnerability (CVSS 7.5) in Hackerone Localhost-now Node Module, published June 7, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.99%, the 80th percentile. Fixed in localhost-now 1.0.2.

References

MoveEnter Open