CVE-2018-3757
Command Injection in pdf-image
Command injection exists in pdf-image v2.0.0 due to an unescaped string parameter.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Command injection exists in pdf-image v2.0.0 due to an unescaped string parameter.
- Record
CVE-2018-3757- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 10.0 High
AV:N/AC:L/Au:N/C:C/I:C/A:C - Weakness
- CWE-78
- Updated
- 2026-11-02
CVE List No score
Command injection exists in pdf-image v2.0.0 due to an unescaped string parameter.
- Record
CVE-2018-3757- Updated
- 2026-11-02
EUVDEUVD-2020-0787 No score
Command injection exists in pdf-image v2.0.0 due to an unescaped string parameter.
- Record
EUVD-2020-0787- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5gwh-g79j-vh4q
9.8
Command Injection in pdf-image
Versions of pdf-image before 2.0.0 are vulnerable to command injection. This vulnerability is exploitable if the attacker has control over the pdfFilePath variable passed into pdf-image.
Recommendation
Update to version 2.0.0 or later.
- Record
GHSA-5gwh-g79j-vh4q- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
OSV
9.8
Command injection exists in pdf-image v2.0.0 due to an unescaped string parameter.
- Record
CVE-2018-3757- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-5gwh-g79j-vh4q
9.8
Command Injection in pdf-image
Versions of pdf-image before 2.0.0 are vulnerable to command injection. This vulnerability is exploitable if the attacker has control over the pdfFilePath variable passed into pdf-image.
Recommendation
Update to version 2.0.0 or later.
- Record
GHSA-5gwh-g79j-vh4q- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pdf-imagenpm |
before 2.0.0 | 2.0.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-3757 is a critical vulnerability (CVSS 9.8) in Pdf-image Project Pdf-image, published June 1, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.62%, the 91st percentile. Fixed in pdf-image 2.0.0.