Every CVE Search/ Get API key

CVE-2018-3772

Command Injection in whereis

9.8 CriticalFix available

Concatenating unsanitized user input in the whereis npm module < 0.4.1 allowed an attacker to execute arbitrary commands. The whereis module is deprecated and it is recommended to use the which npm module instead.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.76%Up 2.0 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

Concatenating unsanitized user input in the whereis npm module < 0.4.1 allowed an attacker to execute arbitrary commands. The whereis module is deprecated and it is recommended to use the which npm module instead.

Record
CVE-2018-3772
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-77, CWE-20
Updated
2026-11-02
CVE List No score

Concatenating unsanitized user input in the whereis npm module < 0.4.1 allowed an attacker to execute arbitrary commands. The whereis module is deprecated and it is recommended to use the which npm module instead.

Record
CVE-2018-3772
Weakness
CWE-77
Updated
2026-11-02
EUVDEUVD-2018-0333 No score

Concatenating unsanitized user input in the whereis npm module < 0.4.1 allowed an attacker to execute arbitrary commands. The whereis module is deprecated and it is recommended to use the which npm module instead.

Record
EUVD-2018-0333
Updated
2026-11-03
GitHub AdvisoriesGHSA-wjr4-2jgw-hmv8 9.8

Command Injection in whereis

Versions of whereis before 0.4.1 are vulnerable to command injection if untrusted user input is passed into whereis.

Recommendation

Update to version 0.4.1 or later.

Record
GHSA-wjr4-2jgw-hmv8
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-77
Updated
2026-11-02
OSVGHSA-wjr4-2jgw-hmv8 9.8

Command Injection in whereis

Versions of whereis before 0.4.1 are vulnerable to command injection if untrusted user input is passed into whereis.

Recommendation

Update to version 0.4.1 or later.

Record
GHSA-wjr4-2jgw-hmv8
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-77
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
whereis
npm
before 0.4.1
0.4.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-3772 is a critical vulnerability (CVSS 9.8) in Https://github.com/vvo Whereis, published July 30, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.76%, the 86th percentile. Fixed in whereis 0.4.1.

References

MoveEnter Open