Every CVE Search/ Get API key

CVE-2018-3773

metascraper before v5.2.0 vulnerable to stored cross-site scripting

6.1 MediumFix available

There is a stored Cross-Site Scripting vulnerability in Open Graph meta properties read by the metascrape npm module <= 3.9.2.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.93%Up 0.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

There is a stored Cross-Site Scripting vulnerability in Open Graph meta properties read by the metascrape npm module <= 3.9.2.

Record
CVE-2018-3773
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

There is a stored Cross-Site Scripting vulnerability in Open Graph meta properties read by the metascrape npm module <= 3.9.2.

Record
CVE-2018-3773
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2018-0381 No score

There is a stored Cross-Site Scripting vulnerability in Open Graph meta properties read by the metascrape npm module <= 3.9.2.

Record
EUVD-2018-0381
Updated
2026-11-03
GitHub AdvisoriesGHSA-8f64-q7jc-ccgp 6.1

metascraper before v5.2.0 vulnerable to stored cross-site scripting

Versions of metascraper prior to 5.2.0 are vulnerable to stored cross-site scripting (XSS).

Recommendation

Upgrade to version 5.2.0 or later.

Record
GHSA-8f64-q7jc-ccgp
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

There is a stored Cross-Site Scripting vulnerability in Open Graph meta properties read by the metascrape npm module <= 3.9.2.

Record
CVE-2018-3773
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-8f64-q7jc-ccgp 6.1

metascraper before v5.2.0 vulnerable to stored cross-site scripting

Versions of metascraper prior to 5.2.0 are vulnerable to stored cross-site scripting (XSS).

Recommendation

Upgrade to version 5.2.0 or later.

Record
GHSA-8f64-q7jc-ccgp
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
metascraper
npm
before 5.2.0
5.2.0

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-3773 is a medium vulnerability (CVSS 6.1) in Https://github.com/microlinkhq Metascraper, published July 30, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.93%, the 60th percentile. Fixed in metascraper 5.2.0.

References

MoveEnter Open