CVE-2018-4934
Adobe Flash Player versions 29.0.0.113 and earlier have an exploitable out-of-bounds read...
CVE-2018-4934 is a medium vulnerability (CVSS 6.5) in Adobe Flash Player, published May 19, 2018. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 19.7%, the 97th percentile. Fixed in flash-plugin 0:29.0.0.140-1.el6_9.
Adobe Flash Player versions 29.0.0.113 and earlier have an exploitable out-of-bounds read vulnerability. Successful exploitation could lead to information disclosure.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.5
Adobe Flash Player versions 29.0.0.113 and earlier have an exploitable out-of-bounds read vulnerability. Successful exploitation could lead to information disclosure.
- Record
CVE-2018-4934- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:P/I:N/A:N - Weakness
- CWE-125
- Updated
- 2026-11-02
CVE List No score
Adobe Flash Player versions 29.0.0.113 and earlier have an exploitable out-of-bounds read vulnerability. Successful exploitation could lead to information disclosure.
- Record
CVE-2018-4934- Updated
- 2026-11-02
EUVDEUVD-2018-16719 No score
Adobe Flash Player versions 29.0.0.113 and earlier have an exploitable out-of-bounds read vulnerability. Successful exploitation could lead to information disclosure.
- Record
EUVD-2018-16719- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-jfwg-vwv6-72fc
7.5
Adobe Flash Player versions 29.0.0.113 and earlier have an exploitable out-of-bounds read...
Adobe Flash Player versions 29.0.0.113 and earlier have an exploitable out-of-bounds read vulnerability. Successful exploitation could lead to information disclosure.
- Record
GHSA-jfwg-vwv6-72fc- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-125
- Updated
- 2026-11-02
OSVRHSA-2018:1119
8.8
Red Hat Security Advisory: flash-plugin security update
- Record
RHSA-2018:1119- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-4934
6.5
Adobe Flash Player versions 29.0.0.113 and earlier have an exploitable out-of-bounds read vulnerability. Successful exploitation could lead to information disclosure.
- Record
UBUNTU-CVE-2018-4934- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N - CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
flash-pluginRed Hat:rhel_extras:6 |
before 0:29.0.0.140-1.el6_9 | 0:29.0.0.140-1.el6_9 |
flashplugin-nonfreeUbuntu:14.04:LTS |
before 29.0.0.140ubuntu0.14.04.1, plus listed versions 11.2.202.310ubuntu111.2.202.327ubuntu0.13.10.111.2.202.332ubuntu111.2.202.335ubuntu111.2.202.336ubuntu1 Show 45 moreShow less11.2.202.341ubuntu111.2.202.346ubuntu111.2.202.350ubuntu111.2.202.356ubuntu0.14.04.111.2.202.359ubuntu0.14.04.111.2.202.378ubuntu0.14.04.111.2.202.394ubuntu0.14.04.111.2.202.400ubuntu0.14.04.111.2.202.406ubuntu0.14.04.111.2.202.406ubuntu0.14.04.211.2.202.411ubuntu0.14.04.111.2.202.418ubuntu0.14.04.111.2.202.424ubuntu0.14.04.111.2.202.425ubuntu0.14.04.111.2.202.429ubuntu0.14.04.111.2.202.438ubuntu0.14.04.111.2.202.440ubuntu0.14.04.111.2.202.442ubuntu0.14.04.111.2.202.451ubuntu0.14.04.111.2.202.457ubuntu0.14.04.111.2.202.460ubuntu0.14.04.111.2.202.466ubuntu0.14.04.111.2.202.468ubuntu0.14.04.111.2.202.481ubuntu0.14.04.111.2.202.481ubuntu0.14.04.211.2.202.491ubuntu0.14.04.111.2.202.508ubuntu0.14.04.111.2.202.521ubuntu0.14.04.111.2.202.535ubuntu0.14.04.111.2.202.540ubuntu0.14.04.211.2.202.548ubuntu0.14.04.111.2.202.554ubuntu0.14.04.111.2.202.559ubuntu0.14.04.111.2.202.569ubuntu0.14.04.111.2.202.577ubuntu0.14.04.111.2.202.616ubuntu0.14.04.111.2.202.621ubuntu0.14.04.111.2.202.626ubuntu0.14.04.111.2.202.632ubuntu0.14.04.111.2.202.635ubuntu0.14.04.111.2.202.637ubuntu0.14.04.111.2.202.643ubuntu0.14.04.111.2.202.644ubuntu0.14.04.124.0.0.186ubuntu0.14.04.124.0.0.194ubuntu0.14.04.1 |
29.0.0.140ubuntu0.14.04.1 |
flashplugin-nonfreeUbuntu:16.04:LTS |
before 29.0.0.140ubuntu0.16.04.1, plus listed versions 11.2.202.540ubuntu211.2.202.548ubuntu111.2.202.554ubuntu111.2.202.559ubuntu111.2.202.569ubuntu1 Show 28 moreShow less11.2.202.577ubuntu111.2.202.616ubuntu111.2.202.621ubuntu0.16.04.111.2.202.626ubuntu0.16.04.111.2.202.632ubuntu0.16.04.111.2.202.635ubuntu0.16.04.111.2.202.637ubuntu0.16.04.111.2.202.643ubuntu0.16.04.111.2.202.644ubuntu0.16.04.124.0.0.186ubuntu0.16.04.124.0.0.194ubuntu0.16.04.124.0.0.221ubuntu0.16.04.125.0.0.127ubuntu0.16.04.125.0.0.148ubuntu0.16.04.125.0.0.171ubuntu0.16.04.126.0.0.126ubuntu0.16.04.126.0.0.131ubuntu0.16.04.126.0.0.137ubuntu0.16.04.126.0.0.151ubuntu0.16.04.127.0.0.130ubuntu0.16.04.127.0.0.159ubuntu0.16.04.127.0.0.170ubuntu0.16.04.127.0.0.183ubuntu0.16.04.127.0.0.187ubuntu0.16.04.128.0.0.126ubuntu0.16.04.128.0.0.137ubuntu0.16.04.128.0.0.161ubuntu0.16.04.129.0.0.113ubuntu0.16.04.1 |
29.0.0.140ubuntu0.16.04.1 |
flashplugin-nonfreeUbuntu:18.04:LTS |
before 29.0.0.140ubuntu1, plus listed versions 27.0.0.170ubuntu127.0.0.187ubuntu128.0.0.126ubuntu128.0.0.137ubuntu128.0.0.161ubuntu128.0.0.161ubuntu228.0.0.161ubuntu329.0.0.113ubuntu1 |
29.0.0.140ubuntu1 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | Adobe Flash - Info Leak in Image Inflation | 2018-04-24 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV |
References
securityfocus.com/bid/103708
access.redhat.com/errata/RHSA-2018:1119
securitytracker.com/id/1040648
security.gentoo.org/glsa/201804-11
exploit-db.com/exploits/44528
helpx.adobe.com/security/products/flash-player/apsb18-08.html
Show 25 moreShow less
nvd.nist.gov/vuln/detail/CVE-2018-4934
github.com/advisories/GHSA-jfwg-vwv6-72fc
access.redhat.com/security/updates/classification
bugzilla.redhat.com/show_bug.cgi?id=1565799
bugzilla.redhat.com/show_bug.cgi?id=1565800
security.access.redhat.com/data/csaf/v2/advisories/2018/rhsa-2018_1119.json
access.redhat.com/security/cve/CVE-2018-4932
cve.org/CVERecord?id=CVE-2018-4932
nvd.nist.gov/vuln/detail/CVE-2018-4932
access.redhat.com/security/cve/CVE-2018-4933
cve.org/CVERecord?id=CVE-2018-4933
nvd.nist.gov/vuln/detail/CVE-2018-4933
access.redhat.com/security/cve/CVE-2018-4934
cve.org/CVERecord?id=CVE-2018-4934
access.redhat.com/security/cve/CVE-2018-4935
cve.org/CVERecord?id=CVE-2018-4935
nvd.nist.gov/vuln/detail/CVE-2018-4935
access.redhat.com/security/cve/CVE-2018-4936
cve.org/CVERecord?id=CVE-2018-4936
nvd.nist.gov/vuln/detail/CVE-2018-4936
access.redhat.com/security/cve/CVE-2018-4937
cve.org/CVERecord?id=CVE-2018-4937
nvd.nist.gov/vuln/detail/CVE-2018-4937
ubuntu.com/security/CVE-2018-4934
rhn.redhat.com/errata/RHSA-2018-1119.html
Left out here: 17 versions. The JSON record has them.