CVE-2018-5478
Contao Cross-site Scripting vulnerabililty
Contao 3.x before 3.5.32 allows XSS via the unsubscribe module in the frontend newsletter extension.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Contao 3.x before 3.5.32 allows XSS via the unsubscribe module in the frontend newsletter extension.
- Record
CVE-2018-5478- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Contao 3.x before 3.5.32 allows XSS via the unsubscribe module in the frontend newsletter extension.
- Record
CVE-2018-5478- Updated
- 2026-11-02
EUVDEUVD-2023-2550 No score
Contao 3.x before 3.5.32 allows XSS via the unsubscribe module in the frontend newsletter extension.
- Record
EUVD-2023-2550- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-mpg7-2rx9-h5qp
6.1
Contao Cross-site Scripting vulnerabililty
Contao 3.x before 3.5.32 allows Cross-site Scripting (XSS) via the unsubscribe module in the frontend newsletter extension.
- Record
GHSA-mpg7-2rx9-h5qp- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-mpg7-2rx9-h5qp
6.1
Contao Cross-site Scripting vulnerabililty
Contao 3.x before 3.5.32 allows Cross-site Scripting (XSS) via the unsubscribe module in the frontend newsletter extension.
- Record
GHSA-mpg7-2rx9-h5qp- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
contao/corePackagist |
3.0.0 up to 3.5.32 | 3.5.32 |
contao/corePackagist |
3.0.0 up to 3.5.32, plus listed versions 3.0.13.0.23.0.33.0.43.0.5 Show 45 moreShow less3.0.63.1.03.1.13.1.23.1.33.1.43.1.53.1.RC13.1.beta13.2.03.2.13.2.103.2.113.2.123.2.133.2.143.2.153.2.163.2.173.2.183.2.193.2.23.2.203.2.213.2.33.2.43.2.53.2.63.2.73.2.83.2.93.2.RC13.2.beta13.2.beta23.3.03.3.0-RC13.3.0-RC23.3.0-beta13.3.13.3.23.3.33.3.43.3.53.3.63.3.7 |
3.5.32 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-5478 is a medium vulnerability (CVSS 6.1) in Contao, published September 21, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.41%, the 36th percentile. Fixed in contao/core 3.5.32.
References
github.com/FriendsOfPHP/security-advisories/blob/master/contao/core/CVE-2018-5478.yaml
security.snyk.io/vuln/SNYK-PHP-CONTAOCORE-70397
nvd.nist.gov/vuln/detail/CVE-2018-5478
github.com/contao/core/commit/3123d6527ae6c46087b0ad8061eb8651cb645b8d
contao.org/en/news/contao-3_5_32.html
github.com/advisories/GHSA-mpg7-2rx9-h5qp
github.com/contao/core
Left out here: 42 versions. The JSON record has them.