Every CVE Search/ Get API key

CVE-2018-6508

Puppet Enterprise 2017.3.x prior to 2017.3.3 are vulnerable to a remote execution bug when a...

8.0 HighFix available

CVE-2018-6508 is a high vulnerability (CVSS 8.0) in Perforce Puppet Enterprise, published February 9, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.87%, the 79th percentile. Fixed in puppet-module-puppetlabs-apache 3.0.0-1.

Puppet Enterprise 2017.3.x prior to 2017.3.3 are vulnerable to a remote execution bug when a specially crafted string was passed into the facter_task or puppet_conf tasks. This vulnerability only affects tasks in the affected modules, if you are not using puppet tasks you are not affected by this vulnerability.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.87%Up 0.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.0

Puppet Enterprise 2017.3.x prior to 2017.3.3 are vulnerable to a remote execution bug when a specially crafted string was passed into the facter_task or puppet_conf tasks. This vulnerability only affects tasks in the affected modules, if you are not using puppet tasks you are not affected by this vulnerability.

Record
CVE-2018-6508
CVSS 3.0
8.0 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.0 MediumAV:N/AC:M/Au:S/C:P/I:P/A:P
Weakness
CWE-134
Updated
2026-11-02
CVE List No score

Puppet Enterprise 2017.3.x prior to 2017.3.3 are vulnerable to a remote execution bug when a specially crafted string was passed into the facter_task or puppet_conf tasks. This vulnerability only affects tasks in the affected modules, if you are not using puppet tasks you are not affected by this vulnerability.

Record
CVE-2018-6508
Updated
2026-11-02
EUVDEUVD-2018-18264 No score

Puppet Enterprise 2017.3.x prior to 2017.3.3 are vulnerable to a remote execution bug when a specially crafted string was passed into the facter_task or puppet_conf tasks. This vulnerability only affects tasks in the affected modules, if you are not using puppet tasks you are not affected by this vulnerability.

Record
EUVD-2018-18264
Updated
2026-11-03
GitHub AdvisoriesGHSA-j433-wpfx-cxg3 8.0

Puppet Enterprise 2017.3.x prior to 2017.3.3 are vulnerable to a remote execution bug when a...

Puppet Enterprise 2017.3.x prior to 2017.3.3 are vulnerable to a remote execution bug when a specially crafted string was passed into the facter_task or puppet_conf tasks. This vulnerability only affects tasks in the affected modules, if you are not using puppet tasks you are not affected by this vulnerability.

Record
GHSA-j433-wpfx-cxg3
CVSS 3.0
8.0 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-134
Updated
2026-11-02
OSV 8.0

Puppet Enterprise 2017.3.x prior to 2017.3.3 are vulnerable to a remote execution bug when a specially crafted string was passed into the facter_task or puppet_conf tasks. This vulnerability only affects tasks in the affected modules, if you are not using puppet tasks you are not affected by this vulnerability.

Record
CVE-2018-6508
CVSS 3.0
8.0 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2018-6508 8.0

Puppet Enterprise 2017.3.x prior to 2017.3.3 are vulnerable to a remote execution bug when a specially crafted string was passed into the facter_task or puppet_conf tasks. This vulnerability only affects tasks in the affected modules, if you are not using puppet tasks you are not affected by this vulnerability.

Record
DEBIAN-CVE-2018-6508
CVSS 3.0
8.0 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2018-6508 8.0

Puppet Enterprise 2017.3.x prior to 2017.3.3 are vulnerable to a remote execution bug when a specially crafted string was passed into the facter_task or puppet_conf tasks. This vulnerability only affects tasks in the affected modules, if you are not using puppet tasks you are not affected by this vulnerability.

Record
UBUNTU-CVE-2018-6508
CVSS 3.0
8.0 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
puppet-module-puppetlabs-apache
Debian:12
before 3.0.0-1
3.0.0-1
puppet-module-puppetlabs-apache
Debian:13
before 3.0.0-1
3.0.0-1
puppet-module-puppetlabs-apt
Debian:12
before 4.5.1-1
4.5.1-1
puppet-module-puppetlabs-apt
Debian:13
before 4.5.1-1
4.5.1-1
puppet-module-puppetlabs-apt
Debian:14
before 4.5.1-1
4.5.1-1
puppet-module-puppetlabs-mysql
Debian:12
before 5.3.0-1
5.3.0-1
puppet-module-puppetlabs-mysql
Debian:13
before 5.3.0-1
5.3.0-1
puppet-module-puppetlabs-mysql
Debian:14
before 5.3.0-1
5.3.0-1
puppet-module-puppetlabs-apache
Ubuntu:16.04:LTS
All versions, plus listed versions
1.1.1-11.6.0-1
None known
puppet-module-puppetlabs-apt
Ubuntu:16.04:LTS
All versions, plus listed versions
1.6.0-22.2.0-1
None known
Show 22 moreShow less
Affected packages
PackageAffectedFixed
puppet-module-puppetlabs-mysql
Ubuntu:16.04:LTS
All versions, plus listed versions
2.3.1-13.6.1-1
None known
puppet-module-puppetlabs-apache
Ubuntu:18.04:LTS
All versions, plus listed versions
1.10.0-13.0.0-1
None known
puppet-module-puppetlabs-apt
Ubuntu:18.04:LTS
All versions, plus listed versions
2.3.0-14.4.1-14.5.1-1
None known
puppet-module-puppetlabs-mysql
Ubuntu:18.04:LTS
All versions, plus listed versions
3.10.0-1
None known
puppet-module-puppetlabs-apache
Ubuntu:20.04:LTS
All versions, plus listed versions
3.4.0-1
None known
puppet-module-puppetlabs-apt
Ubuntu:20.04:LTS
All versions, plus listed versions
6.1.1-1
None known
puppet-module-puppetlabs-mysql
Ubuntu:20.04:LTS
All versions, plus listed versions
5.3.0-1ubuntu18.1.0-2ubuntu1
None known
puppet-module-puppetlabs-apache
Ubuntu:22.04:LTS
All versions, plus listed versions
5.5.0-2
None known
puppet-module-puppetlabs-apt
Ubuntu:22.04:LTS
All versions, plus listed versions
6.1.1-1
None known
puppet-module-puppetlabs-mysql
Ubuntu:22.04:LTS
All versions, plus listed versions
8.1.0-5ubuntu1
None known
puppet-module-puppetlabs-apache
Ubuntu:24.04:LTS
All versions, plus listed versions
5.5.0-212.0.2-1
None known
puppet-module-puppetlabs-apt
Ubuntu:24.04:LTS
All versions, plus listed versions
9.0.1-19.4.0-1
None known
puppet-module-puppetlabs-mysql
Ubuntu:24.04:LTS
All versions, plus listed versions
8.1.0-7ubuntu1
None known
puppet-module-puppetlabs-apache
Ubuntu:25.10
All versions, plus listed versions
12.2.0-1
None known
puppet-module-puppetlabs-apt
Ubuntu:25.10
All versions, plus listed versions
9.4.0-1
None known
puppet-module-puppetlabs-mysql
Ubuntu:25.10
All versions, plus listed versions
8.1.0-7ubuntu1
None known
puppet-module-puppetlabs-apache
Ubuntu:26.10
All versions, plus listed versions
12.2.0-1build1
None known
puppet-module-puppetlabs-apt
Ubuntu:26.10
All versions, plus listed versions
9.4.0-1build1
None known
puppet-module-puppetlabs-mysql
Ubuntu:26.10
All versions, plus listed versions
8.1.0-7ubuntu2
None known
puppet-module-puppetlabs-apache
Ubuntu:26.04:LTS
All versions, plus listed versions
12.2.0-112.2.0-1build1
None known
puppet-module-puppetlabs-apt
Ubuntu:26.04:LTS
All versions, plus listed versions
9.4.0-19.4.0-1build1
None known
puppet-module-puppetlabs-mysql
Ubuntu:26.04:LTS
All versions, plus listed versions
8.1.0-7ubuntu18.1.0-7ubuntu2
None known

History

History
WhenChangedSources
2026-11-03aliases, productsEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 6 moreShow less
MoveEnter Open