CVE-2018-6521
SimpleSAMLphp Use of insecure connection charset (sqlauth module)
CVE-2018-6521 is a critical vulnerability (CVSS 9.8) in Simplesamlphp, published February 2, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.05%, the 87th percentile. Fixed in simplesamlphp/simplesamlphp 1.15.2.
The sqlauth module in SimpleSAMLphp before 1.15.2 relies on the MySQL utf8 charset, which truncates queries upon encountering four-byte characters. There might be a scenario in which this allows remote attackers to bypass intended access restrictions.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
The sqlauth module in SimpleSAMLphp before 1.15.2 relies on the MySQL utf8 charset, which truncates queries upon encountering four-byte characters. There might be a scenario in which this allows remote attackers to bypass intended access restrictions.
- Record
CVE-2018-6521- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
The sqlauth module in SimpleSAMLphp before 1.15.2 relies on the MySQL utf8 charset, which truncates queries upon encountering four-byte characters. There might be a scenario in which this allows remote attackers to bypass intended access restrictions.
- Record
CVE-2018-6521- Updated
- 2026-11-02
EUVDEUVD-2022-5030 No score
The sqlauth module in SimpleSAMLphp before 1.15.2 relies on the MySQL utf8 charset, which truncates queries upon encountering four-byte characters. There might be a scenario in which this allows remote attackers to bypass intended access restrictions.
- Record
EUVD-2022-5030- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qv5p-6wrc-79wg
9.8
SimpleSAMLphp Use of insecure connection charset (sqlauth module)
The sqlauth module in SimpleSAMLphp before 1.15.2 relies on the MySQL utf8 charset, which truncates queries upon encountering four-byte characters. There might be a scenario in which this allows remote attackers to bypass intended access restrictions.
- Record
GHSA-qv5p-6wrc-79wg- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV
9.8
The sqlauth module in SimpleSAMLphp before 1.15.2 relies on the MySQL utf8 charset, which truncates queries upon encountering four-byte characters. There might be a scenario in which this allows remote attackers to bypass intended access restrictions.
- Record
CVE-2018-6521- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-6521
9.8
The sqlauth module in SimpleSAMLphp before 1.15.2 relies on the MySQL utf8 charset, which truncates queries upon encountering four-byte characters. There might be a scenario in which this allows remote attackers to bypass intended access restrictions.
- Record
DEBIAN-CVE-2018-6521- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-qv5p-6wrc-79wg
9.8
SimpleSAMLphp Use of insecure connection charset (sqlauth module)
The sqlauth module in SimpleSAMLphp before 1.15.2 relies on the MySQL utf8 charset, which truncates queries upon encountering four-byte characters. There might be a scenario in which this allows remote attackers to bypass intended access restrictions.
- Record
GHSA-qv5p-6wrc-79wg- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-6521
9.8
The sqlauth module in SimpleSAMLphp before 1.15.2 relies on the MySQL utf8 charset, which truncates queries upon encountering four-byte characters. There might be a scenario in which this allows remote attackers to bypass intended access restrictions.
- Record
UBUNTU-CVE-2018-6521- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
simplesamlphp/simplesamlphpPackagist |
before 1.15.2 | 1.15.2 |
simplesamlphpDebian:12 |
before 1.15.2-1 | 1.15.2-1 |
simplesamlphpDebian:14 |
before 1.15.2-1, plus listed versions 1.10.0-11.11.0-11.12.0-11.12.0~rc1-11.12.0~rc2-1 Show 36 moreShow less1.13.0-11.13.1-11.13.1-21.13.2-11.14.0-11.14.1-11.14.10-11.14.11-11.14.15-11.14.2-11.14.2-21.14.3-11.14.4-11.14.5-11.14.6-11.14.7-11.14.8-11.14.9-11.15.0-11.15.1-11.6.0-11.6.1-11.6.2-11.6.3-11.6.3-21.6.3-31.7.0-11.7.0-21.8.0-11.8.1-11.8.2-11.9.0-11.9.0~rc1-11.9.0~rc2-11.9.1-11.9.2-1 |
1.15.2-1 |
simplesamlphpDebian:7 |
before 1.9.2-1+deb7u2, plus listed versions 1.9.2-11.9.2-1+deb7u1 |
1.9.2-1+deb7u2 |
simplesamlphpDebian:8 |
before 1.13.1-2+deb8u1, plus listed versions 1.13.1-2 |
1.13.1-2+deb8u1 |
simplesamlphpDebian:9 |
before 1.14.11-1+deb9u1, plus listed versions 1.14.11-1 |
1.14.11-1+deb9u1 |
simplesamlphp/simplesamlphpPackagist |
before 1.15.2, plus listed versions v1.12.0v1.13.0v1.13.0-rc1v1.13.0-rc2v1.13.1 Show 25 moreShow lessv1.13.2v1.14.0v1.14.0-rc1v1.14.1v1.14.10v1.14.11v1.14.12v1.14.13v1.14.14v1.14.15v1.14.16v1.14.17v1.14.2v1.14.3v1.14.4v1.14.5v1.14.6v1.14.7v1.14.8v1.14.9v1.15.0v1.15.0-rc1v1.15.0-rc2v1.15.0-rc3v1.15.1 |
1.15.2 |
simplesamlphpUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 1.13.2-11.14.0-11.14.0-1ubuntu21.14.0-1ubuntu2+esm1 |
None known |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
simplesamlphp.org/security/201801-03
lists.debian.org/debian-lts-announce/2018/02/msg00008.html
debian.org/security/2018/dsa-4127
nvd.nist.gov/vuln/detail/CVE-2018-6521
github.com/FriendsOfPHP/security-advisories/blob/master/simplesamlphp/simplesamlphp/CVE-2018-6521.yaml
github.com/advisories/GHSA-qv5p-6wrc-79wg