CVE-2018-6553
AppArmor cupsd Sandbox Bypass Due to Use of Hard Links
The CUPS AppArmor profile incorrectly confined the dnssd backend due to use of hard links. A local attacker could possibly use this issue to escape confinement. This flaw affects versions prior to 2.2.7-1ubuntu2.1 in Ubuntu 18.04 LTS, prior to 2.2.4-7ubuntu3.1 in Ubuntu 17.10, prior to 2.1.3-4ubuntu0.5 in Ubuntu 16.04 LTS, and prior to 1.7.2-0ubuntu1.10 in Ubuntu 14.04 LTS.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
The CUPS AppArmor profile incorrectly confined the dnssd backend due to use of hard links. A local attacker could possibly use this issue to escape confinement. This flaw affects versions prior to 2.2.7-1ubuntu2.1 in Ubuntu 18.04 LTS, prior to 2.2.4-7ubuntu3.1 in Ubuntu 17.10, prior to 2.1.3-4ubuntu0.5 in Ubuntu 16.04 LTS, and prior to 1.7.2-0ubuntu1.10 in Ubuntu 14.04 LTS.
- Record
CVE-2018-6553- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H - CVSS 2.0
- 4.6 Medium
AV:L/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
AppArmor cupsd Sandbox Bypass Due to Use of Hard Links
The CUPS AppArmor profile incorrectly confined the dnssd backend due to use of hard links. A local attacker could possibly use this issue to escape confinement. This flaw affects versions prior to 2.2.7-1ubuntu2.1 in Ubuntu 18.04 LTS, prior to 2.2.4-7ubuntu3.1 in Ubuntu 17.10, prior to 2.1.3-4ubuntu0.5 in Ubuntu 16.04 LTS, and prior to 1.7.2-0ubuntu1.10 in Ubuntu 14.04 LTS.
- Record
CVE-2018-6553- Updated
- 2026-11-02
EUVDEUVD-2018-18305 No score
The CUPS AppArmor profile incorrectly confined the dnssd backend due to use of hard links. A local attacker could possibly use this issue to escape confinement. This flaw affects versions prior to 2.2.7-1ubuntu2.1 in Ubuntu 18.04 LTS, prior to 2.2.4-7ubuntu3.1 in Ubuntu 17.10, prior to 2.1.3-4ubuntu0.5 in Ubuntu 16.04 LTS, and prior to 1.7.2-0ubuntu1.10 in Ubuntu 14.04 LTS.
- Record
EUVD-2018-18305- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-2f8v-v7q3-8gqv
8.8
The CUPS AppArmor profile incorrectly confined the dnssd backend due to use of hard links. A...
The CUPS AppArmor profile incorrectly confined the dnssd backend due to use of hard links. A local attacker could possibly use this issue to escape confinement. This flaw affects versions prior to 2.2.7-1ubuntu2.1 in Ubuntu 18.04 LTS, prior to 2.2.4-7ubuntu3.1 in Ubuntu 17.10, prior to 2.1.3-4ubuntu0.5 in Ubuntu 16.04 LTS, and prior to 1.7.2-0ubuntu1.10 in Ubuntu 14.04 LTS.
- Record
GHSA-2f8v-v7q3-8gqv- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
OSV
8.8
The CUPS AppArmor profile incorrectly confined the dnssd backend due to use of hard links. A local attacker could possibly use this issue to escape confinement. This flaw affects versions prior to 2.2.7-1ubuntu2.1 in Ubuntu 18.04 LTS, prior to 2.2.4-7ubuntu3.1 in Ubuntu 17.10, prior to 2.1.3-4ubuntu0.5 in Ubuntu 16.04 LTS, and prior to 1.7.2-0ubuntu1.10 in Ubuntu 14.04 LTS.
- Record
CVE-2018-6553- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-6553
8.8
The CUPS AppArmor profile incorrectly confined the dnssd backend due to use of hard links. A local attacker could possibly use this issue to escape confinement. This flaw affects versions prior to 2.2.7-1ubuntu2.1 in Ubuntu 18.04 LTS, prior to 2.2.4-7ubuntu3.1 in Ubuntu 17.10, prior to 2.1.3-4ubuntu0.5 in Ubuntu 16.04 LTS, and prior to 1.7.2-0ubuntu1.10 in Ubuntu 14.04 LTS.
- Record
DEBIAN-CVE-2018-6553- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-6553
8.8
The CUPS AppArmor profile incorrectly confined the dnssd backend due to use of hard links. A local attacker could possibly use this issue to escape confinement. This flaw affects versions prior to 2.2.7-1ubuntu2.1 in Ubuntu 18.04 LTS, prior to 2.2.4-7ubuntu3.1 in Ubuntu 17.10, prior to 2.1.3-4ubuntu0.5 in Ubuntu 16.04 LTS, and prior to 1.7.2-0ubuntu1.10 in Ubuntu 14.04 LTS.
- Record
UBUNTU-CVE-2018-6553- CVSS 3.0
- 8.8 High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-3713-1 No score
cups vulnerabilities
It was discovered that CUPS incorrectly handled certain print jobs with invalid usernames. A remote attacker could possibly use this issue to cause CUPS to crash, resulting in a denial of service. This issue only affected Ubuntu 14.04 LTS, Ubuntu 17.10 and Ubuntu 18.04 LTS. (CVE-2017-18248)
Dan Bastone discovered that the CUPS dnssd backend incorrectly handled certain environment variables. A local attacker could possibly use this issue to escalate privileges. (CVE-2018-4180)
Eric Rafaloff and John Dunlap discovered that CUPS incorrectly handled certain include directives. A local attacker could possibly use this issue to read arbitrary files. (CVE-2018-4181)
Dan Bastone discovered that the CUPS AppArmor profile incorrectly confined the dnssd backend. A local attacker could possibly use this issue to escape confinement. (CVE-2018-6553)
- Record
USN-3713-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
cupsDebian:12 |
before 2.2.8-5 | 2.2.8-5 |
cupsDebian:13 |
before 2.2.8-5 | 2.2.8-5 |
cupsDebian:14 |
before 2.2.8-5 | 2.2.8-5 |
cupsDebian:8 |
before 1.7.5-11+deb8u4, plus listed versions 1.7.5-111.7.5-11+deb8u11.7.5-11+deb8u21.7.5-11+deb8u3 |
1.7.5-11+deb8u4 |
cupsDebian:9 |
before 2.2.1-8+deb9u2, plus listed versions 2.2.1-82.2.1-8+deb9u12.2.1-8+deb9u1~bpo8+1 |
2.2.1-8+deb9u2 |
cupsUbuntu:14.04:LTS |
before 1.7.2-0ubuntu1.10, plus listed versions 1.7.0~rc1-0ubuntu51.7.0-0ubuntu21.7.0-0ubuntu31.7.0-11.7.0-2 Show 24 moreShow less1.7.1-11.7.1-21.7.1-2git11.7.1-31.7.1-41.7.1-4ubuntu11.7.1-5ubuntu11.7.1-5ubuntu31.7.1-5ubuntu41.7.1-5ubuntu51.7.1-5ubuntu61.7.1-5ubuntu71.7.1-5ubuntu81.7.1-5ubuntu91.7.1-5ubuntu101.7.2-0ubuntu11.7.2-0ubuntu1.11.7.2-0ubuntu1.21.7.2-0ubuntu1.41.7.2-0ubuntu1.51.7.2-0ubuntu1.61.7.2-0ubuntu1.71.7.2-0ubuntu1.81.7.2-0ubuntu1.9 |
1.7.2-0ubuntu1.10 |
cupsUbuntu:16.04:LTS |
before 2.1.3-4ubuntu0.5, plus listed versions 2.1.0-4ubuntu32.1.0-52.1.0-62.1.0-6ubuntu12.1.0-7 Show 9 moreShow less2.1.2-12.1.2-22.1.3-12.1.3-1build12.1.3-32.1.3-42.1.3-4ubuntu0.22.1.3-4ubuntu0.32.1.3-4ubuntu0.4 |
2.1.3-4ubuntu0.5 |
cupsUbuntu:18.04:LTS |
before 2.2.7-1ubuntu2.1, plus listed versions 2.2.4-7ubuntu22.2.5-22.2.6-22.2.6-32.2.6-42.2.6-52.2.7-1ubuntu12.2.7-1ubuntu2 |
2.2.7-1ubuntu2.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, products | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-6553 is a high vulnerability (CVSS 8.8) in Cups, published July 11, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.39%, the 32nd percentile. Fixed in cups 2.2.8-5.