CVE-2018-6758
The uwsgi_expand_path function in core/utils.c in Unbit uWSGI through 2.0.15 has a stack-based...
The uwsgi_expand_path function in core/utils.c in Unbit uWSGI through 2.0.15 has a stack-based buffer overflow via a large directory length.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
The uwsgi_expand_path function in core/utils.c in Unbit uWSGI through 2.0.15 has a stack-based buffer overflow via a large directory length.
- Record
CVE-2018-6758- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-787
- Updated
- 2026-11-02
CVE List No score
The uwsgi_expand_path function in core/utils.c in Unbit uWSGI through 2.0.15 has a stack-based buffer overflow via a large directory length.
- Record
CVE-2018-6758- Updated
- 2026-11-02
EUVDEUVD-2018-18505 No score
The uwsgi_expand_path function in core/utils.c in Unbit uWSGI through 2.0.15 has a stack-based buffer overflow via a large directory length.
- Record
EUVD-2018-18505- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-gp37-5368-2566
9.8
The uwsgi_expand_path function in core/utils.c in Unbit uWSGI through 2.0.15 has a stack-based...
The uwsgi_expand_path function in core/utils.c in Unbit uWSGI through 2.0.15 has a stack-based buffer overflow via a large directory length.
- Record
GHSA-gp37-5368-2566- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
OSVALPINE-CVE-2018-6758
9.8
The uwsgi_expand_path function in core/utils.c in Unbit uWSGI through 2.0.15 has a stack-based buffer overflow via a large directory length.
- Record
ALPINE-CVE-2018-6758- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVBELL-CVE-2018-6758
9.8
CVE-2018-6758 does not affect BellSoft software
- Record
BELL-CVE-2018-6758- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 4 moreShow less
OSV
9.8
The uwsgi_expand_path function in core/utils.c in Unbit uWSGI through 2.0.15 has a stack-based buffer overflow via a large directory length.
- Record
CVE-2018-6758- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-6758
9.8
The uwsgi_expand_path function in core/utils.c in Unbit uWSGI through 2.0.15 has a stack-based buffer overflow via a large directory length.
- Record
DEBIAN-CVE-2018-6758- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-6758
9.8
The uwsgi_expand_path function in core/utils.c in Unbit uWSGI through 2.0.15 has a stack-based buffer overflow via a large directory length.
- Record
UBUNTU-CVE-2018-6758- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVopenSUSE-SU-2024:11490-1 No score
apache2-mod_uwsgi-2.0.19.1-3.10 on GA media
These are all security issues fixed in the apache2-mod_uwsgi-2.0.19.1-3.10 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:11490-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
uwsgiAlpine:v3.10 |
before 2.0.16-r0 | 2.0.16-r0 |
uwsgiAlpine:v3.11 |
before 2.0.16-r0 | 2.0.16-r0 |
uwsgiAlpine:v3.12 |
before 2.0.16-r0 | 2.0.16-r0 |
uwsgiAlpine:v3.13 |
before 2.0.16-r0 | 2.0.16-r0 |
uwsgiAlpine:v3.14 |
before 2.0.16-r0 | 2.0.16-r0 |
uwsgiAlpine:v3.15 |
before 2.0.16-r0 | 2.0.16-r0 |
uwsgiAlpine:v3.16 |
before 2.0.16-r0 | 2.0.16-r0 |
uwsgiAlpine:v3.17 |
before 2.0.16-r0 | 2.0.16-r0 |
uwsgiAlpine:v3.18 |
before 2.0.16-r0 | 2.0.16-r0 |
uwsgiAlpine:v3.19 |
before 2.0.16-r0 | 2.0.16-r0 |
Show 18 moreShow less
| Package | Affected | Fixed |
|---|---|---|
uwsgiAlpine:v3.20 |
before 2.0.16-r0 | 2.0.16-r0 |
uwsgiAlpine:v3.21 |
before 2.0.16-r0 | 2.0.16-r0 |
uwsgiAlpine:v3.22 |
before 2.0.16-r0 | 2.0.16-r0 |
uwsgiAlpine:v3.23 |
before 2.0.16-r0 | 2.0.16-r0 |
uwsgiAlpine:v3.24 |
before 2.0.16-r0 | 2.0.16-r0 |
uwsgiAlpine:v3.4 |
before 2.0.16-r0 | 2.0.16-r0 |
uwsgiAlpine:v3.5 |
before 2.0.16-r0 | 2.0.16-r0 |
uwsgiAlpine:v3.6 |
before 2.0.16-r0 | 2.0.16-r0 |
uwsgiAlpine:v3.7 |
before 2.0.16-r0 | 2.0.16-r0 |
uwsgiAlpine:v3.8 |
before 2.0.16-r0 | 2.0.16-r0 |
uwsgiAlpine:v3.9 |
before 2.0.16-r0 | 2.0.16-r0 |
uwsgiDebian:12 |
before 2.0.15-10.2 | 2.0.15-10.2 |
uwsgiDebian:13 |
before 2.0.15-10.2 | 2.0.15-10.2 |
uwsgiDebian:14 |
before 2.0.15-10.2 | 2.0.15-10.2 |
uwsgiDebian:7 |
before 1.2.3+dfsg-5+deb7u2, plus listed versions 1.2.3+dfsg-51.2.3+dfsg-5+deb7u1 |
1.2.3+dfsg-5+deb7u2 |
uwsgiUbuntu:14.04:LTS |
before 1.9.17.1-5ubuntu0.1, plus listed versions 1.9.13-4build11.9.17.1-51.9.17.1-5build21.9.17.1-5build41.9.17.1-5build5 |
1.9.17.1-5ubuntu0.1 |
uwsgiUbuntu:16.04:LTS |
before 2.0.12-5ubuntu3.2, plus listed versions 2.0.7-1ubuntu52.0.7-1ubuntu62.0.11.2-6ubuntu12.0.11.2-6ubuntu22.0.12-4ubuntu2 Show 4 moreShow less2.0.12-5ubuntu12.0.12-5ubuntu22.0.12-5ubuntu32.0.12-5ubuntu3.1 |
2.0.12-5ubuntu3.2 |
uwsgiopenSUSE:Tumbleweed |
before 2.0.19.1-3.10 | 2.0.19.1-3.10 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-6758 is a critical vulnerability (CVSS 9.8) in Unbit Uwsgi, published February 6, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.05%, the 81st percentile. Fixed in uwsgi 2.0.16-r0.
References
lists.debian.org/debian-lts-announce/2018/02/msg00010.html
lists.unbit.it/pipermail/uwsgi/2018-February/008835.html
github.com/unbit/uwsgi/commit/cb4636f7c0af2e97a4eef7a3cdcbd85a71247bfe
nvd.nist.gov/vuln/detail/CVE-2018-6758
github.com/advisories/GHSA-gp37-5368-2566
security.alpinelinux.org/vuln/CVE-2018-6758