Every CVE Search/ Get API key

CVE-2018-7557

The decode_init function in libavcodec/utvideodec.c in FFmpeg 2.8 through 3.4.2 allows remote...

6.5 MediumFix available

CVE-2018-7557 is a medium vulnerability (CVSS 6.5) in Ffmpeg, published February 28, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.89%, the 79th percentile. Fixed in ffmpeg 3.4.3-r0.

The decode_init function in libavcodec/utvideodec.c in FFmpeg 2.8 through 3.4.2 allows remote attackers to cause a denial of service (Out of array read) via an AVI file with crafted dimensions within chroma subsampling data.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.89%Down 0.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.5

The decode_init function in libavcodec/utvideodec.c in FFmpeg 2.8 through 3.4.2 allows remote attackers to cause a denial of service (Out of array read) via an AVI file with crafted dimensions within chroma subsampling data.

Record
CVE-2018-7557
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

The decode_init function in libavcodec/utvideodec.c in FFmpeg 2.8 through 3.4.2 allows remote attackers to cause a denial of service (Out of array read) via an AVI file with crafted dimensions within chroma subsampling data.

Record
CVE-2018-7557
Updated
2026-11-02
EUVDEUVD-2018-19284 No score

The decode_init function in libavcodec/utvideodec.c in FFmpeg 2.8 through 3.4.2 allows remote attackers to cause a denial of service (Out of array read) via an AVI file with crafted dimensions within chroma subsampling data.

Record
EUVD-2018-19284
Updated
2026-11-03
GitHub AdvisoriesGHSA-6wh2-f463-c2vf 6.5

The decode_init function in libavcodec/utvideodec.c in FFmpeg 2.8 through 3.4.2 allows remote...

The decode_init function in libavcodec/utvideodec.c in FFmpeg 2.8 through 3.4.2 allows remote attackers to cause a denial of service (Out of array read) via an AVI file with crafted dimensions within chroma subsampling data.

Record
GHSA-6wh2-f463-c2vf
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSVALPINE-CVE-2018-7557 6.5

The decode_init function in libavcodec/utvideodec.c in FFmpeg 2.8 through 3.4.2 allows remote attackers to cause a denial of service (Out of array read) via an AVI file with crafted dimensions within chroma subsampling data.

Record
ALPINE-CVE-2018-7557
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSV 6.5

The decode_init function in libavcodec/utvideodec.c in FFmpeg 2.8 through 3.4.2 allows remote attackers to cause a denial of service (Out of array read) via an AVI file with crafted dimensions within chroma subsampling data.

Record
CVE-2018-7557
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2018-7557 6.5

The decode_init function in libavcodec/utvideodec.c in FFmpeg 2.8 through 3.4.2 allows remote attackers to cause a denial of service (Out of array read) via an AVI file with crafted dimensions within chroma subsampling data.

Record
DEBIAN-CVE-2018-7557
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2018-7557 6.5

The decode_init function in libavcodec/utvideodec.c in FFmpeg 2.8 through 3.4.2 allows remote attackers to cause a denial of service (Out of array read) via an AVI file with crafted dimensions within chroma subsampling data.

Record
UBUNTU-CVE-2018-7557
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 3.0
6.5 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2018-0319 No score

Updated ffmpeg packages fix security vulnerabilities

This update provides ffmpeg version 3.3.8, which fixes several security vulnerabilities and other bugs which were corrected upstream.

Record
MGASA-2018-0319
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ffmpeg
Alpine:v3.10
2.8 up to 3.4.3-r0
3.4.3-r0
ffmpeg
Alpine:v3.11
2.8 up to 3.4.3-r0
3.4.3-r0
ffmpeg
Alpine:v3.12
2.8 up to 3.4.3-r0
3.4.3-r0
ffmpeg
Alpine:v3.13
2.8 up to 3.4.3-r0
3.4.3-r0
ffmpeg
Alpine:v3.14
2.8 up to 3.4.3-r0
3.4.3-r0
ffmpeg
Alpine:v3.15
2.8 up to 3.4.3-r0
3.4.3-r0
ffmpeg
Alpine:v3.16
2.8 up to 3.4.3-r0
3.4.3-r0
ffmpeg
Alpine:v3.17
2.8 up to 3.4.3-r0
3.4.3-r0
ffmpeg
Alpine:v3.18
2.8 up to 3.4.3-r0
3.4.3-r0
ffmpeg
Alpine:v3.19
2.8 up to 3.4.3-r0
3.4.3-r0
Show 23 moreShow less
Affected packages
PackageAffectedFixed
ffmpeg
Alpine:v3.20
2.8 up to 3.4.3-r0
3.4.3-r0
ffmpeg
Alpine:v3.21
2.8 up to 3.4.3-r0
3.4.3-r0
ffmpeg
Alpine:v3.22
2.8 up to 3.4.3-r0
3.4.3-r0
ffmpeg
Alpine:v3.23
2.8 up to 3.4.3-r0
3.4.3-r0
ffmpeg
Alpine:v3.24
2.8 up to 3.4.3-r0
3.4.3-r0
ffmpeg
Alpine:v3.8
2.8 up to 3.4.3-r0
3.4.3-r0
ffmpeg
Alpine:v3.9
2.8 up to 3.4.3-r0
3.4.3-r0
ffmpeg4
Alpine:v3.16
before 3.4.3-r0
3.4.3-r0
ffmpeg4
Alpine:v3.17
before 3.4.3-r0
3.4.3-r0
ffmpeg4
Alpine:v3.18
before 3.4.3-r0
3.4.3-r0
ffmpeg4
Alpine:v3.19
before 3.4.3-r0
3.4.3-r0
ffmpeg4
Alpine:v3.20
before 3.4.3-r0
3.4.3-r0
ffmpeg4
Alpine:v3.21
before 3.4.3-r0
3.4.3-r0
ffmpeg4
Alpine:v3.22
before 3.4.3-r0
3.4.3-r0
ffmpeg
Debian:12
before 7:3.4.3-1
7:3.4.3-1
ffmpeg
Debian:13
before 7:3.4.3-1
7:3.4.3-1
ffmpeg
Debian:14
before 7:3.4.3-1
7:3.4.3-1
libav
Debian:8
before 6:11.12-1~deb8u4, plus listed versions
6:11.11-1~deb8u16:11.12-1~deb8u16:11.12-1~deb8u26:11.12-1~deb8u36:11.3-1
Show 11 moreShow less
6:11.3-1+deb8u16:11.3-26:11.3-36:11.4-16:11.4-1~deb8u16:11.4-26:11.4-2+x32.16:11.6-1~deb8u16:11.7-1~deb8u16:11.8-1~deb8u16:11.9-1~deb8u1
6:11.12-1~deb8u4
ffmpeg
Debian:9
before 7:3.2.11-1~deb9u1, plus listed versions
7:3.2.10-1~deb9u17:3.2.10-1~deb9u1~bpo8+17:3.2.5-17:3.2.6-17:3.2.7-1~deb9u17:3.2.8-1~deb9u17:3.2.9-1~deb9u1
7:3.2.11-1~deb9u1
ffmpeg
Mageia:6
before 3.3.8-1.mga6
3.3.8-1.mga6
ffmpeg
Mageia:6
before 3.3.8-1.mga6.tainted
3.3.8-1.mga6.tainted
ffmpeg
Ubuntu:16.04:LTS
before 7:2.8.15-0ubuntu0.16.04.1, plus listed versions
7:2.7.2-1build17:2.8.1-1ubuntu17:2.8.2-1ubuntu17:2.8.3-17:2.8.4-1
Show 10 moreShow less
7:2.8.4-1ubuntu17:2.8.4-1ubuntu27:2.8.4-1ubuntu37:2.8.4-1ubuntu47:2.8.6-1ubuntu17:2.8.6-1ubuntu27:2.8.8-0ubuntu0.16.04.17:2.8.10-0ubuntu0.16.04.17:2.8.11-0ubuntu0.16.04.17:2.8.14-0ubuntu0.16.04.1
7:2.8.15-0ubuntu0.16.04.1
ffmpeg
Ubuntu:18.04:LTS
before 7:3.4.4-0ubuntu0.18.04.1, plus listed versions
7:3.3.4-27:3.3.4-2build37:3.4-2ubuntu27:3.4-47:3.4-4build1
Show 5 moreShow less
7:3.4.1-17:3.4.1-1build17:3.4.2-17:3.4.2-1build17:3.4.2-2
7:3.4.4-0ubuntu0.18.04.1

History

History
WhenChangedSources
2026-11-03affected, aliases, referencesOSV
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 10 moreShow less
MoveEnter Open