CVE-2018-7711
SimpleSAMLphp saml2 incorrect signature validation
HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect check of return values in the signature validation utilities, allowing an attacker to get invalid signatures accepted as valid by forcing an error during validation. This occurs because of a dependency on PHP functionality that interprets a -1 error code as a true boolean value.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.1
HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect check of return values in the signature validation utilities, allowing an attacker to get invalid signatures accepted as valid by forcing an error during validation. This occurs because of a dependency on PHP functionality that interprets a -1 error code as a true boolean value.
- Record
CVE-2018-7711- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-347
- Updated
- 2026-11-02
CVE List No score
HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect check of return values in the signature validation utilities, allowing an attacker to get invalid signatures accepted as valid by forcing an error during validation. This occurs because of a dependency on PHP functionality that interprets a -1 error code as a true boolean value.
- Record
CVE-2018-7711- Updated
- 2026-11-02
EUVDEUVD-2022-3924 No score
HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect check of return values in the signature validation utilities, allowing an attacker to get invalid signatures accepted as valid by forcing an error during validation. This occurs because of a dependency on PHP functionality that interprets a -1 error code as a true boolean value.
- Record
EUVD-2022-3924- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-g888-g2pp-82hf
8.1
SimpleSAMLphp saml2 incorrect signature validation
HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect check of return values in the signature validation utilities, allowing an attacker to get invalid signatures accepted as valid by forcing an error during validation. This occurs because of a dependency on PHP functionality that interprets a -1 error code as a true boolean value.
- Record
GHSA-g888-g2pp-82hf- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-347
- Updated
- 2026-11-02
OSV
8.1
HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect check of return values in the signature validation utilities, allowing an attacker to get invalid signatures accepted as valid by forcing an error during validation. This occurs because of a dependency on PHP functionality that interprets a -1 error code as a true boolean value.
- Record
CVE-2018-7711- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-7711
8.1
HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect check of return values in the signature validation utilities, allowing an attacker to get invalid signatures accepted as valid by forcing an error during validation. This occurs because of a dependency on PHP functionality that interprets a -1 error code as a true boolean value.
- Record
DEBIAN-CVE-2018-7711- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-g888-g2pp-82hf
8.1
SimpleSAMLphp saml2 incorrect signature validation
HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect check of return values in the signature validation utilities, allowing an attacker to get invalid signatures accepted as valid by forcing an error during validation. This occurs because of a dependency on PHP functionality that interprets a -1 error code as a true boolean value.
- Record
GHSA-g888-g2pp-82hf- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-347
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2018-7711
8.1
HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect check of return values in the signature validation utilities, allowing an attacker to get invalid signatures accepted as valid by forcing an error during validation. This occurs because of a dependency on PHP functionality that interprets a -1 error code as a true boolean value.
- Record
UBUNTU-CVE-2018-7711- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
simplesamlphp/saml2Packagist |
before 1.10.6 | 1.10.6 |
simplesamlphp/saml2Packagist |
2.0 up to 2.3.8 | 2.3.8 |
simplesamlphp/saml2Packagist |
3.0 up to 3.1.4 | 3.1.4 |
simplesamlphpDebian:12 |
before 1.15.4-1 | 1.15.4-1 |
simplesamlphpDebian:14 |
before 1.15.4-1, plus listed versions 1.10.0-11.11.0-11.12.0-11.12.0~rc1-11.12.0~rc2-1 Show 38 moreShow less1.13.0-11.13.1-11.13.1-21.13.2-11.14.0-11.14.1-11.14.10-11.14.11-11.14.15-11.14.2-11.14.2-21.14.3-11.14.4-11.14.5-11.14.6-11.14.7-11.14.8-11.14.9-11.15.0-11.15.1-11.15.2-11.15.3-11.6.0-11.6.1-11.6.2-11.6.3-11.6.3-21.6.3-31.7.0-11.7.0-21.8.0-11.8.1-11.8.2-11.9.0-11.9.0~rc1-11.9.0~rc2-11.9.1-11.9.2-1 |
1.15.4-1 |
simplesamlphpDebian:7 |
before 1.9.2-1+deb7u4, plus listed versions 1.9.2-11.9.2-1+deb7u11.9.2-1+deb7u21.9.2-1+deb7u3 |
1.9.2-1+deb7u4 |
simplesamlphp/saml2Packagist |
before 1.10.6, plus listed versions v0.1.0v0.1.0-alphav0.3.0v0.4.0v0.4.1 Show 40 moreShow lessv0.4.2v0.5.0v0.6.0v0.6.1v0.6.2v0.6.3v0.6.4v0.7.0v0.7.1v0.8.0v0.8.1v1.0.0v1.1.0v1.10v1.10.1v1.10.2v1.10.3v1.10.4v1.10.5v1.2.0v1.3.0v1.3.1v1.3.2v1.4.0v1.5.0v1.5.1v1.5.2v1.5.3v1.5.4v1.6.0v1.6.1v1.7.0v1.7.1v1.7.2v1.8v1.8.1v1.8.2v1.9v1.9.1v1.9.2 |
1.10.6 |
simplesamlphp/saml2Packagist |
2.0 up to 2.3.8, plus listed versions v2.0.0v2.0.1v2.1v2.2v2.3 Show 7 moreShow lessv2.3.1v2.3.2v2.3.3v2.3.4v2.3.5v2.3.6v2.3.7 |
2.3.8 |
simplesamlphp/saml2Packagist |
3.0 up to 3.1.4, plus listed versions v3.0.0v3.0.1v3.0.2v3.0.3v3.1.0v3.1.1v3.1.2v3.1.3 |
3.1.4 |
simplesamlphpUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 1.13.2-11.14.0-11.14.0-1ubuntu21.14.0-1ubuntu2+esm1 |
None known |
simplesamlphpUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 1.14.15-11.15.0-11.15.1-11.15.2-11.15.3-11.15.3-1ubuntu0.1~esm1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-7711 is a high vulnerability (CVSS 8.1) in Simplesamlphp Saml2, published March 5, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.19%, the 68th percentile. Fixed in simplesamlphp/saml2 1.10.6.
References
github.com/simplesamlphp/saml2/commit/4f6af7f69f29df8555a18b9bb7b646906b45924d
lists.debian.org/debian-lts-announce/2018/03/msg00017.html
simplesamlphp.org/security/201803-01
nvd.nist.gov/vuln/detail/CVE-2018-7711
github.com/FriendsOfPHP/security-advisories/blob/master/simplesamlphp/saml2/CVE-2018-7711.yaml
github.com/advisories/GHSA-g888-g2pp-82hf
security-tracker.debian.org/tracker/CVE-2018-7711
ubuntu.com/security/CVE-2018-7711
cve.org/CVERecord?id=CVE-2018-7711