CVE-2018-7729
An issue was discovered in Exempi through 2.4.4. There is a stack-based buffer over-read in the...
An issue was discovered in Exempi through 2.4.4. There is a stack-based buffer over-read in the PostScript_MetaHandler::ParsePSFile() function in XMPFiles/source/FileHandlers/PostScript_Handler.cpp.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
5.5
An issue was discovered in Exempi through 2.4.4. There is a stack-based buffer over-read in the PostScript_MetaHandler::ParsePSFile() function in XMPFiles/source/FileHandlers/PostScript_Handler.cpp.
- Record
CVE-2018-7729- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-125
- Updated
- 2026-11-02
CVE List No score
An issue was discovered in Exempi through 2.4.4. There is a stack-based buffer over-read in the PostScript_MetaHandler::ParsePSFile() function in XMPFiles/source/FileHandlers/PostScript_Handler.cpp.
- Record
CVE-2018-7729- Updated
- 2026-11-02
EUVDEUVD-2018-19444 No score
An issue was discovered in Exempi through 2.4.4. There is a stack-based buffer over-read in the PostScript_MetaHandler::ParsePSFile() function in XMPFiles/source/FileHandlers/PostScript_Handler.cpp.
- Record
EUVD-2018-19444- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qfmg-v7xj-8gxc
5.5
An issue was discovered in Exempi through 2.4.4. There is a stack-based buffer over-read in the...
An issue was discovered in Exempi through 2.4.4. There is a stack-based buffer over-read in the PostScript_MetaHandler::ParsePSFile() function in XMPFiles/source/FileHandlers/PostScript_Handler.cpp.
- Record
GHSA-qfmg-v7xj-8gxc- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-125
- Updated
- 2026-11-02
OSV
5.5
An issue was discovered in Exempi through 2.4.4. There is a stack-based buffer over-read in the PostScript_MetaHandler::ParsePSFile() function in XMPFiles/source/FileHandlers/PostScript_Handler.cpp.
- Record
CVE-2018-7729- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2018-7729
5.5
An issue was discovered in Exempi through 2.4.4. There is a stack-based buffer over-read in the PostScript_MetaHandler::ParsePSFile() function in XMPFiles/source/FileHandlers/PostScript_Handler.cpp.
- Record
DEBIAN-CVE-2018-7729- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Show 4 moreShow less
OSVUBUNTU-CVE-2018-7729
5.5
An issue was discovered in Exempi through 2.4.4. There is a stack-based buffer over-read in the PostScript_MetaHandler::ParsePSFile() function in XMPFiles/source/FileHandlers/PostScript_Handler.cpp.
- Record
UBUNTU-CVE-2018-7729- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVMGASA-2018-0239 No score
Updated exempi package fixes security vulnerabilities
An issue was discovered in Exempi through 2.4.4. There is a stack-based buffer over-read in the PostScript_MetaHandler::ParsePSFile() function in PostScript_Handler.cpp (CVE-2018-7729).
An issue was discovered in Exempi through 2.4.4. WEBP_Support.cpp does not check whether a bitstream has a NULL value, leading to a NULL pointer dereference in the WEBP::VP8XChunk class (CVE-2018-7731).
An issue was discovered in Exempi before 2.4.4. Integer overflow in the Chunk class in RIFF.cpp allows remote attackers to cause a denial of service (infinite loop) via crafted XMP data in a .avi file (CVE-2017-18233).
An issue was discovered in Exempi before 2.4.3. It allows remote attackers to cause a denial of service (invalid memcpy with resultant use-after-free) or possibly have unspecified other impact via a .pdf file containing JPEG data, related to ReconcileTIFF.cpp, TIFF_MemoryReader.cpp, and TIFF_Support.hpp (CVE-2017-18234).
An issue was discovered in Exempi before 2.4.3. The VPXChunk class in WEBP_Support.cpp does not ensure nonzero widths and heights, which allows remote attackers to cause a denial of service (assertion failure and application exit) via a crafted .webp file (CVE-2017-18235).
An issue was discovered in Exempi before 2.4.4. The ASF_Support::ReadHeaderObject function in ASF_Support.cpp allows remote attackers to cause a denial of service (infinite loop) via a crafted .asf file (CVE-2017-18236).
An issue was discovered in Exempi before 2.4.3. The PostScript_Support::ConvertToDate function in PostScript_Support.cpp allows remote attackers to cause a denial of service (invalid pointer dereference and application crash) via a crafted .ps file (CVE-2017-18237).
- Record
MGASA-2018-0239- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10745-1 No score
exempi-tools-2.5.2-1.3 on GA media
These are all security issues fixed in the exempi-tools-2.5.2-1.3 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10745-1- Updated
- 2026-11-02
OSVUSN-3668-1 No score
exempi vulnerabilities
It was discovered that Exempi incorrectly handled certain media files. If a user or automated system were tricked into opening a specially crafted file, a remote attacker could cause Exempi to hang or crash, resulting in a denial of service, or possibly execute arbitrary code.
- Record
USN-3668-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
exempiDebian:12 |
before 2.4.5-1 | 2.4.5-1 |
exempiDebian:13 |
before 2.4.5-1 | 2.4.5-1 |
exempiDebian:14 |
before 2.4.5-1 | 2.4.5-1 |
exempiMageia:6 |
before 2.4.5-1.mga6 | 2.4.5-1.mga6 |
exempiUbuntu:14.04:LTS |
before 2.2.1-1ubuntu1.1, plus listed versions 2.2.1-1ubuntu1 |
2.2.1-1ubuntu1.1 |
exempiUbuntu:16.04:LTS |
before 2.2.2-2ubuntu0.1, plus listed versions 2.2.2-2 |
2.2.2-2ubuntu0.1 |
exempiopenSUSE:Tumbleweed |
before 2.5.2-1.3 | 2.5.2-1.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2018-7729 is a medium vulnerability (CVSS 5.5) in Exempi Project Exempi, published March 6, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.23%, the 69th percentile. Fixed in exempi 2.4.5-1.
References
usn.ubuntu.com/3668-1
cgit.freedesktop.org/exempi/commit?id=baa4b8a02c1ffab9645d13f0bfb1c0d10d311a0c
bugs.freedesktop.org/show_bug.cgi?id=105206
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BCFXKOOATZ2B5G3G7EBXZWVZHEABN4ZV
nvd.nist.gov/vuln/detail/CVE-2018-7729
lists.fedoraproject.org/archives/list/[email protected]/message/BCFXKOOATZ2B5G3G7EBXZWVZHEABN4ZV
Show 21 moreShow less
github.com/advisories/GHSA-qfmg-v7xj-8gxc
security-tracker.debian.org/tracker/CVE-2018-7729
advisories.mageia.org/MGASA-2018-0239.html
bugs.mageia.org/show_bug.cgi?id=22871
lists.fedoraproject.org/archives/list/[email protected]/thread/ZTR7ZDRVKLKSI65QBRMJFDTW4EPRPZYH
lists.fedoraproject.org/archives/list/[email protected]/thread/H4PKNNGR3XYNB7B7BYNWTABCOPERDDLB
ubuntu.com/security/CVE-2018-7729
ubuntu.com/security/notices/USN-3668-1
cve.org/CVERecord?id=CVE-2018-7729
ubuntu.com/security/CVE-2017-18233
ubuntu.com/security/CVE-2017-18234
ubuntu.com/security/CVE-2017-18236
ubuntu.com/security/CVE-2017-18238
ubuntu.com/security/CVE-2018-7728
ubuntu.com/security/CVE-2018-7730
ubuntu.com/security/CVE-2018-7731
suse.com/security/cve/CVE-2018-12648
suse.com/security/cve/CVE-2018-7728
suse.com/security/cve/CVE-2018-7729
suse.com/security/cve/CVE-2018-7730
suse.com/security/cve/CVE-2018-7731