CVE-2018-8021
Deserialization of Untrusted Data in superset
CVE-2018-8021 is a critical vulnerability (CVSS 9.8) in Apache Superset, published November 7, 2018. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 53.4%, the 98th percentile. Fixed in superset 0.23.
Versions of Superset prior to 0.23 used an unsafe load method from the pickle library to deserialize data leading to possible remote code execution. Note Superset 0.23 was released prior to any Superset release under the Apache Software Foundation.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Versions of Superset prior to 0.23 used an unsafe load method from the pickle library to deserialize data leading to possible remote code execution. Note Superset 0.23 was released prior to any Superset release under the Apache Software Foundation.
- Record
CVE-2018-8021- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-502
- Updated
- 2026-11-02
CVE List No score
Versions of Superset prior to 0.23 used an unsafe load method from the pickle library to deserialize data leading to possible remote code execution. Note Superset 0.23 was released prior to any Superset release under the Apache Software Foundation.
- Record
CVE-2018-8021- Updated
- 2026-11-02
EUVDEUVD-2018-0137 No score
Versions of Superset prior to 0.23 used an unsafe load method from the pickle library to deserialize data leading to possible remote code execution. Note Superset 0.23 was released prior to any Superset release under the Apache Software Foundation.
- Record
EUVD-2018-0137- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-vxp9-wv2f-wqmw
9.3
Deserialization of Untrusted Data in superset
Versions of Superset prior to 0.23 used an unsafe load method from the pickle library to deserialize data leading to possible remote code execution. Note Superset 0.23 was released prior to any Superset release under the Apache Software Foundation.
- Record
GHSA-vxp9-wv2f-wqmw- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-502
- Updated
- 2026-11-02
OSV
9.8
Versions of Superset prior to 0.23 used an unsafe load method from the pickle library to deserialize data leading to possible remote code execution. Note Superset 0.23 was released prior to any Superset release under the Apache Software Foundation.
- Record
CVE-2018-8021- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-vxp9-wv2f-wqmw
9.3
Deserialization of Untrusted Data in superset
Versions of Superset prior to 0.23 used an unsafe load method from the pickle library to deserialize data leading to possible remote code execution. Note Superset 0.23 was released prior to any Superset release under the Apache Software Foundation.
- Record
GHSA-vxp9-wv2f-wqmw- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-502
- Updated
- 2026-11-02
OSVPYSEC-2018-74 No score
Versions of Superset prior to 0.23 used an unsafe load method from the pickle library to deserialize data leading to possible remote code execution. Note Superset 0.23 was released prior to any Superset release under the Apache Software Foundation.
- Record
PYSEC-2018-74- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
supersetPyPI |
before 0.23 | 0.23 |
supersetPyPI |
before 0.23, plus listed versions 0.13.20.14.00.14.10.15.00.15.1 Show 27 moreShow less0.15.30.15.40.17.00.17.10.17.20.17.30.17.40.17.50.17.60.18.00.18.20.18.30.18.40.18.50.19.00.19.10.20.00.20.10.20.20.20.30.20.40.20.50.20.60.21.00.21.10.22.00.22.1 |
0.23 |
supersetPyPI |
before 0.23.0, plus listed versions 0.13.20.14.00.14.10.15.00.15.1 Show 27 moreShow less0.15.30.15.40.17.00.17.10.17.20.17.30.17.40.17.50.17.60.18.00.18.20.18.30.18.40.18.50.19.00.19.10.20.00.20.10.20.20.20.30.20.40.20.50.20.60.21.00.21.10.22.00.22.1 |
0.23.0 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | Apache Superset < 0.23 - Remote Code Execution | 2018-12-03 |
| PoC in GitHub | r3dxpl0it/Apache-Superset-Remote-Code-Execution-PoC-CVE-2018-8021 | 2018-12-02 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV, PoC in GitHub |
References
exploit-db.com/exploits/45933
github.com/apache/incubator-superset/pull/4243
nvd.nist.gov/vuln/detail/CVE-2018-8021
github.com/apache/superset/pull/4243
github.com/apache/superset/commit/2c72a7ae4fc0a8bac1f037a79efa90e1c5549710
github.com/advisories/GHSA-vxp9-wv2f-wqmw
github.com/pypa/advisory-database/tree/main/vulns/superset/PYSEC-2018-74.yaml
github.com/apache/superset