Every CVE Search/ Get API key

CVE-2018-8027

Apache is vulnerable to XXE in XSD validation processor

9.8 CriticalFix available

Apache Camel 2.20.0 to 2.20.3 and 2.21.0 Core is vulnerable to XXE in XSD validation processor.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

5.45%Up 1.8 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

Apache Camel 2.20.0 to 2.20.3 and 2.21.0 Core is vulnerable to XXE in XSD validation processor.

Record
CVE-2018-8027
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-611
Updated
2026-11-02
CVE List No score

Apache Camel 2.20.0 to 2.20.3 and 2.21.0 Core is vulnerable to XXE in XSD validation processor.

Record
CVE-2018-8027
Updated
2026-11-02
EUVDEUVD-2018-0555 No score

Apache Camel 2.20.0 to 2.20.3 and 2.21.0 Core is vulnerable to XXE in XSD validation processor.

Record
EUVD-2018-0555
Updated
2026-11-03
GitHub AdvisoriesGHSA-8vfm-4388-6rpc 9.8

Apache is vulnerable to XXE in XSD validation processor

Apache Camel 2.20.0 to 2.20.3 and 2.21.0 Core is vulnerable to XXE in XSD validation processor.

Record
GHSA-8vfm-4388-6rpc
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-611
Updated
2026-11-02
OSV 9.8

Apache Camel 2.20.0 to 2.20.3 and 2.21.0 Core is vulnerable to XXE in XSD validation processor.

Record
CVE-2018-8027
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-8vfm-4388-6rpc 9.8

Apache is vulnerable to XXE in XSD validation processor

Apache Camel 2.20.0 to 2.20.3 and 2.21.0 Core is vulnerable to XXE in XSD validation processor.

Record
GHSA-8vfm-4388-6rpc
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-611
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.camel:camel-core
Maven
2.20.0 up to 2.20.4
2.20.4
org.apache.camel:camel-core
Maven
2.21.0 to 2.21.0
2.21.1
org.apache.camel:camel-core
Maven
2.20.0 up to 2.20.4, plus listed versions
2.20.12.20.22.20.3
2.20.4
org.apache.camel:camel-core
Maven
2.21.0 up to 2.21.1
2.21.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-8027 is a critical vulnerability (CVSS 9.8) in Apache Camel, published July 31, 2018. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.45%, the 92nd percentile. Fixed in org.apache.camel:camel-core 2.20.4.

References

Show 19 moreShow less
MoveEnter Open