Every CVE Search/ Get API key

CVE-2018-8029

Privilege escalation vulnerability in Apache Hadoop

8.8 HighFix available

In Apache Hadoop versions 3.0.0-alpha1 to 3.1.0, 2.9.0 to 2.9.1, and 2.2.0 to 2.8.4, a user who can escalate to yarn user can possibly run arbitrary commands as root user.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

3.91%Down 1.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

In Apache Hadoop versions 3.0.0-alpha1 to 3.1.0, 2.9.0 to 2.9.1, and 2.2.0 to 2.8.4, a user who can escalate to yarn user can possibly run arbitrary commands as root user.

Record
CVE-2018-8029
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
9.0 HighAV:N/AC:L/Au:S/C:C/I:C/A:C
Updated
2026-11-02
CVE List No score

In Apache Hadoop versions 3.0.0-alpha1 to 3.1.0, 2.9.0 to 2.9.1, and 2.2.0 to 2.8.4, a user who can escalate to yarn user can possibly run arbitrary commands as root user.

Record
CVE-2018-8029
Updated
2026-11-02
EUVDEUVD-2019-0447 No score

In Apache Hadoop versions 3.0.0-alpha1 to 3.1.0, 2.9.0 to 2.9.1, and 2.2.0 to 2.8.4, a user who can escalate to yarn user can possibly run arbitrary commands as root user.

Record
EUVD-2019-0447
Updated
2026-11-03
GitHub AdvisoriesGHSA-37pw-qw47-4jxm 8.8

Privilege escalation vulnerability in Apache Hadoop

In Apache Hadoop versions 3.0.0-alpha1 to 3.1.0, 2.9.0 to 2.9.1, and 2.2.0 to 2.8.4, a user who can escalate to yarn user can possibly run arbitrary commands as root user.

Record
GHSA-37pw-qw47-4jxm
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-285
Updated
2026-11-02
OSV 8.8

In Apache Hadoop versions 3.0.0-alpha1 to 3.1.0, 2.9.0 to 2.9.1, and 2.2.0 to 2.8.4, a user who can escalate to yarn user can possibly run arbitrary commands as root user.

Record
CVE-2018-8029
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-37pw-qw47-4jxm 8.8

Privilege escalation vulnerability in Apache Hadoop

In Apache Hadoop versions 3.0.0-alpha1 to 3.1.0, 2.9.0 to 2.9.1, and 2.2.0 to 2.8.4, a user who can escalate to yarn user can possibly run arbitrary commands as root user.

Record
GHSA-37pw-qw47-4jxm
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-285
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.apache.hadoop:hadoop-main
Maven
2.2.0 up to 2.8.4
2.8.4
org.apache.hadoop:hadoop-main
Maven
2.9.0 up to 2.9.2
2.9.2
org.apache.hadoop:hadoop-main
Maven
3.0.0 up to 3.1.1
3.1.1
org.apache.hadoop:hadoop-main
Maven
2.2.0 up to 2.8.4, plus listed versions
2.3.02.4.02.4.12.5.02.5.1
Show 19 moreShow less
2.5.22.6.02.6.12.6.22.6.32.6.42.6.52.7.02.7.12.7.22.7.32.7.42.7.52.7.62.7.72.8.02.8.12.8.22.8.3
2.8.4
org.apache.hadoop:hadoop-main
Maven
2.9.0 up to 2.9.2, plus listed versions
2.9.1
2.9.2
org.apache.hadoop:hadoop-main
Maven
3.0.0 up to 3.1.1, plus listed versions
3.0.13.0.23.0.33.1.0
3.1.1

History

History
RecordedChangedSources
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2018-8029 is a high vulnerability (CVSS 8.8) in Apache Hadoop, published May 30, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.91%, the 90th percentile. Fixed in org.apache.hadoop:hadoop-main 2.8.4.

References

Show 10 moreShow less
MoveEnter Open